Jump to content

Since the last two updates, I cannot make or add to a collection as a user.


estranged2000
 Share

Recommended Posts

estranged2000

Hello Community,

I  was hoping someone else is having a similar problem and perhaps know the reason why after the second to last update of Emby, my collections vanished (both user created, and those generated by the box set plugin). At first I thought it had to be ownership/permissions had become muddled, but all other writes are allowed (updates to metadata, metadata refreshes on intervals, favourites) 

 

Here is a breakdown of my formerly working setup:

Emby running on Docker - app folder in home directory to utilize the SSD benefit.

OS: Fedora 33 - kept up to date daily

Docker image is from Linuxserver.io (I chose that image to keep things in line with my other services, and ease of setup

Permissions are defined in the docker-compose file for PGID:1000 (logged user) and GUID:973 (docker) however i've also tried chowning the permissions to 1000:1000 in both the .yaml file and filesystem in keeping with linuxserver.io's standard setups.. No joy as of yet..

I'm copying a backup of the emby appdata folder to backup in an attempt to start fresh, if that doesn't work i'll restore and hope that either emby, or the image provider figures it out.

One thing worth noting, while I can't make a collection, the Boxset plugin CAN, and I can add and remove from them, if I try to create my own it circles out.

I'd really prefer to keep my watched status. not so much for me, but my elderly parents (also my main reason for fighting with collections, so I can narrow down content for them) so I was wondering if the community can :

1) Diagnose what might have happened to either the config or the docker image (last two versions, first time lost all collections, I tried backing up the collections folder and starting new, no joy.

or

2) If I create a new instance, which folders to keep so my 2 users keep their watched status. I don't mind rescanning metadata and tailoring the layout again.

Any help would be appreciated, I hope I gave the community enough information, so as to not waste your time.

Thank You,

Ray.

Link to comment
Share on other sites

Hi there, what Emby update are you referring to? What version are you running now?

Link to comment
Share on other sites

  • 4 weeks later...
Endymion
Posted (edited)

I had a similar issue come up a few updates back, too. My collections disappear. Then it seemed it was rebuilt... minus a couple. It wasn't a big deal at the time, so I just let it be. I just recently went investigate the issue and noticed the missing collection folders was still in the Collections directory, but was not showing up in the Collections UI. I noticed the folder names did not match the name in the xml file. Once I corrected that, the issue was resolved.

So, check to see if folder names (minus the '[box set]" at the end... that should be there in folder name) and the name in the xml file match. That solved my issue... hope it helps.

Edited by Endymion
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...