Jump to content

I cannot seem to play a certain tv show.


milpat
 Share

Go to solution Solved by Luke,

Recommended Posts

Just now, vdatanet said:

I see a lot of errors:


System.IO.DirectoryNotFoundException: System.IO.DirectoryNotFoundException

But I don't think they are relevant to this issue. I also can't find any play attempt in that log.

what does that mean and ill attach an older one 

embyserver-63734215351.txt

Link to comment
Share on other sites

Happy2Play

Your first server log would appear to show a issue with the J drive.  What is your J drive?

2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\1Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\My_Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\TV SHOWS because the path does not exist

 

45 minutes ago, milpat said:

what does that mean and ill attach an older one 

embyserver-63734215351.txt 12.54 kB · 1 download

This log would appear to show Emby is already running and this instance is shutting down do to the Database being locked.

Link to comment
Share on other sites

Just now, Happy2Play said:

Your first server log would appear to show a issue with the J drive.  What is your J drive?


2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\1Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\My_Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\TV SHOWS because the path does not exist

 

This log would appear to show Emby is already running and this instance is shutting down do to the Database being locked.

my J drive is the My Passport Ultra 2tb that i am using to host the server

Link to comment
Share on other sites

Happy2Play

Emby is having issues with the libraries you have via that drive, the only library that would appear to be working is your Z:\Movies HDD FAST.

Link to comment
Share on other sites

3 minutes ago, Happy2Play said:

Emby is having issues with the libraries you have via that drive, the only library that would appear to be working is your Z:\Movies HDD FAST.

what do you mean by trouble - the Z:/ is a internal drive in the PC. i can play everything fine on the J:/ libraries. 

Edited by milpat
Link to comment
Share on other sites

2 minutes ago, Happy2Play said:

Emby is having issues with the libraries you have via that drive, the only library that would appear to be working is your Z:\Movies HDD FAST.

also what external HDD do you suggest to get space around 4 or 8TB

Link to comment
Share on other sites

Happy2Play
4 minutes ago, milpat said:

what do you mean by trouble - the Z:/ is a internal drive in the PC.

I do not know exactly but your log is full of "System.IO.DirectoryNotFoundException: System.IO.DirectoryNotFoundException: Could not find a part of the path" to those paths on the J drive.

2020-08-29 11:09:30.114 Error App: Error in GetFilteredFileSystemEntries isPhysicalRoot: False IsVf: False
	*** Error Report ***
	Version: 4.4.3.0
	Command line: C:\Users\S\AppData\Roaming\Emby-Server\system\EmbyServer.dll
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///C:/Users/S/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	System.Environment.Version: 3.1.4
	Processor count: 4
	Program data path: C:\Users\S\AppData\Roaming\Emby-Server\programdata
	Application directory: C:\Users\S\AppData\Roaming\Emby-Server\system
	System.IO.DirectoryNotFoundException: System.IO.DirectoryNotFoundException: Could not find a part of the path 'J:\TV SHOWS'.
	   at System.IO.Enumeration.FileSystemEnumerator`1.CreateDirectoryHandle(String path, Boolean ignoreNotFound)
	   at System.IO.Enumeration.FileSystemEnumerator`1.Init()
	   at System.IO.Enumeration.FileSystemEnumerable`1..ctor(String directory, FindTransform transform, EnumerationOptions options, Boolean isNormalized)
	   at System.IO.Enumeration.FileSystemEnumerableFactory.FileSystemInfos(String directory, String expression, EnumerationOptions options, Boolean isNormalized)
	   at System.IO.DirectoryInfo.InternalEnumerateInfos(String path, String searchPattern, SearchTarget searchTarget, EnumerationOptions options)
	   at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileSystemEntries(String path, Boolean recursive)
	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)
	   at MediaBrowser.Controller.IO.FileData.GetFilteredFileSystemEntries(IDirectoryService directoryService, String path, IFileSystem fileSystem, IServerApplicationHost appHost, ILogger logger, ItemResolveArgs args, Int32 flattenFolderDepth, Boolean resolveShortcuts)
	   at Emby.Server.Implementations.Library.LibraryManager.ResolvePath(FileSystemMetadata fileInfo, IDirectoryService directoryService, IItemResolver[] resolvers, Folder parent, LibraryOptions libraryOptions)
	Source: System.IO.FileSystem
	TargetSite: IntPtr CreateDirectoryHandle(System.String, Boolean)

@Luke would this just be the external drive being spun down/offline?  log snippet for this post.

Link to comment
Share on other sites

3 minutes ago, Happy2Play said:

Emby is having issues with the libraries you have via that drive, the only library that would appear to be working is your Z:\Movies HDD FAST.

 

Just now, Happy2Play said:

I do not know exactly but your log is full of "System.IO.DirectoryNotFoundException: System.IO.DirectoryNotFoundException: Could not find a part of the path" to those paths on the J drive.


2020-08-29 11:09:30.114 Error App: Error in GetFilteredFileSystemEntries isPhysicalRoot: False IsVf: False
	*** Error Report ***
	Version: 4.4.3.0
	Command line: C:\Users\S\AppData\Roaming\Emby-Server\system\EmbyServer.dll
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///C:/Users/S/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	System.Environment.Version: 3.1.4
	Processor count: 4
	Program data path: C:\Users\S\AppData\Roaming\Emby-Server\programdata
	Application directory: C:\Users\S\AppData\Roaming\Emby-Server\system
	System.IO.DirectoryNotFoundException: System.IO.DirectoryNotFoundException: Could not find a part of the path 'J:\TV SHOWS'.
	   at System.IO.Enumeration.FileSystemEnumerator`1.CreateDirectoryHandle(String path, Boolean ignoreNotFound)
	   at System.IO.Enumeration.FileSystemEnumerator`1.Init()
	   at System.IO.Enumeration.FileSystemEnumerable`1..ctor(String directory, FindTransform transform, EnumerationOptions options, Boolean isNormalized)
	   at System.IO.Enumeration.FileSystemEnumerableFactory.FileSystemInfos(String directory, String expression, EnumerationOptions options, Boolean isNormalized)
	   at System.IO.DirectoryInfo.InternalEnumerateInfos(String path, String searchPattern, SearchTarget searchTarget, EnumerationOptions options)
	   at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileSystemEntries(String path, Boolean recursive)
	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)
	   at MediaBrowser.Controller.IO.FileData.GetFilteredFileSystemEntries(IDirectoryService directoryService, String path, IFileSystem fileSystem, IServerApplicationHost appHost, ILogger logger, ItemResolveArgs args, Int32 flattenFolderDepth, Boolean resolveShortcuts)
	   at Emby.Server.Implementations.Library.LibraryManager.ResolvePath(FileSystemMetadata fileInfo, IDirectoryService directoryService, IItemResolver[] resolvers, Folder parent, LibraryOptions libraryOptions)
	Source: System.IO.FileSystem
	TargetSite: IntPtr CreateDirectoryHandle(System.String, Boolean)

@Luke would this just be the external drive being spun down/offline?  log snippet for this post.

i think i may know a problem - is it because the file path is long?

Link to comment
Share on other sites

Hi,

Check the paths to make sure they exist and also the permissions for the user running EmbyServer.

Link to comment
Share on other sites

Just now, cayars said:

Hi,

Check the paths to make sure they exist and also the permissions for the user running EmbyServer.

the user running emby is a admin (S) is that what you mean? and what do you mean by paths exist?

Link to comment
Share on other sites

2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\1Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\My_Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\TV SHOWS because the path does not exist
Link to comment
Share on other sites

Happy2Play

Also with it being a External drive is it maintaining the same drive letter?  But this should be irrelevant to this topic though.

4 minutes ago, milpat said:

think i may know a problem - is it because the file path is long?

Why would you think path is long "J:\TV SHOWS"?

Link to comment
Share on other sites

vdatanet
Just now, cayars said:

2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\1Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\My_Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\TV SHOWS because the path does not exist

Are you sure the drive is connected to the computer? Drive letter is still J?

Link to comment
Share on other sites

1 minute ago, cayars said:

2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\1Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\My_Movies because the path does not exist
2020-08-29 11:09:35.291 Info LibraryMonitor: Skipping realtime monitor for J:\TV SHOWS because the path does not exist

I think i know of the problem - i unplugged it at the time because of adding new movies via another pc.

Link to comment
Share on other sites

1 minute ago, Happy2Play said:

Also with it being a External drive is it maintaining the same drive letter?  But this should be irrelevant to this topic though.

Why would you think path is long "J:\TV SHOWS"?

I was talking about a movie path like the full length

Link to comment
Share on other sites

vdatanet

I think this is another problem unrelated to yesterday's problem. The drive is not connected.

Link to comment
Share on other sites

Just now, vdatanet said:

I think this is another problem unrelated to yesterday's problem. The drive is not connected.

correct how can we fix yesterday's problem.

Link to comment
Share on other sites

Just now, vdatanet said:

When the drive is connected, play the item and send the server log again.

play the item on phone or on server?

Link to comment
Share on other sites

Happy2Play

Is there a ffmpeg log created when you attempt to play a item on your phone?

Link to comment
Share on other sites

Just now, Happy2Play said:

Is there a ffmpeg log created when you attempt to play a item on your phone?

probably but ill get a new one now. 

Link to comment
Share on other sites

Happy2Play
Just now, milpat said:

play the item on phone or on server?

You have no problems playing items on the server correct?

Link to comment
Share on other sites

Just now, Happy2Play said:

You have no problems playing items on the server correct?

correct the problems arise when playing on a client (before pc now phone)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...