Jump to content


Photo

Problem with Trailers/channel download disc filling up

Trailers Channels

Best Answer ronvp , 18 July 2014 - 08:36 PM

make sure you're on the latest server because i tested and verified this was resolved.

Confirmed, version  3.0.5309.26857, is working OK it creates a single file in the Temp dir and after the trailer is downloaded, it deletes the temp file and starts the next one..

Go to the full post


  • Please log in to reply
4 replies to this topic

#1 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 486 posts
  • Local time: 04:34 AM

Posted 18 July 2014 - 08:07 AM

Recently I enabled the "Enable channel content downloading for: Trailers" option and set the download path to a 8 TB server. No problem there.

 

I then noticed that my 120 GB SSD (with the regular MBS cache completely filled up, causing my system to throw "out of memory errors". The culprit was a "TEMP directory created inside the normal MBS cache directory.

 

I decided to move the MBS cache to a striped Hard disc with about 160 GB space left. It too got filled up

 

I did some testing and here is what I found:

 

  1. If you enable the "Enable channel content downloading for: Trailers" and set a special Path on a large server, the Trailers do get downloaded to that directory, without any issues. However no matter where you download the trailers, MBS creates 2 more directories (Channels & TEMP) in the regular Cache location. For most people this is in "C:\Users\"your-user-name-here"\AppData\Roaming\MediaBrowser-Server\cache".
  2. The above "Channel" directory gets only a couple of entries and does not create problems.
  3. The TEMP directory, fills up with HUGE amounts of data and the *.tmp* files (as in 610a216c-948b-46ab-b746-14ea8220f61c.tmp), do not get deleted.

The only workaround I found was to disable the channel content downloading for Trailers



#2 A8HTPC OFFLINE  

A8HTPC

    Advanced Member

  • Members
  • 313 posts
  • Local time: 06:34 AM
  • LocationUS

Posted 18 July 2014 - 08:38 PM

I have my cache on a much larger sata drive. Its fast enough n doesnt need to b on my 60gb ssd

#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134225 posts
  • Local time: 06:34 AM

Posted 18 July 2014 - 08:40 PM

make sure you're on the latest server because i tested and verified this was resolved.



#4 ronvp OFFLINE  

ronvp

    Advanced Member

  • Members
  • 486 posts
  • Local time: 04:34 AM

Posted 18 July 2014 - 08:36 PM   Best Answer

make sure you're on the latest server because i tested and verified this was resolved.

Confirmed, version  3.0.5309.26857, is working OK it creates a single file in the Temp dir and after the trailer is downloaded, it deletes the temp file and starts the next one..


Edited by ronvp, 18 July 2014 - 06:36 PM.


#5 ginjaninja OFFLINE  

ginjaninja

    Advanced Member

  • Members
  • 1641 posts
  • Local time: 11:34 AM
  • Locationuk

Posted 02 August 2014 - 09:27 AM

@Luke

 

Version 3.0.5326.38482

 

just had same problem...temp was full of 700 trailers c. 100 gb,

last week i had set the channel 'delete content after'  to 700 days and yesterday i reduced to 60 days.. Today i was running the download channel content scheduled task..and noticed my drive was full.

. So there are still some use cases when it goes wrong.

 

i have a custom path for channel downloads

 

 

wiping cache\temp  and the custom channel  path, seems to have fixed it...


Edited by ginjaninja, 02 August 2014 - 11:54 AM.






Also tagged with one or more of these keywords: Trailers, Channels

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users