Jump to content

Subtitle Errors while Running Tasks


Recommended Posts

Quick question that might have a quick response. After setting up a new server, I noticed that whenever I run the "download subtitles" task it always takes over 2 hours. I thought it was normal at first since it was starting from scratch. But it's been a month and it's still taking just as long.

When I opened up the log, I did notice a few errors, but I'm completely unfamiliar with it, so I do need some help deciphering it please. I believe the log includes the two times I ran it today.

I'm pretty sure this question will come up, but I did sign into my Open Subtitles account (Free account, not VIP) on the dashboard.

Here is a link to my log: https://filebin.net/fxsw3xneaqthg1wj/embyserver.txt?t=zt4ilqlz

Definitely let me know if I can clarify anything! Thank you as always!

Edited by qazwsx10
Link to post
Share on other sites

When I was reading some of the errors, I did see it said "Access to the path ... is denied" a few times. But this is extremely odd to me. When I put in new media just yesterday, the nfo files were created alongside the media, so I'm fairly certain Emby has read/write access.

Link to post
Share on other sites

There is a few things going on.  It appears that you don't have create access to allow Emby to write files

2020-08-08 23:47:20.587 Info SubtitleManager: Saving subtitles to A:\Movies\Seven Pounds (2008).2.en.srt
2020-08-08 23:47:22.509 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).10.en.srt
2020-08-08 23:47:22.628 Info MediaProbeManager: ProcessRun 'ffprobe' Execute: C:\Users\Thanos\AppData\Roaming\Emby-Server\system\ffprobe.exe -i file:"A:\Movies\Seven Pounds (2008).avi" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data
2020-08-08 23:47:53.013 Error MediaProbeManager: Timeout while running Ffprobe -i file:"A:\Movies\Seven Pounds (2008).avi" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data
2020-08-08 23:47:53.686 Info MediaProbeManager: ProcessRun 'ffprobe' Process exited with code -1
2020-08-08 23:47:53.690 Error MediaProbeManager: ProcessRun 'ffprobe' Error Output:
	ffprobe version 4.3.0-emby_2020_05_23-g8f222573e9+530 Copyright (c) 2007-2019 the FFmpeg developers and softworkz for Emby LLC
	  built with gcc 9.2.0 (Rev2, Built by MSYS2 project)
2020-08-08 23:47:53.697 Error App: Error in ffprobe
	*** Error Report ***
	Version: 4.4.3.0
	Command line: C:\Users\Thanos\AppData\Roaming\Emby-Server\system\EmbyServer.dll
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///C:/Users/Thanos/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	System.Environment.Version: 3.1.4
	Processor count: 6
	Program data path: C:\Users\Thanos\AppData\Roaming\Emby-Server\programdata
	Application directory: C:\Users\Thanos\AppData\Roaming\Emby-Server\system
	System.Exception: System.Exception: Error running ffprobe for file:"A:\Movies\Seven Pounds (2008).avi" - 
	   at Emby.Server.MediaEncoding.Probing.MediaProbeManager.GetMediaInfoInternal(String inputPath, String primaryPath, MediaProtocol protocol, Boolean extractChapters, String probeSizeArgument, Boolean isAudio, Boolean forceEnableLogging, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.MediaInfo.FFProbeVideoInfo.ProbeVideo[T](T item, MetadataRefreshOptions options, LibraryOptions libraryOptions, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.Manager.MetadataService`2.RunCustomProvider(ICustomMetadataProvider`1 provider, TItemType item, String logName, MetadataRefreshOptions options, RefreshResult refreshResult, CancellationToken cancellationToken)
	Source: Emby.Server.MediaEncoding
	TargetSite: Void MoveNext()
	

Does that movie actually exist on drive A: ?  What kind of drive is A?

What kind of Open Subtitles account do you have?

Are you running behind a VPN service?

Link to post
Share on other sites
13 minutes ago, cayars said:

There is a few things going on.  It appears that you don't have create access to allow Emby to write files


2020-08-08 23:47:20.587 Info SubtitleManager: Saving subtitles to A:\Movies\Seven Pounds (2008).2.en.srt
2020-08-08 23:47:22.509 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).10.en.srt
2020-08-08 23:47:22.628 Info MediaProbeManager: ProcessRun 'ffprobe' Execute: C:\Users\Thanos\AppData\Roaming\Emby-Server\system\ffprobe.exe -i file:"A:\Movies\Seven Pounds (2008).avi" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data
2020-08-08 23:47:53.013 Error MediaProbeManager: Timeout while running Ffprobe -i file:"A:\Movies\Seven Pounds (2008).avi" -threads 0 -v info -print_format json -show_streams -show_chapters -show_format -show_data
2020-08-08 23:47:53.686 Info MediaProbeManager: ProcessRun 'ffprobe' Process exited with code -1
2020-08-08 23:47:53.690 Error MediaProbeManager: ProcessRun 'ffprobe' Error Output:
	ffprobe version 4.3.0-emby_2020_05_23-g8f222573e9+530 Copyright (c) 2007-2019 the FFmpeg developers and softworkz for Emby LLC
	  built with gcc 9.2.0 (Rev2, Built by MSYS2 project)
2020-08-08 23:47:53.697 Error App: Error in ffprobe
	*** Error Report ***
	Version: 4.4.3.0
	Command line: C:\Users\Thanos\AppData\Roaming\Emby-Server\system\EmbyServer.dll
	Operating system: Microsoft Windows NT 6.2.9200.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Runtime: file:///C:/Users/Thanos/AppData/Roaming/Emby-Server/system/System.Private.CoreLib.dll
	System.Environment.Version: 3.1.4
	Processor count: 6
	Program data path: C:\Users\Thanos\AppData\Roaming\Emby-Server\programdata
	Application directory: C:\Users\Thanos\AppData\Roaming\Emby-Server\system
	System.Exception: System.Exception: Error running ffprobe for file:"A:\Movies\Seven Pounds (2008).avi" - 
	   at Emby.Server.MediaEncoding.Probing.MediaProbeManager.GetMediaInfoInternal(String inputPath, String primaryPath, MediaProtocol protocol, Boolean extractChapters, String probeSizeArgument, Boolean isAudio, Boolean forceEnableLogging, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.MediaInfo.FFProbeVideoInfo.ProbeVideo[T](T item, MetadataRefreshOptions options, LibraryOptions libraryOptions, CancellationToken cancellationToken)
	   at MediaBrowser.Providers.Manager.MetadataService`2.RunCustomProvider(ICustomMetadataProvider`1 provider, TItemType item, String logName, MetadataRefreshOptions options, RefreshResult refreshResult, CancellationToken cancellationToken)
	Source: Emby.Server.MediaEncoding
	TargetSite: Void MoveNext()
	

Does that movie actually exist on drive A: ?  What kind of drive is A?

What kind of Open Subtitles account do you have?

Are you running behind a VPN service?

When you say "create access" does that mean write access? It should since whenever I scan new media NFO files are created with the media. I have my subtitle setting set to save along with the media as well.

Does that movie actually exist on drive A: ?  What kind of drive is A? Yes, the movie does exist on A:, it is a virtual drive that I mounted. By virtual I mean a server.

What kind of Open Subtitles account do you have? Free, not VIP.

Are you running behind a VPN service? Nope!

Edited by qazwsx10
Link to post
Share on other sites

Those are different permissions.  But basically you want the Emby user to have full access.

Ahh, virtual access, that probably accounts for some of the time depending on your settings used. But Emby is definitely having trouble reaching or writing to your A drive at times.

If it's a Google Drive this happens a lot to some users as they hit their quotas on use.

I don't know what the limit is for non VIP members but can tell you the VIP pages says 1000 downloads per 24 hours WITH VIP.  So in one 30 day month you could download 30K subs which depending on the size of your library and your settings might not be enough.

Link to post
Share on other sites
1 minute ago, cayars said:

Those are different permissions.  But basically you want the Emby user to have full access.

Ahh, virtual access, that probably accounts for some of the time depending on your settings used. But Emby is definitely having trouble reaching or writing to your A drive at times.

If it's a Google Drive this happens a lot to some users as they hit their quotas on use.

I don't know what the limit is for non VIP members but can tell you the VIP pages says 1000 downloads per 24 hours WITH VIP.  So in one 30 day month you could download 30K subs which depending on the size of your library and your settings might not be enough.

Thank you for the clarification! I'm running the subtitle task on the admin account. Do you know where I would look to make sure they have full access? Is this an option within Emby?

I think combining movies and TV, I should well under that, so I don't believe I should have passed the the non-VIP allotment, but I can check.

Thanks again!

Link to post
Share on other sites
Happy2Play

This example shows subtitles working, but just has a permissions issue writing to that location so it is falling back to \metadata location.

2020-08-08 23:47:22.509 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).10.en.srt

But the log shows this happening 4 times for this file.  Like it is stuck in a loop.

2020-08-08 23:47:22.509 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).10.en.srt
2020-08-09 06:26:59.739 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).11.en.srt
2020-08-09 13:17:21.382 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).12.en.srt
2020-08-09 14:20:17.930 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).13.en.srt

To me it looks like OpenSubtitles may be doing maintainance.

MediaBrowser.Model.Net.HttpException: MediaBrowser.Model.Net.HttpException: ServiceUnavailable
From https://api.opensubtitles.org/xml-rpc

<methodResponse>
<params>
<param>
<value>
<struct>
<member>
<name>status</name>
<value>
<string>506 Server under maintenance</string>
</value>
</member>
</struct>
</value>
</param>
</params>
</methodResponse>

main.jpg.a0160a381a7d3bb06d32b6412f92c595.jpg

 

http://www.opensubtitles.org/

Site will be online soon. We are doing some necessary backups and upgrades. Thanks for understanding.

 

Link to post
Share on other sites

I agree Happy2Play but I also question or will ask.

Where is Drive B located?

Is this also a virtual drive or a real HDD attached to your computer?

Link to post
Share on other sites
25 minutes ago, Happy2Play said:

This example shows subtitles working, but just has a permissions issue writing to that location so it is falling back to \metadata location.


2020-08-08 23:47:22.509 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).10.en.srt

But the log shows this happening 4 times for this file.  Like it is stuck in a loop.


2020-08-08 23:47:22.509 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).10.en.srt
2020-08-09 06:26:59.739 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).11.en.srt
2020-08-09 13:17:21.382 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).12.en.srt
2020-08-09 14:20:17.930 Info SubtitleManager: Subtitle saving write access denied, falling back to saving subtitles to B:\Emby-Server\programdata\metadata\library\dd\ddc3ecf48ccd0ebccf0f32a03fbfe4d9\Seven Pounds (2008).13.en.srt

To me it looks like OpenSubtitles may be doing maintainance.


MediaBrowser.Model.Net.HttpException: MediaBrowser.Model.Net.HttpException: ServiceUnavailable

From https://api.opensubtitles.org/xml-rpc

<methodResponse>
<params>
<param>
<value>
<struct>
<member>
<name>status</name>
<value>
<string>506 Server under maintenance</string>
</value>
</member>
</struct>
</value>
</param>
</params>
</methodResponse>

main.jpg.a0160a381a7d3bb06d32b6412f92c595.jpg

 


http://www.opensubtitles.org/

Site will be online soon. We are doing some necessary backups and upgrades. Thanks for understanding.

 

 

17 minutes ago, cayars said:

I agree Happy2Play but I also question or will ask.

Where is Drive B located?

Is this also a virtual drive or a real HDD attached to your computer?

 

That's extremely odd about the write access. It's weird that it can't write only during subtitles, but any other task is perfectly fine.

As for opensubtitles being down, I'll try again in the morning to see what is happening.

Drive B is a physical drive for metadata attached to the server.

  • Like 1
Link to post
Share on other sites

So I'm running it again this morning, what does something like this mean when it appears in the log?

2020-08-10 06:44:28.453 Info HttpClient: POST https://api.opensubtitles.org/xml-rpc

Does that mean that it successfully downloaded a subtitle for a particular piece of media? It's appeared quite a few times in a row, so I just wanted to check.

Link to post
Share on other sites

One thing I never actually considered looking into was the actual subtitles files that were downloaded. When I checked within the folders, it looks like subtitles haven't been downloading since the day I set up the server.

Link to post
Share on other sites
  • 3 weeks later...
On 8/11/2020 at 1:21 PM, qazwsx10 said:

One thing I never actually considered looking into was the actual subtitles files that were downloaded. When I checked within the folders, it looks like subtitles haven't been downloading since the day I set up the server.

Well I think happy2play already answered that earlier, right? The server is being denied write access to save the subtitle files to your media folders. Then it ends up falling back to the server's internal metadata folder.

Link to post
Share on other sites
26 minutes ago, Luke said:

Well I think happy2play already answered that earlier, right? The server is being denied write access to save the subtitle files to your media folders. Then it ends up falling back to the server's internal metadata folder.

I believe you are correct. I'm still getting the proper syntax figured out for rclone. So once I have that, I'll be sure to post it here for anyone else that may be running into the same issue.

Link to post
Share on other sites

So I may have resolved it, on rclone be sure to include "--vfs-cache-mode writes". The program I use to auto-run commands doesn't provide any feedback of errors, so I ran this in the command prompt and started seeing some detailed errors popping up. When I ran this with the rest of my rclone command within the command prompt, the first movie's subtitle came just fine (albiet it took some time). I placed it within my original program to see if it has been resolved.


One question I did have was, I did notice under my scheduled tasks, the "Download subtitles" task is slowly progressing and normally completes in 2 hours. What does the percent actually mean? Does it represent how far it has gone through my library or does it represent the time this task is allowed to run?

Edited by qazwsx10
Link to post
Share on other sites
On 8/26/2020 at 5:19 PM, Luke said:

Let us know how you get on. Thanks !

I spoke too soon, it doesn't fully work yet. One question I did have was the exact way subtitles are selected? My understanding from some previous posts were in this order:

  • Hash
  • Title
  • imdb

Hash matches for some reason are not working on my end. My fear is by unselecting hash only matches, it would defer to title AND imdb matches. Is there anyway to restrict it to only title and not look at imdb matches?

Link to post
Share on other sites
  • 2 weeks later...

@qazwsx10 it's not that hash matching is not working, it just means that they don't have any subtitles that are exact hash matches for your videos. Does this answer your question?

 

Quote

Is there anyway to restrict it to only title and not look at imdb matches?

Currently no, but more options are possible for the future.

Link to post
Share on other sites
10 hours ago, Luke said:

@qazwsx10 it's not that hash matching is not working, it just means that they don't have any subtitles that are exact hash matches for your videos. Does this answer your question?

 

Currently no, but more options are possible for the future.

Unfortunately I do believe there are exact hash matches available. The server I'm running now is a complete refresh of my previous server (with the same media). Subtitles were being captured on the previous server, but doesn't appear to be capturing the same subtitles on my current server.

Link to post
Share on other sites
4 hours ago, Luke said:

We haven't changed anything related to the way the hash option is handled with open subtitles.

Okay, then I'm fairly certain it is rClone. We can close this thread if you'd like or wait until I get a reply from the rClone forums if it's helpful.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...