Jump to content
AboveUnrefined

Live TV Playback Frame Freezing

Recommended Posts

AboveUnrefined
Posted (edited)

Hello,

Recently I've been noticing while playing back live TV from my hdhomerun and hdhomerun prime that while playback is happening it occasionally freezes on a frame and keeps playing audio; it just gets stuck on a frame and resumes playing audio. If I pause/play the frame remains frozen - if I fast forward then hit play it'll sometimes recover where it will pick up just before the frozen frame was encountered, but it seems like the time bar is all wrong with where it's at in the stream....

I've encountered this while watching live TV as well with recorded TV and I do have a captured stream where I can reliably hit the frozen frame issue I'm describing. I've tried the alternative transcoding option that's available while playing the stream, but it still freezes...

This is a bit tricky to diagnose since it seems like some bad frames are getting to the Roku and it's causing it to freeze on the bad frame. If I play the same recording on the web client I don't get the issue happening either...

I'm hoping there can be a fix for this since it seems to be happening more frequently as time grinds on. If there's something more I can try to provide with this I'll try to help, but as of right now I'm not sure what would be valuable information to provide...

Edited by AboveUnrefined

Share this post


Link to post
Share on other sites
ebr

Hi.  If you have transcode throttling enabled on your Emby Server, try turning it off to see if it makes a difference.

Thanks.

Share this post


Link to post
Share on other sites
AboveUnrefined
47 minutes ago, ebr said:

Hi.  If you have transcode throttling enabled on your Emby Server, try turning it off to see if it makes a difference.

Thanks.

Thanks for the suggestion - I turned off `transcode throttling` and restarted everything but the problem persists...

I'm attaching the ffmpeg log from the server with the recording that I've been using to test out with (`ffmpeg-directstream-a43b034a-888f-4680-a6f7-84b64dc86c43_1.txt`)... I think it mentions some things about bad frames but like I was mentioning, the problem doesn't happen with the web client and only seems to be present with the recent Roku client...

 

I just had it happen about ten minutes ago while playing a live stream -- I let it keep playing as I was busy and it wound up going back to the `Loading` screen like the buffer ran low and recovered...  am also attaching the log for that here (`ffmpeg-directstream-f6aaae21-21f1-4261-b1d1-da9fb1785892_1.txt` and `ffmpeg-directstream-28ecf361-1ddb-487a-9da1-514f45cad500_1.txt`)

ffmpeg-directstream-a43b034a-888f-4680-a6f7-84b64dc86c43_1.txt ffmpeg-directstream-28ecf361-1ddb-487a-9da1-514f45cad500_1.txt ffmpeg-directstream-f6aaae21-21f1-4261-b1d1-da9fb1785892_1.txt

Share this post


Link to post
Share on other sites
AboveUnrefined

I just had another encounter with this while watching live tv -- I tried to get the log out from that but my wife restarted streaming and can't find a meaningful log on that...

This definitely seems to have started happening around a couple weeks ago and just seems to happen with the TV streams -- I'm going to try and convert the recordings to see if that clears those up, but there seems to be a pretty prevalent problem going on with the roku client and the TV streams right now.

Share this post


Link to post
Share on other sites
ebr

Hi.  What firmware version is your Roku running and when did it last update?

Share this post


Link to post
Share on other sites
AboveUnrefined
1 hour ago, ebr said:

Hi.  What firmware version is your Roku running and when did it last update?

I'm on server 4.5.0.13 beta and using the beta client on Roku. I've tried the regular client as well, but the problem was there as well.

Share this post


Link to post
Share on other sites
AboveUnrefined
Posted (edited)
12 hours ago, AboveUnrefined said:

I'm on server 4.5.0.13 beta and using the beta client on Roku. I've tried the regular client as well, but the problem was there as well.

I'm sorry I just realized you asked me for Roku versioning information, I've been a bit busy juggling work and this so thanks for bearing with me and helping out.

It's a TCL Roku TV SG 4.0.4 and it was last updated on June 24.

Edited by AboveUnrefined

Share this post


Link to post
Share on other sites
ebr

Hi.  I'm asking for the Roku firmware itself...

Share this post


Link to post
Share on other sites
AboveUnrefined
6 hours ago, ebr said:

Hi.  I'm asking for the Roku firmware itself...

Got it:

Software version: 9.3.0

Build: 4182

Share this post


Link to post
Share on other sites
ebr

Okay, and that updated about the same time - a week or so ago, correct?

Share this post


Link to post
Share on other sites
AboveUnrefined
1 hour ago, ebr said:

Okay, and that updated about the same time - a week or so ago, correct?

It was June 24, it's hard to say for sure but I'd guess it probably was then, unless there was another update shortly before that...

Share this post


Link to post
Share on other sites
AboveUnrefined

I just had it happen again today, I took a look through the logs but really don't see anything meaningful that could help. I'll attach the segment from the embyserver log where the stream started and ended in case there is something I don't see...

embyserver-tvframefreeze-202007021704.txt

Share this post


Link to post
Share on other sites
Luke

@AboveUnrefined can you please attach the complete emby server log? Thanks !

Share this post


Link to post
Share on other sites
AboveUnrefined
41 minutes ago, Luke said:

@AboveUnrefined can you please attach the complete emby server log? Thanks !

Sure, I've attached the most recent here. If there's more I can provide please let me know -- it did happen a couple more times today... Thanks for taking a look!

embyserver-20200708-full..txt

Share this post


Link to post
Share on other sites
AboveUnrefined
4 hours ago, Noah0504 said:

I'm pretty sure this is being caused by an issue with the 9.3 update for Roku TV.

Same issue being reported by Plex users: https://forums.plex.tv/t/roku-update-to-9-3-0-causes-live-tv-video-to-freeze/60662

You're probably right about that -- it does seem to happen more often when my wife is watching shows where there's a higher chance for "bad" frames to slide in from commercial splicing or whatever else they're doing (it just happened again while she was watching her show)...  I've also noticed it happening with OTA channels, which likely just introduce bad frames given the nature of OTA... I do know it likely started happening since the date the update applied, so at least there's that to confirm with.

Anybody know how we can try to bring this up to Roku where they might actually fix it? 

Share this post


Link to post
Share on other sites
AboveUnrefined

I'll set a reminder to follow up on this in a couple weeks on the Roku side -- it's not a terrible issue but it is pretty annoying when it happens (it seems to always happen when I'm most relaxed and don't want to be bothered with this sort of thing). Unless we hear something otherwise, I suspect that you're right about this so thank you for chiming in!

Share this post


Link to post
Share on other sites
Luke

Are you still running into this?

Share this post


Link to post
Share on other sites
AboveUnrefined

Yeah we're still encountering this issue, it happened a few more times this weekend and more throughout the week.

We've been working around it by fast forwarding whenever it happens and it seems like it'll just wind up slightly before the frozen frame and usually work its way through it. Not ideal but for now doable; it's hard to really tell if it's more of a Roku issue like Noah0504 pointed out (I think it is) or if something else needs to be done to accommodate for crapped up TV frames that get to the Roku.

Share this post


Link to post
Share on other sites
Luke

Thanks for doing that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...