Jump to content

"No compatible streams are currently available" error


rhiannongilland

Recommended Posts

rhiannongilland

I converted an iTunes m4v file to mp4 on my Mac and then loaded it to the emby server...however when I try to play the file, I get an error stating "No compatible streams are currently available." I'm very new to emby so I don't know the system very well but any help would be appreciated.

embyserver.txt

post-648400-0-59466100-1589751431_thumb.png

embyserver-63725319937.txt

Edited by rhiannongilland
Link to post
Share on other sites
rhiannongilland

sorry, I didn't finish attaching the screenshot and log file before...I have done so in my original post. Does this help?

Link to post
Share on other sites
  • 1 year later...
therealstanding

Just paid for Emby and next day I can't play a single movie or song, No compatible streams are currently available.What a joke no help from Emby, act like they never heard of problem.

 

Link to post
Share on other sites
Luke
4 hours ago, therealstanding said:

Just paid for Emby and next day I can't play a single movie or song, No compatible streams are currently available.What a joke no help from Emby, act like they never heard of problem.

 

Hi @therealstanding we're happy to help you with your issue. Can you please attach the emby server log from when you tried to play? Thanks !

Link to post
Share on other sites
therealstanding

How many log files from how many people do you need before you know how to fix problem? Every morning when i turn on my mac or reboot emby says no compatible streams for what ever I play movies or music. I have to delete library and do all over again and all is fine until next restart of mac. All files are stored on wd nas. connected to my router.

Link to post
Share on other sites
therealstanding

i just noticed this morning that when i delete and reconnect everything back to movie folder that it also fixes my music folder so that it plays audio again. i have no need to delete and redue it. up til now I have just deleted my data for movies and my music and reloaded both files back to work. But I guess doing only one or the other reconnects what ever is lost during the reboot or shut down of my mac that then makes emby loose connection to my data. Something new i just figured out.

 

Link to post
Share on other sites
therealstanding

As i just had to do a retart on emby because i made a change, i ended up with no compatible stream right after reboot again, so this time i created file on nas with one photo in it and connected it to my emby and all worked again for video and audio files again, now when i loose connection i only need delete photo file and redue taking only seconds to scan where when doing movies or music it would take me 45 min because of size of both files. But I still don't want to have to delete and redue photo file every morn to get emby to work again.

Link to post
Share on other sites
therealstanding

can't figure out my host to set up server. says can't find server. won't allow to add server, but not sure how with host name or ip, seems to allow sign up but no server.

Link to post
Share on other sites
therealstanding

Yes got to connect, but I see I must have emby server for my Mac downloaded and installed with what ever you gave me. But after getting all set up I did a reboot and lost connection to all files again. Because this app you said to try is not a stand alone that I can see if it stays connected. It is my emby server that dies on a restart of emby or a reboot of computer. 

Link to post
Share on other sites
therealstanding

So yes sorry, it does play on your online emby app so long as there is no reboot as it does the same and says no compatible files again, un til i go and delete my picture library and redue it again, then all is fine again

 

Link to post
Share on other sites
Luke
Quote

So yes sorry, it does play on your online emby app

Ok then there is a good chance this is resolved in the 4.6.3 server release that is beginning to roll out. Thanks.

Link to post
Share on other sites
therealstanding

installed after I deleted old emby server and the very first thing was no compatible streams even though I see my movies and music librays. So no luck.

Link to post
Share on other sites
Luke
9 minutes ago, therealstanding said:

installed after I deleted old emby server and the very first thing was no compatible streams even though I see my movies and music librays. So no luck.

Ok, your issue is probably something different then. Can you please attach the emby server log? Thanks.

Link to post
Share on other sites
Happy2Play

Not a platform user but to me it looks like a issue with the SMB library path.  RTM doesn't see path either.

2021-06-18 19:05:31.305 Info LibraryMonitor: Skipping realtime monitor for smb://wdmycloud/Public/Bear Pics because the path does not exist
2021-06-18 19:05:31.307 Info LibraryMonitor: Skipping realtime monitor for smb://wdmycloud/Public/Movies because the path does not exist
2021-06-18 19:05:31.309 Info LibraryMonitor: Skipping realtime monitor for smb://wdmycloud/Public/Music because the path does not exist
21-06-18 19:06:19.522 Error Server: Error processing request
	*** Error Report ***
	Version: 4.6.3.0
	Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll
	Operating system: Darwin 20.5.0 Darwin Kernel Version 20.5.0: Sat May  8 05:10:33 PDT 2021; root:xnu-7195.121.3~9/RELEASE_X86_64
	Framework: .NET Core 3.1.8
	OS/Process: x64/x64
	Runtime: Applications/EmbyServer.app/Contents/MacOS/System.Private.CoreLib.dll
	Processor count: 6
	Data path: /Users/yvonne/.config/emby-server
	Application path: /Applications/EmbyServer.app/Contents/MacOS
	SharpCifs.Smb.SmbException: SharpCifs.Smb.SmbException: Failed to connect to server
	   at SharpCifs.Smb.SmbFile.Connect0()
	   at SharpCifs.Smb.SmbFile.QueryPath(String path, Int32 infoLevel)
	   at SharpCifs.Smb.SmbFile.Exists()
	   at Emby.Server.Implementations.IO.SharpCifsFileSystem.AssertFileExists(SmbFile file, String path)
	   at Emby.Server.Implementations.IO.SharpCifsFileSystem.OpenRead(String path)
	   at Emby.Server.Implementations.IO.SharpCifsFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share)
	   at Emby.Server.Implementations.IO.ManagedFileSystem.GetFileStream(String path, FileOpenMode mode, FileAccessMode access, FileShareMode share, FileOpenOptions fileOpenOptions)
	   at Emby.Server.Implementations.IO.IOManager.GetResponse(HttpRequestOptions options, MediaProtocol protocol)
	   at Emby.Server.Implementations.IO.IOManager.GetResponse(HttpRequestOptions options)
	   at Emby.Server.Implementations.HttpServer.HttpResultFactory.GetContent(StaticFileResultOptions options, Int64 offset, Int64 length, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.FileWriter.SetContentResponseHeaders(Nullable`1 reportedTotalContentLength, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpResultFactory.GetStaticResult(IRequest requestContext, StaticResultOptions options)
	   at Emby.Server.Implementations.Services.ServiceController.GetTaskResult(Task task)
	   at Emby.Server.Implementations.Services.ServiceHandler.ProcessRequestAsync(HttpListenerHost appHost, IRequest httpReq, IResponse httpRes, RestPath restPath, String responseContentType, CancellationToken cancellationToken)
	   at Emby.Server.Implementations.HttpServer.HttpListenerHost.RequestHandler(IRequest httpReq, ReadOnlyMemory`1 urlString, ReadOnlyMemory`1 localPath, CancellationToken cancellationToken)
	SharpCifs.Util.Sharpen.UnknownHostException: WDMYCLOUD<20>
	   at SharpCifs.Netbios.NbtAddress.DoNameQuery(Name name, IPAddress svr)
	   at SharpCifs.Netbios.NbtAddress.GetByName(String host, Int32 type, String scope, IPAddress svr)
	   at SharpCifs.UniAddress.GetAllByName(String hostname, Boolean possibleNtDomainOrWorkgroup)
	   at SharpCifs.Smb.SmbFile.GetFirstAddress()
	   at SharpCifs.Smb.SmbFile.Connect()
	   at SharpCifs.Smb.SmbFile.Connect0()

 

Edited by Happy2Play
added info
Link to post
Share on other sites
Happy2Play

@therealstandingif you were to do a refresh on "Above.Suspicion.2019" do you get errors in the log?

Link to post
Share on other sites
therealstanding

have no idea what you mean to refresh my movie. I have tries to rescan and rescan data but nothing works unless I actually delete one of my 4 library's and then redue to make a connection again. I have tried a hundred different ways but I can only get my library's on my emby by following certain steps so if there is another way to add library where emby will keep a connection I don't know.

Link to post
Share on other sites
therealstanding

And I will point out that my mac mini never looses connection to my wd nas and my info on it. It is always in my finder for me to get, When I open my Audirvana music player that accesses the files on nas never looses data connection. Or if I play stand alone video player on my mac no problem with connection path to nas. When I run Kodi i never loose connection, just didn't like interface on it, but I may have to go back I guess. And it seems to me I tried emby for almost the whole trial period with no issues, until I paid and nothing has worked ever since. 

Link to post
Share on other sites
therealstanding

Well I had a brain cramp and put a audio track in my download folder on my mac mini as opposed to all other libraries which are on a nas connected to router on my network. I can reboot computer or restart Emby and I loose all connection to files on nas but what I connected to the download folder, the audio track kept playing and stays connected no matter what. Only things stored on nas looses connection. I have been threw my nas settings top to bottom and can't seem to change anything that makes a difference.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...