Jump to content
mpb2000

album appears twice(or more)

Recommended Posts

mpb2000

In my library, some albums appear multiple times even when they have the Ids (MusicBrainz).

 

These IDs are from one double:

 

5e86f92f10c9d_Anmerkung20200403105109.pn

 

5e86f8aaba084_Anmerkung20200403104918.pn

Share this post


Link to post
Share on other sites
Luke

Hi there, how are your music files named and organized?

Share this post


Link to post
Share on other sites
mpb2000
Posted (edited)

It is organized like this:

 

Artist - (folder)

          | album - (folder)

                   |Titel - (file)

 

But some Albums are split up between Artists.

 

Example:

 

   Folder Structure:

 

     Artist

           | Album

                     | Song

  

 

     Artist & other Artist

           | same Album

                     | Song

Edited by mpb2000

Share this post


Link to post
Share on other sites
Luke

Ok, that's the reason why. Currently albums are associated with folders in your library. We plan to remove this and become fully tag driven in the near future, but we're not quite there yet. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
Skyobliwind

Hm, I have the same Problem on Emby 4.3.1.0 but I didn't split anything.

 

I use:

 

   Artist

           | Album

                     | Song

 

I have one Artist with 4 Albums for example, but under Artist the Same artist exists 3 times 1 with 3 Albums, 1 with 1 Album, 1 with 0 Albums... I checked the MP3-tags, those are all fine and all the same. I added the same MusicBrainz ID to all 3 Versions of the artist, but that doesn't change anything. How can I remove artists manually? Same name and same ID doesn't seem to fix this. I have this with multiple Artists which makes the Artist overview quite ugly.

Share this post


Link to post
Share on other sites
Skyobliwind

Ok, a workaround is to set emby to store the information in NFOs and manually edit them. Then after readding the albums the artist is correct and only appears once.

Share this post


Link to post
Share on other sites
Luke

Hi, we'd have to look at a specific example and I would suggest updating to emby server 4.4.2. thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...