Jump to content

Gestionnaire de metadonnées - Affichage par "Movie" et non "Folder"


Mickelebof
 Share

Recommended Posts

Hello,

 

I'm having a problem with the display in the Metadata Manager for "Movies" media libraries.

Indeed, for these media libraries, the variable " serveritemtype " is set to " Movie ", while for media libraries of the " TV " type , the display is in " Folder " mode eg:

 

" Films " type media library :

<li role = "treeitem" serveritemtype = "Movie" collectiontype = "undefined" aria-selected = "false" aria-level = "2" aria-labelledby = "8_anchor" id = "8" class = "jstree-node jstree -leaf ">

" TV " type media library :

<li role = "treeitem" serveritemtype = "Folder" collectiontype = "undefined" aria-selected = "false" aria-level = "2" aria-labelledby = "8_anchor" id = "8" class = "jstree-node jstree -leaf ">

The fact is that when a media is not correctly detected by the scrapper, it is very practical to be able to find it thanks to the Metadata Manager (I think, moreover, that is its function).

Display in " Folder " mode is therefore necessary.

 

On an Emby server, in the latest stable version (4.3.1.0), which I upgrade from version to version since version 4, I don't have this problem, the display is in " Folder "

On a freshly installed Emby server (4.3.1.0), I have this problem.
 

For information on configuration, the 2 Emby servers are installed on an Ubuntu 18.04 server 64bits (up-to-date) with an Emby Premiere LifeTime license each.

 

Is there the possibility to force the display in " Folder " mode in the Metadata Manager ?

 

Thanks for your help.

Mick

@@neik

@@Happy2Play

@@arrbee99




			
		
Link to comment
Share on other sites

Je ne saurais pas t'aider mais puisque l'anglais ne semble pas être un problème pour toi, tu aurais plus de succès à poster ton message dans le forum "Emby Server" directement.  ;)

Link to comment
Share on other sites

Happy2Play

This is a per library option in the librarys options.xml, change <CollapseSingleItemFolders> to false and do a library scan.  SEE NOTE BELOW

 

Look at Dashboard Paths box to get the general location of your programdata folder or it is near the top of a server log.

\Emby-Server\programdata\root\default\"each library folder"

Note changing this option is destructive, so all items will be removed and re-added for every library you apply it to.  If you do not save metadata/image with media this will delete all media metadata/image customization.

 

This would have to applied to all new libraries also as it default to true. 

This is sort of problematic as you have to create a library first, unless you do the hack of copy an existing library and change folder name to the library display name you are adding and edit the  "Path" and "Name" fields in options.xml and a library scan after starting the server.

 

Also note member tags were added by a Admin.

Edited by Happy2Play
Link to comment
Share on other sites

Hello @@Happy2Play,

 

Thank you for your return :)
Unfortunately, it doesn't work.
I tested on one of my libraries and the problem remains the same.

Indeed, on the server that works well, the "CollapseSingleItemFolders" variable seems to be set to "false" by default.
While on the other one, it is set to "true" by default.

But on "TV" libraries, the "CollapseSingleItemFolders" is set to "true" and yet the display in "Metadata Manager" is correct.

I can't put a screenshot (permissions denied), so I'll try to show what I'm looking for:

I would like the display in Metadata Manager to look like this:

 Library Name
     `- Folder name
          `- Content name by scrapper

Example :

 Animations
      `- Abominable (2019)
            `- Abominable

But right now it's showing up :

 Library Name
      `- Content name by scrapper

=>

 Animations
       `- Abominable

Maybe it is not possible to change this setting once the library has been created ?
Is it possible to add this option when creating the library ?

 

NB : I've tried on "Animations" libraries :

# grep "CollapseSingleItemFolders" Animations/*
Animations/options.xml:  <CollapseSingleItemFolders>false</CollapseSingleItemFolders>

Thanks a lot.

Mick
 

Edited by Mickelebof
Link to comment
Share on other sites

Happy2Play

Sorry, looks like you have to ensure the system.xml <CollapseVideoFolders> is set to false also so it will honor the individual library settings.  It is in the Emby-Server\programdata\config folder.

5e53a52a750fb_MM.jpg

Link to comment
Share on other sites

Hello @@Happy2Play,

 

Thanks, that's working ! (but only for my first library, the second library "Movie" has not changed ^^)

But I will try to recreate this library ;)

 

@@Luke :

Why would you say that ?

You think it can be replaced with a new version of Emby ?

 

On my second Emby Server, on the one I don't have this problem with, that parameter's already set to "false." (I'm not the one who changed it.)

The only difference on this one is that I upgraded Emby Server regularly since version 3.
On the other one, it's a "fresh install" in 4.3.1.0 directly

 

Anyway, thank you for your help.

Emby is a very good product, I love it ;)

Link to comment
Share on other sites

Happy2Play

This was I guess a unintended change from 3.5 to 4.0, and these switches were added to revert back to 3.5 format.  So your preferred showing is not intended.  As these were/are destructive library actions.

  • Like 1
Link to comment
Share on other sites

@@Luke : I understand :)
However, I find that this was a regression, we should put this parameter back as it was before and not change it anymore :P

For info, I recreated my 2nd library and the display is back in "Folder" mode. :lol:

Thanks again @@Happy2Play ;)

 

(This topic can be marked to Solved :) )

Link to comment
Share on other sites

I suppose so, too.
Luckily Emby scans much faster than a few years ago :D

 

I'll think about asking Emby to put all the info in the files directly, but I have some constraints that make this choice difficult :ph34r:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...