Jump to content


Photo

Non secure connection

emby ssl certificate secure app

Best Answer Luke , 15 February 2020 - 05:31 PM

For the online web app it's not that simple. We have to allow http://app.emby.media to work so that users who haven't' setup SSL can connect.

 

We could probably have it redirect to https://app.emby.media in certain circumstances, but there's still a couple problem with trying to do that. You'd have to login twice because http/https are two different urls, thus two different web apps as far as browser data storage is concerned.  And also when you're inside your local network, it would have to use your remote https address all the time, because the local network http address is not allowed on the https protocol.

 

So you have to make sure to understand these things and then decide what is best for you. If you want to have all possible features along with https, then the native android and iOS apps are your best option because those will be able to automatically switch between your local http address when inside your network, and your remote https address when outside.

Go to the full post


  • Please log in to reply
3 replies to this topic

#1 hugo0814 OFFLINE  

hugo0814

    Newbie

  • Members
  • 7 posts
  • Local time: 07:38 AM

Posted 15 February 2020 - 01:17 PM

Hey!

 

So I just finished the SSL certificate and all connections are secure BUT only when I enter my Dynamic DNS address. Not when I visit using the "app.emby.media" site on my iPhone, it shows "Not Secure". Included some pictures to show my configuration.

 

5e48275ba0d8b_networksettings.png

 

 

5e48276feea20_dashboardsettings.png



#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 50662 posts
  • Local time: 02:38 AM

Posted 15 February 2020 - 02:32 PM

Hi.  Did you set the server to require SSL for remote connections?  And also go to https://app.emby.media?



#3 hugo0814 OFFLINE  

hugo0814

    Newbie

  • Members
  • 7 posts
  • Local time: 07:38 AM

Posted 15 February 2020 - 03:23 PM

Hi.  Did you set the server to require SSL for remote connections?  And also go to https://app.emby.media?

Under the setting "Secure Connection Mode" I choosed "Required for all remote connections", as shown in the picture provided. Or is there any other setting to pick?

 

Yes when I type https it directs to a secure connection, but I would like it to automatically direct to a httpconnection and not allow any http connections.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152349 posts
  • Local time: 02:38 AM

Posted 15 February 2020 - 05:31 PM   Best Answer

For the online web app it's not that simple. We have to allow http://app.emby.media to work so that users who haven't' setup SSL can connect.

 

We could probably have it redirect to https://app.emby.media in certain circumstances, but there's still a couple problem with trying to do that. You'd have to login twice because http/https are two different urls, thus two different web apps as far as browser data storage is concerned.  And also when you're inside your local network, it would have to use your remote https address all the time, because the local network http address is not allowed on the https protocol.

 

So you have to make sure to understand these things and then decide what is best for you. If you want to have all possible features along with https, then the native android and iOS apps are your best option because those will be able to automatically switch between your local http address when inside your network, and your remote https address when outside.


  • ebr likes this





Also tagged with one or more of these keywords: emby, ssl, certificate, secure, app

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users