Jump to content


Photo

Multiples « Spider-Man » collections

Collections bug

Best Answer Happy2Play , 13 February 2020 - 09:42 PM

I can try, can you just point me the right file that I have to change and some indications for the SQL Browser?

 

Thanks!

Ensure you only work with a copy of the database, you may have to close Emby to make a copy.

C:\Users\nas\AppData\Roaming\Emby-Server\programdata\data\library.db

 

5e45fae13ca95_db.jpg

Go to the full post


  • Please log in to reply
33 replies to this topic

#1 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 10 February 2020 - 08:03 PM

Attached File  0F9564D9-11BD-47D9-981C-D24D4A16F5EC.png   1.28MB   5 downloadsHi,

As show in the picture attached to this post, I have a collection that appear multiples times. Each time that I reboot the server, a « new entry » appears. I have check in the roaming directory and I have just one folder with one xml and the xml is normal, I don’t have multiples entries...

I have try to make a « sql » cleanup, but without success...

It’s make it just with Spider-Man one. I have deleted all and create a new entry, but same result at the end...  :huh:

Some have a idea?

Thank you!



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:46 PM

Posted 10 February 2020 - 11:32 PM

Hi there, do you have the autoboxsets plugin installed? what version of emby server?



#3 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 11 February 2020 - 08:19 AM

Hi Luke,

Yes, autoboxset was installed with the version 1.23 I think with Emby Server 4.3.0.1.

For now, I have uninstalled boxset and its seem to be good for now, but its a practical plugin, I hope that I will reinstall it...



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:46 PM

Posted 11 February 2020 - 10:59 AM

How many Spiderman movies do you have?

#5 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 11 February 2020 - 01:40 PM

I had the same reflex, but there are 5 films in my library and a lot more collection ... I also have another question that I noticed recently, before version 4.3.1.0, we had a progression transcoding on the tile displayed in the dashboard, but now we only have "transcoding" as information, did I do something that would have broken this function ...?

#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:46 PM

Posted 11 February 2020 - 03:50 PM

What spiderman movies do you have?



#7 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 11 February 2020 - 04:23 PM

Spider-Man
Spider-Man 2
Spider-Man 3
Homecoming
Far from Home

#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:46 PM

Posted 11 February 2020 - 04:31 PM

Ok can you attach the server log from the last time another spiderman collection was created? Thanks.



#9 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 11 February 2020 - 08:59 PM

Always the exact same entries, that add a new Spider-Man collection entry...

2020-02-11 19:55:25.100 Info Auto Box Sets: Executing Automatic BoxSet creation.  Found 106 potential box sets.
2020-02-11 19:55:25.566 Info Auto Box Sets: Verified set 531241 as Spider-Man Collection - creating...
2020-02-11 19:55:25.826 Info Auto Box Sets: Automatic BoxSet creation completed.
2020-02-11 19:55:26.169 Info TaskManager: Scan media library Completed after 0 minute(s) and 21 seconds


#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:46 PM

Posted 12 February 2020 - 02:05 PM

Do the spiderman collections have any external id's assigned?



#11 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 12 February 2020 - 06:29 PM

Yes, ID TheMovieDb: 556



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:46 PM

Posted 12 February 2020 - 07:16 PM

Ok please go through this again and attach the complete emby server log. thanks.



#13 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 12 February 2020 - 07:30 PM

I have detect a problem, two movies with a another collection ID is in the collection, the Homecoming and Far from Home have the ID 531241, but always readd in the collection 556.

 

I will add the log when I will be at home.

 

Thank you



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:46 PM

Posted 12 February 2020 - 07:31 PM

Thanks !



#15 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18435 posts
  • Local time: 07:46 PM
  • LocationWashington State

Posted 12 February 2020 - 07:42 PM

 

Always the exact same entries, that add a new Spider-Man collection entry...

2020-02-11 19:55:25.100 Info Auto Box Sets: Executing Automatic BoxSet creation.  Found 106 potential box sets.
2020-02-11 19:55:25.566 Info Auto Box Sets: Verified set 531241 as Spider-Man Collection - creating...
2020-02-11 19:55:25.826 Info Auto Box Sets: Automatic BoxSet creation completed.
2020-02-11 19:55:26.169 Info TaskManager: Scan media library Completed after 0 minute(s) and 21 seconds

This is a little odd as it should reflect "Spider-Man (Avengers) Collection" for that id.



#16 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 12 February 2020 - 07:55 PM

Effectively Happy2Play...

 

Here is the log, I have made a rotation before refresh 2 times the libraries, and 2 new entries for the Spider-Man collection 556, but nothing for the 531241...

 

Attached Files



#17 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18435 posts
  • Local time: 07:46 PM
  • LocationWashington State

Posted 12 February 2020 - 09:42 PM

Effectively Happy2Play...
 
Here is the log, I have made a rotation before refresh 2 times the libraries, and 2 new entries for the Spider-Man collection 556, but nothing for the 531241...

:) Looks like another Translation issue, as your language translated title is Wrong on TMDB.  Both Collections have the same translated title.


https://api.themoviedb.org/3/collection/531241?api_key=f6bd687ffa63cd282b6ff2c6877f2669&append_to_response=images&language=fr-CA&include_image_language=fr-CA,fr,null,en

https://api.themoviedb.org/3/collection/556?api_key=f6bd687ffa63cd282b6ff2c6877f2669&append_to_response=images&language=fr-CA&include_image_language=fr-CA,fr,null,en

Or should I say there is no Translated title.
 
531241
5e44a76843da1_translate2.jpg
 
5e44a77c42be6_translate.jpg

556
5e44a95a64a0b_translate3.jpg
 
But am not sure why you would get multiple collection entries.  @Luke would have to comment on that.


Edited by Happy2Play, 12 February 2020 - 09:52 PM.


#18 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 18435 posts
  • Local time: 07:46 PM
  • LocationWashington State

Posted 12 February 2020 - 09:48 PM

Knew I just went over this recently.

 

https://emby.media/c...ets-duplicates/


Edited by Happy2Play, 12 February 2020 - 09:49 PM.


#19 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 12 February 2020 - 10:41 PM

I will try it!



#20 Hyp3rD OFFLINE  

Hyp3rD

    Advanced Member

  • Members
  • 121 posts
  • Local time: 10:46 PM

Posted 13 February 2020 - 07:15 PM

I have made the change on themoviedb yesterday at 10pm and After a refresh, the bug is still there.

 

I have made the change on the 2 collections on the website...  :(

 

I have delete all previous entries and when I recreate then and refresh, same pattern, new Spider-Man collection each time...


Edited by Hyp3rD, 13 February 2020 - 07:20 PM.






Also tagged with one or more of these keywords: Collections, bug

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users