Jump to content


Photo

Emby for Android doesn't connect with IPsec VPN.

Android VPN IPsec

  • Please log in to reply
3 replies to this topic

#1 pr1sm OFFLINE  

pr1sm

    Member

  • Members
  • 14 posts
  • Local time: 12:19 AM

Posted 01 February 2020 - 05:45 PM

Hi,

 

I've been having a issue with Emby lately, It's working perfectly through OpenVPN, but not on IPsec.

With IPsec I can connect to Emby through the browser (Chrome and Firefox), but the Android app doesn't connect at all, after opening the app It stays on the loading screen for a while and shows the screen to select servers, Also shows Failed Connection.

With OpenVPN, Emby loads on both browser and App correctly.

 

This isn't a configuration issue with IPsec, since I'm routing everything to my gateway (0.0.0.0/0), Emby even loads normally with the browser.

 

Is there anywhere I can get the logs to known why It isn't connecting?

 

Thanks.


Edited by pr1sm, 01 February 2020 - 05:48 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:19 PM

Posted 03 February 2020 - 02:31 AM

Hi, did you try entering the address manually into the app?



#3 pr1sm OFFLINE  

pr1sm

    Member

  • Members
  • 14 posts
  • Local time: 12:19 AM

Posted 03 February 2020 - 06:17 AM

Hi, did you try entering the address manually into the app?

I've tried this but It didn't worked, The VPN is functioning as expected, but I can't connect to Emby directly with the Android App.

Since I didn't want to use OpenVPN, I've ended up creating a reverse proxy. Now It works.

 

Thanks!



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153190 posts
  • Local time: 10:19 PM

Posted 03 February 2020 - 12:04 PM

Interesting, thanks for the feedback.





Also tagged with one or more of these keywords: Android, VPN, IPsec

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users