Jump to content


Photo

Replaying HEVC in Emby Theater

H265 Emby Premiere HEVC Lag

Best Answer Doofus , 30 December 2019 - 05:22 PM

The lag you're referring to is probably the server transcoding. Yes, using a player that will decode HEVC will stop that happening. Theater for Windows desktop will play everything, natively. Go to the full post


  • Please log in to reply
33 replies to this topic

#21 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13578 posts
  • Local time: 01:18 PM

Posted 04 January 2020 - 05:47 AM

Ah, now the mpv log makes sense. It's playing via a network IP rather than a directory. A stream not a file.

http://IPAddress:809...ea28a9ff24a0aa4
[ 0.047][d][ffmpeg] tcp: Starting connection attempt to IPAddress port 8096
[ 0.061][d][ffmpeg] tcp: Successfully connected to IPAddress port 8096

How do you have your library location set up in Emby? Where are the files located, and how are you sharing them?

#22 schogobong OFFLINE  

schogobong

    Advanced Member

  • Members
  • 86 posts
  • Local time: 10:18 PM

Posted 04 January 2020 - 06:08 AM

That's how the libraries are set up:

 

5e1063fbee063_LibrarySetup.jpg


Edited by schogobong, 04 January 2020 - 11:25 AM.


#23 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13578 posts
  • Local time: 01:18 PM

Posted 04 January 2020 - 12:35 PM

The shared network folder path should be what you see in Windows explorer. Navigate to the folder in Windows explorer and copy what's in the address bar.
  • schogobong likes this

#24 schogobong OFFLINE  

schogobong

    Advanced Member

  • Members
  • 86 posts
  • Local time: 10:18 PM

Posted 04 January 2020 - 12:59 PM

Ha - like magic! So that makes the experience a whole lot better :) Can't believe I was using the wrong settings all this time... thanks :)

 

But when connecting remotely, the issue is still there (long loading with Emby Theater from the Emby site; no playback (or at least not withing around 40 seconds) whith Emby Theater from the Windows Store). At the same time, I am not having any issues at all when using the Android app.

 

Any idea what that is about?



#25 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13578 posts
  • Local time: 01:18 PM

Posted 04 January 2020 - 01:03 PM

When remote, that is likely due to transcoding. Is there a transcode log? Having a NAS transcode is hard work. They aren't designed for that kind of load.

#26 schogobong OFFLINE  

schogobong

    Advanced Member

  • Members
  • 86 posts
  • Local time: 10:18 PM

Posted 04 January 2020 - 01:17 PM

For some reason playback with Emby Theater from the Emby website (let's call this by its version 3.0.10) doesn't create a transcode log - playback actually seems to have improved even when being remotely connected.

 

On the version from the Microsoft store (version 1.1...) I'm still not getting a playback of that file, so I'm also not getting a transcode log. But I just found one from earlier today (playing back a different file). Maybe this helps?

 

Is there no way to access the file directly and transcoding on the machine when accessing remotely? Why can a playback with no issues on the Android App but not on the Microsoft Store App?

Attached Files



#27 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13578 posts
  • Local time: 01:18 PM

Posted 04 January 2020 - 01:34 PM

The store app and Android mobile app have different players. The Android mobile app has the same player as 3.0.10. But the store app is using the Windows standard player, which is basically, crap.

#28 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13578 posts
  • Local time: 01:18 PM

Posted 04 January 2020 - 01:45 PM

And it appears as though you are using subs. Try turning subs off.
  • schogobong likes this

#29 schogobong OFFLINE  

schogobong

    Advanced Member

  • Members
  • 86 posts
  • Local time: 10:18 PM

Posted 04 January 2020 - 01:52 PM

And it appears as though you are using subs. Try turning subs off.

 

Wow ^^ That actually did the trick when playing the file locally! I mean, it's not ideal that it doesn't work with subs ;) but at least now it plays properly :) CPU usage has also gone down considerably.

 

Remotely there is considerable lag - but maybe that has something to do with player. It's kind of a pity, that the Microsoft Store app (which I think is better from a UI-perspective and probably is more in line with what Microsoft is doing) doesn't work properly.

 

But as long as I've got one working app I'm happy :)


  • Doofus likes this

#30 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13578 posts
  • Local time: 01:18 PM

Posted 04 January 2020 - 01:57 PM

For subs, it's best to use external srt files.

#31 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13578 posts
  • Local time: 01:18 PM

Posted 04 January 2020 - 02:13 PM

And you can change the UI layout in 3.0.10. Have you look at the settings?

#32 schogobong OFFLINE  

schogobong

    Advanced Member

  • Members
  • 86 posts
  • Local time: 10:18 PM

Posted 04 January 2020 - 02:20 PM

For subs, it's best to use external srt files.

 

Will do that, thanks for the tip!

 

And you can change the UI layout in 3.0.10. Have you look at the settings?

I have, but for example: I'm not able to re-size the window. Well not really "for example" - that's the main issue I've come across so far.



#33 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 13578 posts
  • Local time: 01:18 PM

Posted 04 January 2020 - 02:31 PM

You mean resize when playing? Yeah, Luke has that locked down because of electron. The whole UI is in the process of being rebuilt. So when that's finished, we may have more fancy shmancy stuff :)

#34 schogobong OFFLINE  

schogobong

    Advanced Member

  • Members
  • 86 posts
  • Local time: 10:18 PM

Posted 04 January 2020 - 05:16 PM

Yeah exactly - looking forward to that :)

 

Thanks for your support!


Edited by schogobong, 04 January 2020 - 05:16 PM.

  • Doofus likes this





Also tagged with one or more of these keywords: H265, Emby Premiere, HEVC, Lag

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users