Jump to content
maeffjus

emby on Rock64Pro does not properly show folders / playback not working properly

Recommended Posts

maeffjus

Hi Guys,
 

this refers to here: https://emby.media/community/index.php?/topic/77892-raspberry-pi4-nas-for-server/page-2

But since the topic is a bit different, I guess no one does even read it..

So let me summarize the problem:

I got folders for movies and for TV-shows.
The are structured as follows:
a) movies \\smb-share_whatever\videos\movies\action\Rambo 1\Rambo 1.mkv (or mp4 or avi)

B) tv-shows \\smb-share_whatever\videos\TV-shows\Friends\Season01\S01E01.mkv (or mp4 or avi)

Every folder does have a Backdrop.jpeg and a folder.jpg, the genre-folders for the movies also do have a folder.jpg.
Since I got an "old" server (Windows 2012 R2), it also does access these files, which are on its RAID-Volume. (~8TB)

Here it works perfectly, the overview shows movies and TV-shows and when you click one of them, you see the genres under movies.

Now for the Rock64Pro-board with Armbian-Buster:

I've mounted the SMB-share under /mnt, I can easily access both, movies AND TV-shows and also read them. (I've even tried via WinSCP to copy them being read from the /mnt).
I've then added separately movies (content-type "movies" and TV-shows (content-type "TV-shows") to emby.
The TV-shows are recognized and can be played easily.
The movies show-up empty as there would be no content or it is not readable or not recognized.

I removed the movies and added them as "mixed content" - same story.

Since I want to retire the Win2k12-Server, I also have a NAS, which offers an SMB-share to my network.
I've also the same files on the NAS, same folders - only different IP.

When I add the movies from my NAS, emby does recognize them BUT:

I) It does not show the folder-structure, only when I select the list-option "folders".
On my windows-server it does it as a standard. Here it shows all movies (~1550) in a bulk-list.

II) It does NOT play the movies. When I click one, the player seems to load and then it says "there are no compatible streams available."
But it does play the TV-shows from the Win2K12-Server... (I've got my emby-premium on both registered, it is a lifetime-key)

So - tons of problems - only because of my effort to save the 125W my server consumes 24/7 ;-)

I'd highly appreciate if you can give me some help.
Regards,
Matthias

Share this post


Link to post
Share on other sites
JaScoMa

Hello..

Since you're still in the testing phase, I'd wipe and start with DietPI (https://www.dietpi.com).  Even thought there's not a buster version for the RockPro64, the stretch version works just fine.

 

During the first power-up and configuration phase of DietPI, have the RockPro connected to a monitor so you can get it's IP address and then finish the configuration using Putty or something similar.  dietpi-config is the program required to complete the configuration of the system; static IP, etc.

 

Also within dietpi-config, there's a "Network Options: Misc" option which will allow you to connect to a SMB share or your NAS.  After entering the IP address and credentials of the share followed by the /mnt folder location, DietPI will test the connection to see if its successful.  If so, it'll write to the /etc/fstab so that this will be mounted every time the system restarts.

 

dietpi-software is run to install the Emby package.  This will go out and grab the latest version of Emby from Github and download it for you.  It'll also setup an Emby group/user for you automatically as well.  Run dietpi-software, select "Software Optimised" and then scroll down and find emby.  Select Emby, tab to OK, then scroll down and select Install.  This will then install the Emby package for you and do the proper configuration.

 

Once this is done and it looks like the connection to your NAS was successful, and emby was installed, you still need to grant access to the Emby user/group to that share.  This is done by editing the /etc/fstab file; e.g.  "nano /etc/fstab"

 

For example, my fstab looks like this:

#----------------------------------------------------------------
# NETWORK
#----------------------------------------------------------------
//10.1.1.4/MediaServer /mnt/MediaServer cifs username=nasembyuser,password=nasembyuser1234,iocharset=utf8,uid=emby,gid=emby,file_mode=0770,dir_mode=0770,vers=3.0,_netdev,nofail
//10.1.1.4/EmbyUpdates /mnt/EmbyUpdates cifs username=nasembyuser,password=nasembyuser1234,iocharset=utf8,uid=emby,gid=emby,file_mode=0770,dir_mode=0770,vers=3.0,_netdev,nofail
 
You can see my NAS IP and it's shares (I have two; MediaServer which contains all my media and EmbyUpdates where I download the Emby updates to).
 
CIFS allows for SMB connections.
 
You can see the folder locations within /mnt which shows where these shares are mounted to; again MediaServer and EmbyUpdates
 
Username and password are the credentials on the NAS to access those shares.  Think of cascading permissions.  Anything denied, gets higher priority over everything else.  If the NAS user has only read-only access for a share within the NAS, then they'll only have read-only access on the system.  Anyway..
 
Now here's an important part, UID/GID.  These are your userID and GroupID on the RockPro system and these need to be changed to from dietpi to emby.  This way when the system is restarted, the mounts will have Emby configured as the owners of the mount points.
 
file_mode and dir_mode are the permissions set for the UID/GID for the mount point folder/files.  For example, 0770 gives full access to OWNER, and GROUP, but no access to anonymous; 770.  This is configured for both all the directories and all the files within that mount point.  And as I was stating prior, if the share permissions are only configured for read-only on the share point, these permissions on the system won't matter.  The share permissions only allow for read-only access.
 
ver=3.0 is the SMB version.  This is depending on what your NAS supports.  More modern NAS's allow for SMB v3 and Windows 8 and above too  I believe dietpi will automatically test this when you do the auto-mount.  But there's different version; 1, 2.1 and 3.  You can change this to see what your NAS supprots.
 
After you make these changes, save the file and exit nano.  Next issue the following command "mount -a" which will then attempt to re-mount these via the updated commands.  If successful, you should be able to access your mount folders and see everything from the system.
 
Next, open a browser and access Emby (http://%serverip%:8096) and if everything is good, complete the configuration of emby with your media folders, etc.
 
Hope this isn't too confusing and helps.
  • Like 1

Share this post


Link to post
Share on other sites
JaScoMa

Also, I've had issues with the latest version of Emby v4.3.0.30; it'll crash immediately when trying to play a MKV file.  But the v4.3.0.24 beta plays fine; you may have to do the same.

 

But to update or downgrade Emby, download the file and then issue the following commands.

 

If Emby dashboard is up and running, shut down emby this way.

 

If you can't access emby through the web, issue the following command from within DietPI:  "dietpi-services stop"

 

Then issue the following command:

dpkg -i /mnt/EmbyUpdates/aarch64_emby_releases/beta/emby-server-deb_4.3.0.24_arm64.deb

 

dpkg - Debian Package Manager

-i - Install

/mnt/EmbyUpdates/aarch64_emby_releases/beta/ - my Emby Updates mount on the NAS.  My laptop has access to this share as well and download the debian package on windows and upload here.

emby-server-deb_4.3.0.24_arm64.deb - this is the debian installer package which I downloaded from the Emby website.  Ensure you get the proper version and the version numbers will change.

 

This will install the version you specify and automatically restart Emby.  If downgrading,  you will be notified of such.

 

Hope this helps.

Edited by JaScoMa
  • Like 1

Share this post


Link to post
Share on other sites
maeffjus

Thanks for all your explanation!
The good thing is, no need for me to prepare a long answer, only one issue is left:

Sorting: What can I do to see the movies sorted by folders instead of a bulk-list with all files?

Everything else works fine, also transcoding!

Share this post


Link to post
Share on other sites
JaScoMa

Sorting: What can I do to see the movies sorted by folders instead of a bulk-list with all files?

 

Everything else works fine, also transcoding!

 

That's good to hear.  Glad you were able to get things working.  I think as SBC get more powerful, they'll make very viable replacements to full PC systems.  Since getting my RockPro64 (and the nVidia Sheild), I've had zero issues playing movies, etc., all the while using a 5w power supply, which is a big plus.

 

Are you talking about listing of folders from within Emby?  From the web browser, there is a option to display by folders.

 

I have my folders for my movies and tv shows on the NAS configured as "Folder" -> "Letter" -> "Movie Name (Year)" -> "Movie Name (Year).suffix".  I use the complex naming convention as described here: https://github.com/MediaBrowser/Wiki/wiki/Movie-naming#complex-folder-structure

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...