Jump to content
Doctor_F

DLNA and 401 http status

Recommended Posts

Doctor_F
Hi. I trying to use dlna for emby, but I got errors in all devices. I see in logs the next exception:

2019-12-02 14:26:21.647 Error HttpServer: Access token is invalid or expired.

I have 2 users:

one with a password and one without it. But I can't log in user in dlna

How I can disable authorization for dlna profile?

I trying to set user without a password, but the same. 401 exception after reading file.

Version emby: 4.3.0.30

Share this post


Link to post
Share on other sites
Luke

Hi there, please attach the emby server log. thanks.

Share this post


Link to post
Share on other sites
Doctor_F

Hi Luke. I attached logs.

 

I see all files, but when I send request to get flow:

2019-12-03 08:26:36.766 Info HttpServer: HTTP GET http://192.168.1.35:8096/videos/59286/stream.mkv?DeviceId=e54bb9714c34b4c1af2f4074dcdca8c4&MediaSourceId=7df09e815104599f5ba50a4337dbe6ec&Static=true&PlaySessionId=cba33fd4571c34c89667ad98eda7b300. Host=192.168.1.35:8096, Accept=*/*, Accept-Language=en_US, User-Agent=VLC/3.0.9 LibVLC/3.0.9, Range=bytes=0-

I got next exception:

2019-12-03 08:26:36.779 Error HttpServer: Access token is invalid or expired.

Share this post


Link to post
Share on other sites
Luke

Hi there, please attach the complete emby server log file. thanks.

Share this post


Link to post
Share on other sites
Doctor_F

Hi Luke. Sorry, I missing button Attach :-) . Here is full log on debug mode. Maybe it will be helfull

emby_debug_logs.txt

Share this post


Link to post
Share on other sites
Luke

Hi, are your dlna devices on a different network?

Share this post


Link to post
Share on other sites
Doctor_F

The same network. But I connecting by wifi to the server, that connected by LAN cable. Could this affect?

Share this post


Link to post
Share on other sites
Luke

Do the dlna devices have 89.x ip addresses?

Share this post


Link to post
Share on other sites
Doctor_F

Yes. They connected to one router with static ip start with 89.x

Share this post


Link to post
Share on other sites
Luke

So the server sees those devices and thinks they're outside your local network. You'll need to configure the LAN networks setting so that it will think the 89.x ip addresses are inside your network.

 

But when you do that, make sure to include 192.X as well so those ip addresses aren't impacted by the change.

Share this post


Link to post
Share on other sites
Doctor_F
Thanks! it helped.

 

I added static ip and my local network to the LAN network and it helps.

 

Could you please add static IP of router add to the verification of dlna devices?

My server and my devices have the same static ip and it will be good if emby detects, that they connected to one router.

Share this post


Link to post
Share on other sites
Luke

It might be difficult for us to detect that, although it's not a bad idea. The LAN networks setting should do the trick for now though. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...