Jump to content


Photo

TV Show audio files defaulting to foreign language - despite English settings

language tvshows audio

  • Please log in to reply
4 replies to this topic

#1 piecesofme OFFLINE  

piecesofme

    Advanced Member

  • Members
  • 39 posts
  • Local time: 09:06 AM

Posted 12 November 2019 - 04:32 PM

Hello,
 
One of my TV shows is defaulting to a non-English language track and I cannot seem to fix it. I have my languages set to English in the settings but it doesn’t seem to help. I refreshed the metadata and also set English in the TV show settings (even though it should have inherited that from the global language/location settings) and it hasn’t helped. Not to try to compare but for reference, I checked how Plex views the same files and it defaults to English. I’ve also had Emby rescan the files to see if it was a glitch. It is doing this in the web client as well as the Roku client.
 
 Could anyone please help me figure out what to do to fix this? We also use these files in a playlist and I cannot be changing over to English everytime it switches to the next show. Thanks so much in advance![/size]



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 145887 posts
  • Local time: 09:06 AM

Posted 12 November 2019 - 04:34 PM

Hi, remember that track selections are saved for individual video files, so for best results you should test this on a video file that you haven't played before. How did you configure your subtitle preferences for your Emby user?



#3 piecesofme OFFLINE  

piecesofme

    Advanced Member

  • Members
  • 39 posts
  • Local time: 09:06 AM

Posted 12 November 2019 - 11:29 PM

Hi, remember that track selections are saved for individual video files, so for best results you should test this on a video file that you haven't played before. How did you configure your subtitle preferences for your Emby user?

 

I’m sorry, I don’t fully understand what you mean. This was the first time that I had played these files.

 

My subtitles were setup when I first set the Library info. I setup English subtitles, the correct country, etc. It seems to be fine on most other things just not these files. It’s saying that the default audio track in a non-English one - and I’ve certainly never indicated that. What do I do next to try to fix this?



#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 48929 posts
  • Local time: 09:06 AM

Posted 13 November 2019 - 09:34 AM

It’s saying that the default audio track in a non-English one 

 

 

What "is saying" that?  If your tracks are not tagged properly, then the logic for selecting them won't work properly.

 

Are all the tracks properly tagged with language?  Do you perhaps have multiple tracks marked as "Default"?



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 145887 posts
  • Local time: 09:06 AM

Posted 13 November 2019 - 03:39 PM

Yea we can we please go over a specific example? thanks.







Also tagged with one or more of these keywords: language, tvshows, audio

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users