Jump to content
Gulan

Subtitle settings

Recommended Posts

Gulan

Hi,

 

I use my video files(mkv) with srt subtitles.

For a while it seemed so that you only had one size for the subtitle and the black background for subtitles were not removable.

With the new version (1.0.19) under settings there came a "subtitle appearance" setting where you could set the font size, color and drop shadow.

Oddly enough this does not seem to work with any of my MKV with srt subtitles.

The subtitle stays with black background and one font size and white letters.
 

Am I missing something?  If you include something like drop shadow, i would expect also that the black background would dissappear because otherwise this would be a useless setting.

But maybe it doesn't work with external srt subs?

 

Thanks in advance for any advise.

 

WEB OS (5.10.20)

Edited by Gulan

Share this post


Link to post
Share on other sites
Gulan

Hi,

 

hope you have here what you need.

I did several tests with a band of brothers file (in between i checked debug logging on the server), the last test was at 11.40.

 

For what is worth.

When i first used Emby (server on Synology) the subtitles where without black background.  The black backgrounds however are already longer there than the latest version.

90% is mkv with srt. And they all seem to act the same.

 

 

post-356579-0-36700900-1572173638_thumb.jpg

embyserver.txt

post-356579-0-30719300-1572173684_thumb.jpg

Share this post


Link to post
Share on other sites
CarlosLima

+1

Share this post


Link to post
Share on other sites
Luke

Hi, yes looks like there's an issue with this on WebOS 3+. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
SamES

@@Gulan, can you please let me know what model your TV is?

 

Can you also please attach the media info for the item playing in your thumbnail attachment above?  Thanks

Share this post


Link to post
Share on other sites
SamES

It's an OLED55C8PLA

 

Thanks, I'll see if I can reproduce this.

Share this post


Link to post
Share on other sites
SamES

Are you still running 1.0.19 or 1.0.20?  

 

Can you please confirm this issue still exists with 1.0.20?  I can't reproduce this using an mkv with an external srt file.

 

Can you confirm it is Direct Playing when you have this issue?

  • Like 1

Share this post


Link to post
Share on other sites
rbjtech

Are you still running 1.0.19 or 1.0.20?  

 

 

This - I tested on 1.0.19 originally and this did not work for me - but just retested on 1.0.20 and this now works.  This is on an LG OLED65C8PLA

 

ps - Any chance of adding GREY to the colours list - that would then sort out the HDR subtitle brightness issue midway through this thread .. :)

  • Like 1

Share this post


Link to post
Share on other sites
Gulan

I use latest version 1.0.20

Pretty sure it's direct play.

Share this post


Link to post
Share on other sites
SamES

This - I tested on 1.0.19 originally and this did not work for me - but just retested on 1.0.20 and this now works.  This is on an LG OLED65C8PLA

 

ps - Any chance of adding GREY to the colours list - that would then sort out the HDR subtitle brightness issue midway through this thread .. :)

 

Great, thanks for the feedback. Yes, Grey would help that

Share this post


Link to post
Share on other sites
SamES

I use latest version 1.0.20

Pretty sure it's direct play.

 

So can you please confirm again whether you still have this issue, as it should have been resolved in 1.0.20

Share this post


Link to post
Share on other sites
Gulan

No,the issue is not resolved for me

I reinstalled the tv app again to be sure but every movie has the black bars.

Share this post


Link to post
Share on other sites
Luke

No,the issue is not resolved for me

I reinstalled the tv app again to be sure but every movie has the black bars.

 

What version of the LG app?

Share this post


Link to post
Share on other sites
Gulan

like I said: 1.0.20.  It's all latest version.

Share this post


Link to post
Share on other sites
SamES

Can you please supply the media info for a sample? Is this internal or external subs?

Share this post


Link to post
Share on other sites
Gulan

Can you please supply the media info for a sample? Is this internal or external subs?

it's all in my earlier responses (look above in the thread)

Share this post


Link to post
Share on other sites
SamES

it's all in my earlier responses (look above in the thread)

 

Sorry, this thread has gotten a bit confusing.  Solving two problems at once.

 

Can you please test playback with this movie, then attach or PM a copy of the server log?  I can't reproduce this with 1.0.20 using DirectPlay and an mkv with an external srt file

Share this post


Link to post
Share on other sites
SamES

Actually, it might also help if you enable debug logging for this test please.

Share this post


Link to post
Share on other sites
rbjtech

.. so in a bid to help a fellow LG OLED TV owner  ;) - I've played exactly the same band of Brothers MKV with external SRT and compared the .srt > .vtt conversion line.

 

OP's

 

ProcessRun 'ffmpeg-subtitle_convert' Execute: /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg  -sub_charenc windows-1252 -i "/volume1/Nasmedia/Films en Series/Series/Band Of Brothers/Band of Brothers - 1x01 - Currahee.srt" "/volume1/Nasmedia/Cache/cache/subtitles/d/d4275dd5cf742b41d9aea286627de5a9_635889980654578520_2_0_0_False.vtt"

 

Mine (working - no Black background)

 

ProcessRun 'ffmpeg-subtitle_convert' Execute: C:\Users\Emby_Service\AppData\Roaming\Emby-Server\system\ffmpeg.exe  -sub_charenc ASCII -i "\\server\TV Series 2\Band of Brothers (2001)\Season 1\Band of Brothers - S01E01 - Currahee.english.srt" "C:\Users\Emby_Service\AppData\Roaming\Emby-Server\programdata\cache\subtitles\7\7d6642f6ed162cdd31734561d58c0a07_636920550718414673_3_0_0_False.vtt"

 

Could this be the reason ?  ie different CHARSET ?  Are there any extended characters in your subtitles ? (ie non ASCII)

 

My converted .VTT file looks like this :-

 

WEBVTT
 
00:07.800 --> 00:13.560
We were in a store, and a guy in that
store told us to put our uniforms on.
 
00:13.980 --> 00:17.020
"What the hell are you talking about?"
 
00:17.310 --> 00:21.730
He says, "The U.S.A.'s
in a war with Japan." ..........

 

- maybe worth checking the OP's .VTT file ?

Edited by rbjtech
  • Like 1

Share this post


Link to post
Share on other sites
Gulan

.. so in a bid to help a fellow LG OLED TV owner  ;) - I've played exactly the same band of Brothers MKV with external SRT and compared the .srt > .vtt conversion line.

 

OP's

 

ProcessRun 'ffmpeg-subtitle_convert' Execute: /var/packages/EmbyServer/target/ffmpeg/bin/ffmpeg  -sub_charenc windows-1252 -i "/volume1/Nasmedia/Films en Series/Series/Band Of Brothers/Band of Brothers - 1x01 - Currahee.srt" "/volume1/Nasmedia/Cache/cache/subtitles/d/d4275dd5cf742b41d9aea286627de5a9_635889980654578520_2_0_0_False.vtt"

 

Mine (working - no Black background)

 

ProcessRun 'ffmpeg-subtitle_convert' Execute: C:\Users\Emby_Service\AppData\Roaming\Emby-Server\system\ffmpeg.exe  -sub_charenc ASCII -i "\\server\TV Series 2\Band of Brothers (2001)\Season 1\Band of Brothers - S01E01 - Currahee.english.srt" "C:\Users\Emby_Service\AppData\Roaming\Emby-Server\programdata\cache\subtitles\7\7d6642f6ed162cdd31734561d58c0a07_636920550718414673_3_0_0_False.vtt"

 

Could this be the reason ?  ie different CHARSET ?  Are there any extended characters in your subtitles ? (ie non ASCII)

 

....

 

Hi fellow helper,

 

you nailed it: i opened my srt in a simple notepad and saved it back.  In the bottom of notepad I see "coding" set as ANSI.  I changed it to UTF-8 and it worked! (no black bars anymore)

First simple test with some odd characters which you don't use in english (my language is dutch) showed no problem with UTF-8.

 

So question is: do you think i can use UTF-8 or should my standard coding also be "fixed" in the future. (because otherwise it is a bit of work for me).

 

Thanks for every bit of help everyone.

Edited by Gulan

Share this post


Link to post
Share on other sites
rbjtech

So question is: do you think i can use UTF-8 or should my standard coding also be "fixed" in the future. (because otherwise it is a bit of work for me).

 

Good news  :)

 

So according to Wiki - VTT supports UTF-8 extended characters just fine.

 

https://en.wikipedia.org/wiki/WebVTT

 

So perhaps the emby team need to ensure any SRT>VTT coding is done to the UTF-8 standard - perhaps a command line in ffmpeg may force it.

Share this post


Link to post
Share on other sites
SamES

Good news  :)

 

So according to Wiki - VTT supports UTF-8 extended characters just fine.

 

https://en.wikipedia.org/wiki/WebVTT

 

So perhaps the emby team need to ensure any SRT>VTT coding is done to the UTF-8 standard - perhaps a command line in ffmpeg may force it.

 

Excellent job, that's a great find.  Thanks for solving it.  So do you think just changing the ffmpeg command line would have resolved this rather than resaving the file with UTF-8?

 

Can I please get a copy of just the srt before and after the change?

 

@@Luke, do you think this can be handled on the server wrt setting the character set?  Do you think that change on it's own will resolve this?

 

I am a little curious as to why this prevents the subtitle styling from being applied.  I want to test this some more

Edited by SamES

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...