Jump to content
JMR

No sound after pausing

Recommended Posts

JMR

When i pause when playing hd audio the sound does not come back i have to hit return thrn resume to get the sound back regular audio works fine

Share this post


Link to post
Share on other sites
Guest asrequested

What app are you using? And are you using an AV receiver?

Share this post


Link to post
Share on other sites
JMR

I am using the player in desk top windows theater Yamaha receiver and it only does this on hd audio power dvd and mpc-be work fine

Share this post


Link to post
Share on other sites
JMR

I am just going back to using external player Thanks for help

Share this post


Link to post
Share on other sites
Luke

Can't it be easily solved via mpv.conf?

Share this post


Link to post
Share on other sites
Guest asrequested

Can't it be easily solved via mpv.conf?

 

I think so. I think what I linked to will solve it.

 

Luke, is there a way you can add a text field in the settings that will write to an mpv.conf? Like the way the android app does it. That way I don't have to keep linking people to various instructions on how to use an mpv.conf. Like for example, in this case, I could have simply told them to add this line.

audio-stream-silence=yes

Share this post


Link to post
Share on other sites
Luke

Yea that's not a bad idea.

Share this post


Link to post
Share on other sites
knutsont

Hi guys. I am having the same issue as the OP, and I was hoping you might elaborate a little on the proposed fix. I'm running Emby Theater on Win 10, feeding to a Yamaha pre-pro. I've tested DTS-MA and TrueHD, and if I pause for more than a few seconds and resume, there is no audio while video continues as normal. Looking at the receiver, it looks like it does not have a bitstream coming to it (or it is ignoring it). The only way to get it back is to stop playback and restart.

 

I've tried all the available audio and video setting options to no avail, and I too was thinking of just using an external player (MPC-HC), as I have with an old version of Media Browser to date. I'm in the process of finally migrating all of my systems to Emby, so I'm hopeful we can troubleshoot a root cause and solution, though.

Edited by knutsont

Share this post


Link to post
Share on other sites
Luke

Hi guys. I am having the same issue as the OP, and I was hoping you might elaborate a little on the proposed fix. I'm running Emby Theater on Win 10, feeding to a Yamaha pre-pro. I've tested DTS-MA and TrueHD, and if I pause for more than a few seconds and resume, there is no audio while video continues as normal. Looking at the receiver, it looks like it does not have a bitstream coming to it (or it is ignoring it). The only way to get it back is to stop playback and restart.

 

I've tried all the available audio and video setting options to no avail, and I too was thinking of just using an external player (MPC-HC), as I have with an old version of Media Browser to date. I'm in the process of finally migrating all of my systems to Emby, so I'm hopeful we can troubleshoot a root cause and solution, though.

 

hi, can you try our test version in this thread and let us know if it happens with that:

https://emby.media/community/index.php?/topic/46763-theater-mpv-test/

 

Thanks.

Share this post


Link to post
Share on other sites
knutsont

I've tried the test app, and the dropped audio after pause persisted.  There was also noticeable AV de-sync with this version.

 

If it matters, I backed up my System folder with in the Emby Theater folder, deleted the contents, and then extracted the contents of the zip file to the System folder.  I did not attempt to modify or troubleshoot any of the settings with the test app.

 

The theory that the receiver looses handshake with the player once the bitstream is stopped makes sense.  It's almost like it needs some beginning "header" information to start the stream again, which is does not get when the paused movie is resumed.  I may be using incorrect terms here...I'm not super familiar with the technical underpinnings of bitstream audio.  Is there a way to modify the standard player to function as described in the linked thread - to play silence on pause vs stopping the stream?

Share this post


Link to post
Share on other sites
Luke

@ wasn't there an mpv conf option to fix this?

Share this post


Link to post
Share on other sites
Guest asrequested

Yup, post #7

Share this post


Link to post
Share on other sites
Guest asrequested

There really should be an easy way for a new user to use options

 

 

 

Luke, is there a way you can add a text field in the settings that will write to an mpv.conf? Like the way the android app does it. That way I don't have to keep linking people to various instructions on how to use an mpv.conf. Like for example, in this case, I could have simply told them to add this line.

audio-stream-silence=yes

 

 

Yea that's not a bad idea.

Share this post


Link to post
Share on other sites
Guest asrequested

I've tried the test app, and the dropped audio after pause persisted.  There was also noticeable AV de-sync with this version.

 

If it matters, I backed up my System folder with in the Emby Theater folder, deleted the contents, and then extracted the contents of the zip file to the System folder.  I did not attempt to modify or troubleshoot any of the settings with the test app.

 

The theory that the receiver looses handshake with the player once the bitstream is stopped makes sense.  It's almost like it needs some beginning "header" information to start the stream again, which is does not get when the paused movie is resumed.  I may be using incorrect terms here...I'm not super familiar with the technical underpinnings of bitstream audio.  Is there a way to modify the standard player to function as described in the linked thread - to play silence on pause vs stopping the stream?

 

You should run it from its own folder.

 

And to use that option, you need to create an mpv.conf and add that line. Follow this guide to make an mpv.conf

 

https://emby.media/community/index.php?/topic/50975-how-to-enable-mpv-logging-for-theater/

 

Then add that line at the top

Share this post


Link to post
Share on other sites
knutsont

Ok, I have the idea now. I'll give it a shot and report back.

Share this post


Link to post
Share on other sites
Luke

Let us know how you get on. Thanks.

Share this post


Link to post
Share on other sites
knutsont

Alright, guys...still no luck.  And by the way, thanks for the quick responses here and apologies it has taken me a couple of days to get back to this.

 

What I tried:

- Extracted the zip to a folder named Emby-Theater in the /appdata/roaming folder (renamed the previous install Emby-Theater-Orig first).

- An mpv folder already existed at /appdata/roaming and was empty.  I created a text file with notepad and named it mpv.conf.

- I added a single line of text in the following variants, one at a time and tested: audio-stream-silence=yes; -audio-stream-silence=yes; --audio-stream-silence=yes (I wasn't sure if the preceding dashes were necessary, so I tried each variant)

 

The result when pausing was the same.  Immediately when paused, the processor display switched from "DTS-MA" to "Decoder Off"...then after about 3 seconds to "Analog."  On resume, it switched to "Decoder Off," and there was no audio.

Again, the theory from what I'm reading sounds like this should work.  Given the processor display, I'm not convinced the app is actually doing what is intended, either because I don't have it configured correctly or something else.

 

If it matters, it is a Yamaha Aventage CX-A5100 Pre-Pro.

 

Thoughts?

Share this post


Link to post
Share on other sites
Guest asrequested

I'm attaching a standalone of mpv. Unzip the folder anywhere, drag 'n' drop your movie on mpv.exe. It should launch and start playing. Use the space bar on your keyboard to toggle pausing. Tell me if it works. If it doesn't, an mpv log will written in the same folder as the movie, attach that log.

Share this post


Link to post
Share on other sites
knutsont

@

 

Thanks, yes, this works.  When paused, it displays "Decoder Off," but it never switches to "Analog."  On resume, audio restores immediately.  This tells me I have something wrong in my configuration file or location.  I will try the options you have included in the .conf file.  Would you confirm the correct path for the .conf file to be in.../appdata/roaming/mpv?

Edited by knutsont

Share this post


Link to post
Share on other sites
Guest asrequested

@

 

Thanks, yes, this works.  When paused, it displays "Decoder Off," but it never switches to "Analog."  On resume, audio restores immediately.  This tells me I have something wrong in my configuration file or location.  I will try the options you have included in the .conf file.  Would you confirm the correct path for the .conf file to be in.../appdata/roaming/mpv?

 

No, I think it's to do with exclusivity. In the audio settings in Theater, do you have exclusive mode, enabled?

 

And yes, that is a good place to put the mpv.conf. Be careful to not have more that one, as mpv will use them all. The standalone I gave you, I made that portable, so it won't affect anything else. 

Edited by Doofus

Share this post


Link to post
Share on other sites
knutsont

Ok, really silly solution found. This PC is a new build, migrating from Win7 to Win10, and I had not yet turned on file extensions. So my mpv.conf file was actually mpv.conf.txt. You know you're getting old when...

 

Once that was corrected, the .conf file fixed the audio streaming problem nicely. Thanks again for your patience working through this with me!

Share this post


Link to post
Share on other sites
knutsont

One more quick question...Will the MPV player that is built into the standard release of Emby Theater accept arguments from a .conf file, or is it necessary to use this particular release?

Share this post


Link to post
Share on other sites
Guest asrequested

One more quick question...Will the MPV player that is built into the standard release of Emby Theater accept arguments from a .conf file, or is it necessary to use this particular release?

It will always read it, even if you uninstall and reinstall.

Share this post


Link to post
Share on other sites
StopTheExcuses

Hello!  Yes, I did search and found this....https://emby.media/community/index.php?/topic/76789-no-sound-after-pausing/

 

How do I effectively implement this fix?  The link to the tutorial was broken.

 

Some background information.  I've been using Emby for a few years and LOVE it, especially how easy it is to organize and change the metadata.  This really helps with large librarys.

Recently Kodi stopped adding fresh thumbnails so I purchased Emby Premiere so I could play direct and use Emby Theater and move on from Kodi completely.  It has been GREAT except for one issue.  When I pause a movie with HD audio and resume it, there is no sound. The only work around I've found is to exit and resume play which isn't a deal breaker, but it is rather annoying.  Any known quick fixes or setting change to resolve.  Thanks!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...