Jump to content


Photo

Auto Quality not adjusting for Slower Networks -Just Spins

Sprint Auto Quality Cellular 1080p 720p

Best Answer tekfranz , 01 September 2019 - 11:37 PM

Since the last update Auto Playback Mode on Cellular is much improved.

I am now seeing the playback progress forward rather than freeze and spin.

Thanks for your hard work on this! Go to the full post


  • Please log in to reply
6 replies to this topic

#1 tekfranz OFFLINE  

tekfranz

    Member

  • Members
  • 15 posts
  • Local time: 04:16 AM

Posted 01 August 2019 - 11:02 AM

Hello we really like EMBY Server. We recently switch to a very inexpensive Sprint plan so our streaming bandwidth is probably lower.

 

When we leave our home WiFi network, Emby will spin and stutter trying to play a higher bandwidth until we manually lower the bandwidth to a lower setting.

 

How does the Auto Quality feature work? It doesn't seem to be doing anything to resolve the stuttering unless for example we kill and restart the App and restart the stream several times.

 

Our solution is to manually limit the network to 720-1 Mbps. (BTW what's the visual difference between 720-1Mbps and say 720-3Mbps?)

 

Is there any sort of of "Automatic Quality switching while in Stream Based on Network conditions" planned since it seems to be very limited right now adjusting the stream once per app session or less.


Edited by tekfranz, 01 August 2019 - 11:08 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 06:16 AM

Posted 01 August 2019 - 03:26 PM

Hi there, did you start playing on your home network and then transition? Or was it off network the whole time?



#3 tekfranz OFFLINE  

tekfranz

    Member

  • Members
  • 15 posts
  • Local time: 04:16 AM

Posted 01 August 2019 - 03:38 PM

Yes I also wondered about switching from the WiFi internal network to the Cellular Network while streaming.

 

However, I do not believe the issue is only the network switch.

 

I can reproduce the issue on Cellular Only as well if I restart the App with WiFi turned off and Cellular On and set Playback --> Internet to Auto. It plays about about 1-2 seconds in 1080p and stops and keeps starting and stopping.  The starting and stopping never resolves. It plays 1-2 Seconds and then stops. I would have expected it to drop quality until EBMY found a quality setting that worked. (In my case 720p-1Mbps).


Edited by tekfranz, 01 August 2019 - 03:40 PM.


#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 06:16 AM

Posted 01 August 2019 - 11:22 PM

Thanks for reporting. We'll look at improving this.


  • tekfranz likes this

#5 tekfranz OFFLINE  

tekfranz

    Member

  • Members
  • 15 posts
  • Local time: 04:16 AM

Posted 01 August 2019 - 11:25 PM

Thanks for reporting. We'll look at improving this.

 

Thanks Luke!



#6 tekfranz OFFLINE  

tekfranz

    Member

  • Members
  • 15 posts
  • Local time: 04:16 AM

Posted 01 September 2019 - 11:37 PM   Best Answer

Since the last update Auto Playback Mode on Cellular is much improved.

I am now seeing the playback progress forward rather than freeze and spin.

Thanks for your hard work on this!

Edited by tekfranz, 01 September 2019 - 11:38 PM.

  • Luke likes this

#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140284 posts
  • Local time: 06:16 AM

Posted 02 September 2019 - 12:42 PM

Thanks for the feedback.







Also tagged with one or more of these keywords: Sprint, Auto Quality, Cellular, 1080p, 720p

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users