Jump to content


Photo

Movie / TV Shows download unsuccessful


Best Answer jakrigg , 26 August 2019 - 09:49 PM

Hi, for anyone else interested in the resolution for my issues above, it was something weird with the device mappings in the server.

 

I had a situation where attempting to download a TV Show or Movie would do nothing, but register in the 'Download & Sync" dashboard against a different device (an iPhone!) as "ready to Transfer". I also had a device listed as "Unknown Device" which had the same content I was trying to download listed as "ready to Transfer"

 

First I removed everything against all devices having problems (and the 'unknown device') in the Downloads & Sync board

 

[attachment=59692:2.png]

 

 

The 2 devices that were experiencing the behavior above, needed to be removed from the devices list also:-

 

[attachment=59693:1.png]

 

Then when re-launching the app on android, downloading TV or Movies would now say 'Downloading' (not syncing) and complete as expected.

 

I'm not sure why it was having issues with device mappings - maybe android updates affected the device ID according to emby - dunno.

No idea why download attempts on a samsung were registering on another (remote) users iPhone though

 

Cheers, Jonny

Go to the full post


  • Please log in to reply
24 replies to this topic

#1 jakrigg OFFLINE  

jakrigg

    Advanced Member

  • Members
  • 30 posts
  • Local time: 07:47 AM

Posted 03 July 2019 - 03:26 AM

Emby server 4.2.0.24 beta

Hi, myself and a couple of my android users are having issues downloading TV / Movies to our phones.

I previously encountered the external storage problem and changed to 'internal' which solved that.

However recently, we can no longer save TV or Movies regardless of the storage location setting. Of note - music downloads fine.

The android download manager just constantly flashes "Download Unsuccessful" - until the item is removed from the download queue on the device.

So far I have:
- cleared the cache on the application
- uninstalled / re-installed
- disabled / re-enabled downloading for the respective users on the server
- restarted both device and server

I've attached Server logs and device screenshots, there are no logs being saved in com.mb.android/files/ on my phone.

I have also just grabed the beta android app - same behaviour unfortunately

please let me know if you have any ideas.

Cheers, Jonny

Attached Files


Edited by jakrigg, 03 July 2019 - 03:32 AM.

  • Flipamanbanc likes this

#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140224 posts
  • Local time: 04:47 PM

Posted 04 July 2019 - 11:54 PM

Hi there, what device and version of android are you downloading to?



#3 jakrigg OFFLINE  

jakrigg

    Advanced Member

  • Members
  • 30 posts
  • Local time: 07:47 AM

Posted 05 July 2019 - 12:03 AM

Hi Luke,

Device - Samsung galaxy S8+
Android version - 9

#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140224 posts
  • Local time: 04:47 PM

Posted 07 July 2019 - 04:16 PM

Can you check that background data is allowed for the app:

https://www.technipa...background-data

 

Please let us know if this helps. Thanks.



#5 jakrigg OFFLINE  

jakrigg

    Advanced Member

  • Members
  • 30 posts
  • Local time: 07:47 AM

Posted 07 July 2019 - 05:28 PM

Hi Luke, yes background data is enabled and data saver is offAttached File  Screenshot_20190708-072540_Settings.jpg   67.08KB   3 downloads

#6 Frankborg OFFLINE  

Frankborg

    Newbie

  • Members
  • 2 posts
  • Local time: 02:47 AM
  • LocationNew York

Posted 12 July 2019 - 09:34 AM

It must be from your downloading file problem every-tings looks perfect to me



#7 jakrigg OFFLINE  

jakrigg

    Advanced Member

  • Members
  • 30 posts
  • Local time: 07:47 AM

Posted 14 July 2019 - 09:01 PM

Hi Luke, attached is the latest server log on beta 28. Still no go with the downloading of tv / movies

 

Cheers

 

JonnyAttached File  embyserver.txt   1.22MB   1 downloads



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140224 posts
  • Local time: 04:47 PM

Posted 17 July 2019 - 12:58 AM

Hi Luke, attached is the latest server log on beta 28. Still no go with the downloading of tv / movies

 

Cheers

 

Jonnyattachicon.gifembyserver.txt

 

What device and version of android?



#9 jakrigg OFFLINE  

jakrigg

    Advanced Member

  • Members
  • 30 posts
  • Local time: 07:47 AM

Posted 17 July 2019 - 01:02 AM

As above, comment #3

#10 Vidman OFFLINE  

Vidman

    Advanced Member

  • Alpha Testers
  • 2662 posts
  • Local time: 05:47 AM

Posted 18 July 2019 - 07:07 PM

i am having the exact same issue after updating my phone from Galaxy s7 to Galaxy s10 (Android 9) . Emby mobile app 3.0.59

Sent from my SM-G975F using Tapatalk

Edited by Vidman, 23 July 2019 - 05:35 PM.


#11 Vidman OFFLINE  

Vidman

    Advanced Member

  • Alpha Testers
  • 2662 posts
  • Local time: 05:47 AM

Posted 25 July 2019 - 09:19 PM

has there been any progress with this issue? i just updated to version 3.0.64 of the Android mobile app and downloads are still unsuccessful

#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140224 posts
  • Local time: 04:47 PM

Posted 26 July 2019 - 01:49 PM

has there been any progress with this issue? i just updated to version 3.0.64 of the Android mobile app and downloads are still unsuccessful

 

Are you downloading to internal or external storage?



#13 Vidman OFFLINE  

Vidman

    Advanced Member

  • Alpha Testers
  • 2662 posts
  • Local time: 05:47 AM

Posted 26 July 2019 - 02:03 PM

external. but i have tried internal also to no success.


edit: actually i just retried downloading to internal storage with 3.0.64 and it was successful

Edited by Vidman, 26 July 2019 - 02:11 PM.


#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140224 posts
  • Local time: 04:47 PM

Posted 26 July 2019 - 10:13 PM

Thanks for the feedback. There is an issue with SD cards that we are looking into.



#15 Vidman OFFLINE  

Vidman

    Advanced Member

  • Alpha Testers
  • 2662 posts
  • Local time: 05:47 AM

Posted 26 July 2019 - 11:01 PM

Thanks for the update



#16 justmejustme OFFLINE  

justmejustme

    Advanced Member

  • Members
  • 34 posts
  • Local time: 05:47 PM

Posted 01 August 2019 - 06:16 AM

@Luke Is there any way to debug this ourselves? It really looks like it's getting hung up on a single file and then failing all downloads thereafter for me. When I start removing downloads from the queue list of things to sync, it will sometimes start working if I happen to remove the right one by simply guessing.

 

Of course, it doesn't help that I have to often restart my chromebook completely before it will even try... only to be unsuccessful.

 

I need more than "Download unsuccessful" - I need why it was unsuccessful:

  • Was it a server-side error?
  • Did conversion fail? Why?
  • Did something run out of disk? What?
  • What file did it fail on?
  • Why can't it just re-queue that file and do the others, then retry it later? It seems to keep things in the same order so that next time it tries, it just fails in the same place, and all consequent syncs fail as well.

And why do I have to restart the entire chromebook for a sync to work?

 

None of this is in the logs that I can find. There are no client-side logs to be found.

 

I came to Emby from Plex because Plex can't get their Sync-act together. Emby sync works when it works, but doesn't seem to be any more reliable....



#17 laola OFFLINE  

laola

    Advanced Member

  • Members
  • 45 posts
  • Local time: 11:47 PM

Posted 14 August 2019 - 11:48 AM

@Luke Is there any way to debug this ourselves? It really looks like it's getting hung up on a single file and then failing all downloads thereafter for me. When I start removing downloads from the queue list of things to sync, it will sometimes start working if I happen to remove the right one by simply guessing.

 

Of course, it doesn't help that I have to often restart my chromebook completely before it will even try... only to be unsuccessful.

 

I need more than "Download unsuccessful" - I need why it was unsuccessful:

  • Was it a server-side error?
  • Did conversion fail? Why?
  • Did something run out of disk? What?
  • What file did it fail on?
  • Why can't it just re-queue that file and do the others, then retry it later? It seems to keep things in the same order so that next time it tries, it just fails in the same place, and all consequent syncs fail as well.

And why do I have to restart the entire chromebook for a sync to work?

 

None of this is in the logs that I can find. There are no client-side logs to be found.

 

I came to Emby from Plex because Plex can't get their Sync-act together. Emby sync works when it works, but doesn't seem to be any more reliable....

 

could this be related to the issue I have... ? -> https://emby.media/c...nload-tv-shows/



#18 Vidman OFFLINE  

Vidman

    Advanced Member

  • Alpha Testers
  • 2662 posts
  • Local time: 05:47 AM

Posted 16 August 2019 - 05:18 PM

any progress with this issue?

#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140224 posts
  • Local time: 04:47 PM

Posted 16 August 2019 - 05:19 PM

We are actively working on it. Thanks.


  • Vidman likes this

#20 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140224 posts
  • Local time: 04:47 PM

Posted 17 August 2019 - 01:18 AM

There are improvements in the app's beta channel if you'd like to help test those out:

https://emby.media/c...wnload-manager/

 

Thanks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users