Jump to content


Photo
- - - - -

Chrome Win10 vs Chrome macOS (ASS subtitle)

subtitle ass chrome font

  • Please log in to reply
16 replies to this topic

#1 iBoss OFFLINE  

iBoss

    Advanced Member

  • Members
  • 167 posts
  • Local time: 04:58 AM

Posted 12 April 2019 - 11:34 AM

Hi ..

 

empy web using Google Chrome: the ASS subtitle style works on both but ..

 

I have installed the same font that used at the subtitle on Win 10 and macOS.

  • Chrome macOS shows the fonts correctly
  • Chrome Win10 shows different font

Please see the attached screenshots for both.

 

-----

 

emby Version 4.0.2.0

Lunix Ubuntu server 16.04.5

Google Chrome Version 73.0.3683.103 (Official Build) (64-bit) - Windows 10 64bit

Google Chrome Version 73.0.3683.103 (Official Build) (64-bit) - macOS 10.14.4

 

logs files are attached 

 

Thanks

Attached Files



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153390 posts
  • Local time: 09:58 PM

Posted 12 April 2019 - 11:41 AM

The font used in the browser isn't guaranteed as we'll be limited to web safe fonts.



#3 iBoss OFFLINE  

iBoss

    Advanced Member

  • Members
  • 167 posts
  • Local time: 04:58 AM

Posted 16 April 2019 - 04:10 AM

The font used in the browser isn't guaranteed as we'll be limited to web safe fonts.

 

But all fonts work on Google Chrome macOS, the issue only on Google Chrome Windows.

 

Do you mean it is limited on Windows only?!

 

Thanks



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153390 posts
  • Local time: 09:58 PM

Posted 16 April 2019 - 01:20 PM

Just because you install a font on the system does not mean it will affect the subtitle rendering. Does that answer your question?



#5 iBoss OFFLINE  

iBoss

    Advanced Member

  • Members
  • 167 posts
  • Local time: 04:58 AM

Posted 23 November 2019 - 11:31 AM

Hi @Luke,

 

Thank you and the team for the hard work to release the new Version of emby server.

 

As I mention before, the font type is shows correctly as in ASS subtitle on Google Chrome on macOS .. but now after I upgrade the emby server to version 4.3.0.26 today, the font type not shows correctly on Chrome macOS. Do you aware about it?! it supposed to develop this to work on other web client not to remove it :(

 

Thanks 



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153390 posts
  • Local time: 09:58 PM

Posted 23 November 2019 - 11:32 AM

What does it look like?

#7 iBoss OFFLINE  

iBoss

    Advanced Member

  • Members
  • 167 posts
  • Local time: 04:58 AM

Posted 23 November 2019 - 11:40 AM

Please see the attached file

Attached Files



#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153390 posts
  • Local time: 09:58 PM

Posted 23 November 2019 - 11:41 AM

But it's fine on windows?

#9 iBoss OFFLINE  

iBoss

    Advanced Member

  • Members
  • 167 posts
  • Local time: 04:58 AM

Posted 23 November 2019 - 11:45 AM

But it's fine on windows?

 

before it was not fine with windows (Chrome), it just fine with mac (Chrome).

After upgrading, not fine with mac as well :(



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153390 posts
  • Local time: 09:58 PM

Posted 23 November 2019 - 11:46 AM

If I had to guess, probably because it was doing a full transcode for macos

#11 iBoss OFFLINE  

iBoss

    Advanced Member

  • Members
  • 167 posts
  • Local time: 04:58 AM

Posted 23 November 2019 - 11:49 AM

it was working with direct play and transcode.

 

the font type is mention on ASS file and the font is installed on macOS and Windows. before it works fine with macOS. now not :(


Edited by iBoss, 23 November 2019 - 11:52 AM.


#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153390 posts
  • Local time: 09:58 PM

Posted 23 November 2019 - 11:55 AM

We're using the same custom font that you've helped us with for iOS and Android.

#13 iBoss OFFLINE  

iBoss

    Advanced Member

  • Members
  • 167 posts
  • Local time: 04:58 AM

Posted 23 November 2019 - 12:07 PM

We're using the same custom font that you've helped us with for iOS and Android.

 

Yes I know. Thanks it works great with SRT subtile. In ASS, the fansub use other fonts inside the file specially in Anime Movies/Series and I want to keep it as it is (in both Arabic and English)

 

On Android/IOS emby App, ASS works amazing. but in Chrome it was working but now it keeps with the same font I gave you (Same in English it will keep the emby system font); it should be changed in ASS.

 

Before the emby server will shows the font correctly if it is installed on macOS; if the font not installed, it will switch automatically to emby font system ... but now it always keep the emby font system.



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153390 posts
  • Local time: 09:58 PM

Posted 23 November 2019 - 12:13 PM

We switched the browser rendering to a different library that renders the subtitles better. It's able to run libass directly in the browser, but i don't think it uses system installed fonts.



#15 iBoss OFFLINE  

iBoss

    Advanced Member

  • Members
  • 167 posts
  • Local time: 04:58 AM

Posted 23 November 2019 - 12:39 PM

I see, I understand now why ... but still I hop to find solution for this. Anyway it is not related to specific language.

 

Please see the attached file, it shows why it's important that need to keep the font type of ASS files

Attached Files

  • Attached File  02.jpg   59.77KB   0 downloads
  • Attached File  01.jpg   56.95KB   0 downloads


#16 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 153390 posts
  • Local time: 09:58 PM

Posted 23 November 2019 - 03:58 PM

Thanks for the feedback. We will constantly be re-evaluating this to look for possible improvements.


  • iBoss likes this

#17 iBoss OFFLINE  

iBoss

    Advanced Member

  • Members
  • 167 posts
  • Local time: 04:58 AM

Posted 23 November 2019 - 03:59 PM

Many thanks







Also tagged with one or more of these keywords: subtitle, ass, chrome, font

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users