Jump to content
Hansel11

Playback Issues with Direct Play

Recommended Posts

Hansel11

My issue is inconsistency with playback, sometimes it's fine for a whole episode playing flawlessly, others for 15-20mins playing how it should then it hangs up and other times it hangs up immediately before playing then stopping and playing repeatedly. This is understandably frustrating as I just switched over from Plex and purchased the Lifetime membership for Emby. (I'm all in!)


 


All my testing has been done on a series of episodes and a movie with the originating format being MKV. Local testing has been done using an X-Box and remote testing has been done using the Nvidia Shield.


 


My first thought was that it had to do with transcoding but as the Emby dash board says it's all Direct Playing, I have no idea why it's having such issues.


 


The testing was done on the x-box attempting to play Angry Birds which is an MKV also tested on Nvidia shield with the same stopping issues.


The primary remote testing was done on Brooklyn 99 with the same inconsistent results.


 


I even used the convert feature in Emby and converted the Brooklyn 99 episodes all to MP4 and it still has the exact same issues.


 


First off my server stats are as follows;


  • Gigabyte MW50-SVO
  • Intel Xeon E5 v3 3.5Ghz
  • Nvidia Quadro P2000 (for hardware accelerated transcoding)
  • 32GB RAM
  • Server Raids 2x Intel Hardware RAID 5s both 4x 8TB Firewolfs (one for TV shows and one for Movies)
  • Internet up and download are over FIOS getting 500mbps up and down

The server is located remotely.


I'm using an Nvidia Shield as my playback device.


 


Here are all of the logs, I apologize for my ignorance in not knowing how to tell which logs are relevant but I thought I would attach them all for the relevant time period just in case...


embyserver.txt


embyserver-63689414400.txt


embyserver-63689450608.txt


embyserver-63689461604.txt


embyserver-63689461681.txt


embyserver-63689464367.txt


embyserver-63689500802.txt


embyserver-63689539161.txt


embyserver-63689587200.txt


embyserver-63689619670.txt


embyserver-63689620488.txt


 


 


Any help is greatly appreciated!!


Share this post


Link to post
Share on other sites
Luke

Hi there, what happens if you lower the in-app quality setting to force a full transcode? How does that compare? Thanks !

Share this post


Link to post
Share on other sites
Hansel11

I adjusted it to 3mbps bitrate and it started much more quickly but still the same starting and stopping issue occurs. 

 

It does appear as if it does work much better if that helps. 

 

P.S. I neglected to mention that the remote client (Nvidia Shield) has 300mbps download. so running at 3 should be no issue....

Edited by Hansel11

Share this post


Link to post
Share on other sites
Hansel11

What does it mean if This works better and is as good as it gets?

 

Also along those lines for streaming 4K content what bitrate do I need to adjust my quality down to? (50GB files)

 

Just tested on a 4K movie and it only play's about 15secs before stopping.

Edited by Hansel11

Share this post


Link to post
Share on other sites
ebr

On the Shield side, you are probably running into the Nvidia firmware bug.  They reportedly have a fix that will be out in a future update.

Share this post


Link to post
Share on other sites
Hansel11

Hmmm but I'm running into the exact same issue locally on the xbox as well.....

Share this post


Link to post
Share on other sites
Hansel11

So to start with I'm going to convert my entire media library to MP4 and would like to do this the fastest possible way (as my library has well over 1,000 movies and an additional 1K+ TV shows) while remaining lossless. Any suggestions?

 

The built in Emby converter seems to take a really long time... but I would like something where I can do batch conversions so it'll just run in the background for the next couple of.....  weeks....

Share this post


Link to post
Share on other sites
Deathsquirrel

So to start with I'm going to convert my entire media library to MP4 and would like to do this the fastest possible way (as my library has well over 1,000 movies and an additional 1K+ TV shows) while remaining lossless. Any suggestions?

 

The built in Emby converter seems to take a really long time... but I would like something where I can do batch conversions so it'll just run in the background for the next couple of.....  weeks....

 

What's your goal in doing the conversion to MP4 and what are you converting from?

 

This is not going to be a small or easy project.  I haven't seen a one size fits all video conversion tool.  Different video sources have very different settings needs when run through a tool like handbrake.  I finally stopped bothering doing conversion as it was just so much easier to stick with full blu-ray rips in MKV containers.

Share this post


Link to post
Share on other sites
Hansel11

The goal is to avoid my main issue above. The constant stopping of my content. If there are any other suggestions I'm more then open to them?

Edited by Hansel11

Share this post


Link to post
Share on other sites
ebr

The goal is to avoid my main issue above. The constant stopping of my content. If there are any other suggestions I'm more then open to them?

 

I don't think the mp4 container is going to have an impact on whatever you are seeing here and it is a bit more restrictive than mkv.

Share this post


Link to post
Share on other sites
Hansel11

Do you have any ideas what the issue here is?

Share this post


Link to post
Share on other sites
ebr

Do you have any ideas what the issue here is?

 

On the Shield, I imagine it is the Nvidia issue I referenced previously.

 

On the Xbox, it could be a limitation in that device's network connection we'd have to see a specific example of just that playback to investigate further.

Share this post


Link to post
Share on other sites
Hansel11

Ok, I'll try and get logs of that tonight and post them for you. Thanks, I appreciate the help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...