Jump to content

Emby for Roku w/reverse proxy but not at root of domain


pinkfamily7
 Share

Recommended Posts

pinkfamily7

With the assistance of a helpful individual (kmbanana) on the Emby discord, I was able to get Emby for Roku working--

 

for those that have struggled previously, if you have Emby installed behind a reverse proxy to go to something like https://domain.com/emby (as opposed to https://emby.domain.com) this apparently completely breaks Emby for Roku when connecting via Emby Connect.  It'll see the server and on the "connect to a server" screen on Emby for Roku it'll says the url is "https://domain.com:443/emby" which LOOKS correct, but if you try to connect, it just won't.

 

You have to delete the server and then re-add it:  https://domain.com/emby and then port 00000.

 

Yes, the port 00000 is the most important part.

 

In your server configuration, of course, set your public port to 80 and your public https port to 443, and have "secure connection mode" to "Handled by reverse proxy".

 

Of course, you can save all this hassle by use a subdomain (i.e. emby.domain.com) as opposed to domain.com/emby, but that's not how I had my server/certs set up.... and while I will probably end up going that direction, I want to explain this option to those where setting up another subdomain may not be an option for whatever reason.

Link to comment
Share on other sites

Hi there, thanks for the info. What you should do though in this situation is just leave the port field blank.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...