Jump to content


Photo

Emby for Roku w/reverse proxy but not at root of domain

Roku reverse proxy

  • Please log in to reply
1 reply to this topic

#1 pinkfamily7 OFFLINE  

pinkfamily7

    Advanced Member

  • Members
  • 39 posts
  • Local time: 04:20 AM

Posted 02 March 2019 - 11:17 AM

With the assistance of a helpful individual (kmbanana) on the Emby discord, I was able to get Emby for Roku working--

 

for those that have struggled previously, if you have Emby installed behind a reverse proxy to go to something like https://domain.com/emby (as opposed to https://emby.domain.com) this apparently completely breaks Emby for Roku when connecting via Emby Connect.  It'll see the server and on the "connect to a server" screen on Emby for Roku it'll says the url is "https://domain.com:443/emby" which LOOKS correct, but if you try to connect, it just won't.

 

You have to delete the server and then re-add it:  https://domain.com/emby and then port 00000.

 

Yes, the port 00000 is the most important part.

 

In your server configuration, of course, set your public port to 80 and your public https port to 443, and have "secure connection mode" to "Handled by reverse proxy".

 

Of course, you can save all this hassle by use a subdomain (i.e. emby.domain.com) as opposed to domain.com/emby, but that's not how I had my server/certs set up.... and while I will probably end up going that direction, I want to explain this option to those where setting up another subdomain may not be an option for whatever reason.



#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 137604 posts
  • Local time: 05:20 AM

Posted 05 March 2019 - 03:40 PM

Hi there, thanks for the info. What you should do though in this situation is just leave the port field blank.







Also tagged with one or more of these keywords: Roku, reverse proxy

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users