Jump to content


Photo

Streams stuttering in Homenetwork

docker stuttering

  • Please log in to reply
18 replies to this topic

#1 Nutellaeis OFFLINE  

Nutellaeis

    Member

  • Members
  • 23 posts
  • Local time: 08:53 AM

Posted 27 February 2019 - 05:35 AM

My streams are often stuttering while streaming. Even inside my own Homenetwork. Maybe someone can help me track down the issue? I am mostly streaming 1080p and I have a Intel Pentium G4560 which has a Passmark of 4868. That should usually be enough for a single 1080p Transcode. I stream mostly to Chromecast (Gen 2).

 

I will attach a Serverlog from yesterday and a Transcodelog from a stuttering file I played yesterday. As far as I can see there are no issues.

I run emby with docker-compose. I will also attach the relevant part of the compose file. If anyone has an idea what the issue can be I would be very happy.

Attached Files



#2 Bob1971 OFFLINE  

Bob1971

    Newbie

  • Members
  • 5 posts
  • Local time: 07:53 AM

Posted 27 February 2019 - 06:22 AM

Do you have hardware acceleration enabled in the transcoding settings?



#3 maegibbons OFFLINE  

maegibbons

    Advanced Member

  • Members
  • 2333 posts
  • Local time: 07:53 AM
  • LocationLutterworth, England, UK

Posted 27 February 2019 - 07:21 AM

The transcode log shows that it is transcoding for the most part at a speed less than 1 which means that it cannot keep up which is strange since it does look like you are using vaapi.

 

Try switching OFF hardware acceleration.

 

Krs

 

Mark



#4 Nutellaeis OFFLINE  

Nutellaeis

    Member

  • Members
  • 23 posts
  • Local time: 08:53 AM

Posted 27 February 2019 - 08:13 AM

Yes I have hardware acceleration enabled. I will try it without it and report back later.



#5 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 46431 posts
  • Local time: 02:53 AM

Posted 27 February 2019 - 10:21 AM

Also, try disabling the throttling.  Thanks.



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:53 AM

Posted 27 February 2019 - 05:29 PM

Actually the answer is most likely the subtitles. They have to be burned in with transcoding and this is a very expensive process, perhaps too much for your server to handle. Try turning the subtitles off and then see how it compares. Thanks.



#7 raphaels880 OFFLINE  

raphaels880

    Newbie

  • Members
  • 8 posts
  • Local time: 04:53 AM

Posted 28 February 2019 - 12:36 AM

I have the same problem since my Emby server update to the new stable version "4.0.2.0". I tried go to the beta version "4.1.0.9" and 4.1.0.10" but the video still have stutters, I tried install in another machine but the problem still there and  I tried a new router still the same though,  I tried play some files what i already watched but the same.

P.S: this problem only happen on Chromecast, on Web player and android app works pretty fine.

 

#8 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:53 AM

Posted 28 February 2019 - 10:32 AM

Hi there, let's look at an example. Please attach the information requested in how to report a media playback issue:
https://emby.media/c...view=getnewpost
Thanks !

#9 Nutellaeis OFFLINE  

Nutellaeis

    Member

  • Members
  • 23 posts
  • Local time: 08:53 AM

Posted 28 February 2019 - 04:01 PM

So I tried switching hardware acceleration off  (max threads, no throtting) and it seems to run a lot better. Adding a transcode log and 2 examples showing my cpu usage. Seems hw accel always only uses one thread. Can someone explain to me why turning of the acceleration helps in this case?

Attached Files



#10 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:53 AM

Posted 01 March 2019 - 01:15 AM

Probably due to having to burn in subtitles. Can you please attach the log with hwa on? Thanks.



#11 Nutellaeis OFFLINE  

Nutellaeis

    Member

  • Members
  • 23 posts
  • Local time: 08:53 AM

Posted 01 March 2019 - 03:07 AM

The logs from the first post are from the same file and have the same settings (max threads, no throttling, ultrafast profile), but have hwa on. I can provide a new one when I come home this evening.

#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:53 AM

Posted 01 March 2019 - 03:31 AM

That would be great, thanks, without subtitles and hwa on.



#13 Nutellaeis OFFLINE  

Nutellaeis

    Member

  • Members
  • 23 posts
  • Local time: 08:53 AM

Posted 01 March 2019 - 12:50 PM

Turning subtitles off does not produce a Transcodelog. Probably the file is just direct streaming. Without any issues of course.

Attached Files



#14 Nutellaeis OFFLINE  

Nutellaeis

    Member

  • Members
  • 23 posts
  • Local time: 08:53 AM

Posted 01 March 2019 - 01:02 PM

I forced it to transcode by setting a lower quality 1080p 4Mbps. Hwa on. No subtitles. Interestingly it now uses all 4 threads. And is not taxed nearly as hard.

Attached Files



#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:53 AM

Posted 19 March 2019 - 12:03 AM

I forced it to transcode by setting a lower quality 1080p 4Mbps. Hwa on. No subtitles. Interestingly it now uses all 4 threads. And is not taxed nearly as hard.

 

And how did it play when you did this?



#16 Nutellaeis OFFLINE  

Nutellaeis

    Member

  • Members
  • 23 posts
  • Local time: 08:53 AM

Posted 19 March 2019 - 05:02 AM

It played fine. As you can see on the picture the CPU was not even close to full load.

Though I now switched to transcoding without hwa I do not have any stuttering. It works with subtitles on and with subtitles off. The CPU load is just a lot higher mit subtitles on, but it does manage without stuttering in both cases. I just think it is weird. Hwa should improve performance and not make it worse.



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:53 AM

Posted 19 March 2019 - 12:13 PM

Thanks. I think the solution is lowering the in-app quality setting, not turning on or off hwa. And of course, avoiding burning in subtitles at all costs.



#18 Nutellaeis OFFLINE  

Nutellaeis

    Member

  • Members
  • 23 posts
  • Local time: 08:53 AM

Posted 19 March 2019 - 12:45 PM

I am pretty sure it has to do with hwa. When I turn it off I can basically set every quality setting and have no issues. Regarding burning in subtitles: The "allow subtitle extraction on-the-fly" setting does sadly not work for more than one subtitle at once. For example: Someone talking + a sign that needs to be translated leads to massively delayed subtitles or none appearing in that scene at all. So I am currenty stuck with burning them in.


Edited by Nutellaeis, 19 March 2019 - 12:46 PM.


#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:53 AM

Posted 19 March 2019 - 03:58 PM

 

 

 Regarding burning in subtitles: The "allow subtitle extraction on-the-fly" setting does sadly not work for more than one subtitle at once.

 

Actually it works just fine, but you have to realize you're deciding between two bad choices. Both operations are very slow - burning in subtitles, or extracting subtitles on the fly. Your system just may not be able to handle it, and it's not just a question of cpu/gpu performance, but disk performance as well.

 

How can you improve this?

  • Use external subtitles, our subtitle download features can help you obtain them
  • Turn the subtitles off
  • Use an Emby app that can direct play the subtitles and therefore doesn't have to utilize either of these techniques






Also tagged with one or more of these keywords: docker, stuttering

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users