Jump to content
makarai

Update to 4.0.0.2 on FreeNAS

Recommended Posts

Luke

Sorry for the delay guys. We should have FreeNAS builds functional again within the next few days. Thanks.

Share this post


Link to post
Share on other sites
taylorstan

I was directed to this thread from https://emby.media/community/index.php?/topic/72283-coverart-plugin-not-supported-on-this-system/. So I need to update my current 4.0.2.0 to 4.1.0.26 as it shows on my dashboard.

 

Is this the proper set of commands I need to use??? I extrapolated from the posts above.

 

service emby-server stop
service emby-server start

Share this post


Link to post
Share on other sites
Luke

We'll have updated install instructions for freenas soon. Thanks.

Share this post


Link to post
Share on other sites
sluggo45

I'll defer to the Emby team for the official process but if you are willing to try with the understanding that this is still a beta, and the new instructions are still being worked out, and therefore you may run in to problems, you can try this for existing beta jails on FreeNAS (new jail install updates are coming):

 

First: I tested this on my system, which is FreeNAS 11.2U3 (the latest GA). I can't guarentee it will work if you are running an older version, or nightlies, whatever. I'm using an existing 11.2 template jail which was running the last available beta that worked on FreeBSD 11 before the new version (forgot the number).

 

From the jail console, first do

pkg upgrade

To insure all your packages are up to date, including Mono and, critically, libx264 (should be .157).

 

Then do

pkg install ImageMagick6

Which is now used by Emby Server. You may already have this and it will tell you if you do, if so no need to reinstall, you're good.

 

Then

service emby-server stop
pkg add -f https://github.com/MediaBrowser/Emby.Releases/releases/download/4.2.0.1/emby-server-freebsd11_4.2.0.1_amd64.txz
service emby-server start

Pay attention to the above package - that is the latest version of the beta, built now for FreeBSD 11 (which FreeNAS is based on).

 

That should be all you have to do. There are a number of non-FreeBSD related changes in the new version, one that stood out for me is Roku thumbnails are now combined with chapter image extraction, as a result there is no longer a Roku thumbs plugin. You can find the settings under "Manage Library" on a per-library basis now. Check your settings - mine reset from the plugin, as I store my thumb image with my media. Do this for each library and rescan.

 

This is working fine for me so far, but keep in mind - it's a new build, and it's a beta, so proceed at your own risk!

  • Like 2

Share this post


Link to post
Share on other sites
sluggo45

Your error message tells you the problem. You don't have all the required packages installed in your Emby server jail. Emby builds ffmpeg with smb support so make sure that is installed (pkg install samba48 I believe).

Share this post


Link to post
Share on other sites
Drego344

it said thats its already installed

Share this post


Link to post
Share on other sites
sluggo45

Is libsmbclient installed? Your error message indicates it isn't or at least it can't be found in the jail:

Shared object "libsmbclient.so.0" not found, required by "libavformat.so.58"

Share this post


Link to post
Share on other sites
Drego344

when i tried to do pkg install libsmbclient.so.0 its saying no such package exist..... libavformat.so.58 is already installed

Share this post


Link to post
Share on other sites
sluggo45

What does

pkg info samba48-4.8.9_1

Output?

Share this post


Link to post
Share on other sites
Drego344

i just when ahead and did a new jail....everything work fine now, just trakt wont sync

Share this post


Link to post
Share on other sites
Baenwort

I'll defer to the Emby team for the official process but if you are willing to try with the understanding that this is still a beta, and the new instructions are still being worked out, and therefore you may run in to problems, you can try this for existing beta jails on FreeNAS (new jail install updates are coming):

 

First: I tested this on my system, which is FreeNAS 11.2U3 (the latest GA). I can't guarentee it will work if you are running an older version, or nightlies, whatever. I'm using an existing 11.2 template jail which was running the last available beta that worked on FreeBSD 11 before the new version (forgot the number).

 

From the jail console, first do

pkg upgrade
To insure all your packages are up to date, including Mono and, critically, libx264 (should be .157).

 

Then do

pkg install ImageMagick6
Which is now used by Emby Server. You may already have this and it will tell you if you do, if so no need to reinstall, you're good.

 

Then

service emby-server stop
pkg add -f https://github.com/MediaBrowser/Emby.Releases/releases/download/4.2.0.1/emby-server-freebsd11_4.2.0.1_amd64.txz
service emby-server start
Pay attention to the above package - that is the latest version of the beta, built now for FreeBSD 11 (which FreeNAS is based on).

 

That should be all you have to do. There are a number of non-FreeBSD related changes in the new version, one that stood out for me is Roku thumbnails are now combined with chapter image extraction, as a result there is no longer a Roku thumbs plugin. You can find the settings under "Manage Library" on a per-library basis now. Check your settings - mine reset from the plugin, as I store my thumb image with my media. Do this for each library and rescan.

 

This is working fine for me so far, but keep in mind - it's a new build, and it's a beta, so proceed at your own risk!

 

So I tried to do this from a 4.0.2 install but instead of going to the beta I used the stable 4.1.0.26 for freebsd11 (https://github.com/MediaBrowser/Emby.Releases/releases/download/4.1.0.26/emby-server-freebsd11_4.1.0.26_amd64.txz ). I already had imageMagic6 installed but I did have to install samba48 (which uninstalled 4.0.2 as part of removing the conflicting samba47).

 

However, since I did that and corrected the chapter images settings to match my old Roku Plugin settings, the server becomes unresponsive after a few seconds on navigating to the home screen. This applies via the webapp. Once this occurs no other interface will respond. However, only the webapp seems to cause this hang when the home screen is selected. if I stay in the dashboard area in the webapp I am able to have every other app work fine.

 

I've attached the series of logs from both before the update to the most recent one that ends on a hang. I only included one hardware_detection log as they all seem to be the same.

 

The computer at 192.168.1.222 you see mentioned in the logs is the desktop Windows 10 machine from which I was trying to access Emby.

 

At the same time that the web and Roku interfaces become unresponsive I get the following message on the log of the FreeNAS 11.2U3: 

Apr 25 23:12:13 FREENAS192 kernel: pid 7750 (mono-sgen), uid 989: exited on signal 6 (core dumped)
Edited by Baenwort

Share this post


Link to post
Share on other sites
sluggo45

I don't have this problem with my jail but:

 

Are you sure you ran a pkg upgrade and furthermore that Mono was updated to the latest stable? Because based on your report that is what is crashing. Sgen is the C# garbage collector for Mono and to make a very long explanation short there's an error causing Mono (the C# interpreter that Emby still uses for FreeBSD because .Net Core hasn't been ported to it) to crash and dump memory.

 

Could be a thousand reasons for this but as it doesn't seem to be a widespread issue with the new Emby build I'd start by making sure your jail is completely up to date.

 

You can always create a new jail and copy your settings/library.db to it, test there, as well.

Share this post


Link to post
Share on other sites
Luke

Is that the newest mono version available?

Share this post


Link to post
Share on other sites
hjason7812

So the freenas version is available now?

Share this post


Link to post
Share on other sites
Luke

We'll have the website updated soon. Thanks.

  • Like 1

Share this post


Link to post
Share on other sites
Baenwort

I did run pkg upgrade and pkg update before installing. Version of mono is: "mono-5.10.1.57_1" I've included the complete ssh dump of running another pkg upgrade and the output of pkg version encase there is anything else you think it might be. 

 

Per freshports this is the newest version of mono. https://www.freshports.org/lang/mono/ 

 

Is that the newest mono version available?

root@emby_2:~ # pkg update
Updating FreeBSD repository catalogue...
[emby_2] Fetching meta.txz: 100%    944 B   0.9kB/s    00:01
[emby_2] Fetching packagesite.txz: 100%    6 MiB   3.4MB/s    00:02
Processing entries: 100%
FreeBSD repository update completed. 32071 packages processed.
All repositories are up to date.
root@emby_2:~ # pkg_version -v -X -s mono
pkg_version: Command not found.
root@emby_2:~ # pkg -h
pkg: illegal option -- h
pkg: no commands specified
Usage: pkg [-v] [-d] [-l] [-N] [-j <jail name or id>|-c <chroot path>|-r <rootdir>] [-C <configuration file>] [-R <repo config dir>] [-o var=value] [-4|-6] <command> [<args>]

For more information on available commands and options see 'pkg help'.

root@emby_2:~ # pkg version 
ImageMagick6-6.9.10.22_1,1         >
adwaita-icon-theme-3.28.0          =
apr-1.6.5.1.6.1_1                  =
argtable-2.13_2                    =
argyllcms-1.9.2_4                  =
at-spi2-atk-2.26.2                 =
at-spi2-core-2.28.0                =
atk-2.28.1                         =
autoconf-2.69_2                    =
autoconf-wrapper-20131203          =
automake-1.16.1_1                  =
avahi-app-0.7_2                    =
base64-1.5_1                       =
bash-5.0.7                         >
binutils-2.32,1                    =
bison-3.3.2,1                      =
ca_root_nss-3.43                   >
cairo-1.16.0,2                     >
ccextractor-0.85_12                >
check-0.12.0_1                     =
cmocka-1.1.1_1                     =
colord-1.3.5                       =
compat10x-amd64-10.4.1004000.20181014 =
compat9x-amd64-9.3.903000.20170608 =
cups-2.2.11                        >
curl-7.64.1_1                      >
cvsps-2.1_2                        =
dav1d-0.2.2                        >
db48-4.8.30.0_2                    =
db5-5.3.28_7                       =
dbus-1.12.12                       >
dbus-glib-0.110                    >
dejavu-2.37_1                      >
desktop-file-utils-0.23            =
dialog4ports-0.1.6                 =
docbook-1.5                        =
docbook-sgml-4.5_1                 =
docbook-xml-5.0_3                  =
docbook-xsl-1.79.1_1,1             =
emby-server-4.1.0.26_1             ?
encodings-1.0.4_4,1                =
expat-2.2.6_1                      =
fdk-aac-2.0.0                      =
ffmpeg-4.1.3_2,1                   >
fftw3-3.3.8_3                      =
flac-1.3.2                         =
font-bh-ttf-1.0.3_4                >
font-misc-ethiopic-1.0.3_4         >
font-misc-meltho-1.0.3_4           >
font-util-1.3.1                    =
fontconfig-2.12.6,1                =
freetype2-2.9.1                    =
frei0r-1.6.1                       =
fribidi-0.19.7                     =
gamin-0.1.10_10                    =
gcc-ecj-4.5                        =
gcc5-5.5.0_6                       =
gcc6-6.5.0_3                       =
gcc7-7.4.0_1                       =
gcc8-8.3.0_2                       >
gdbm-1.18.1_1                      >
gdk-pixbuf2-2.36.12                =
gettext-0.19.8.1                   =
gettext-runtime-0.19.8.1_2         =
gettext-tools-0.19.8.1_1           =
ghostscript9-agpl-base-9.27        >
ghostscript9-agpl-x11-9.27         >
giflib-5.1.4                       =
git-2.21.0                         >
glib-2.56.3_4,1                    >
gmake-4.2.1_3                      =
gmp-6.1.2_1                        =
gnome_subr-1.0                     =
gnutls-3.6.7                       >
gobject-introspection-1.56.1,1     =
graphite2-1.3.13                   =
gsfonts-8.11_8                     =
gstreamer1-1.14.4                  =
gstreamer1-libav-1.14.4_2          =
gstreamer1-plugins-1.14.4_1        =
gstreamer1-plugins-gdkpixbuf-1.14.4 =
gstreamer1-plugins-good-1.14.4     =
gtk-update-icon-cache-2.24.32      =
gtk3-3.24.7                        >
handbrake-1.2.2_1                  >
harfbuzz-2.4.0_1                   >
help2man-1.47.10                   >
hicolor-icon-theme-0.17            >
html2text-1.3.2a                   =
iconv-2.0_4                        =
icu-64.2,1                         >
indexinfo-0.3.1                    =
intltool-0.51.0_1                  =
iso-codes-4.2                      >
iso8879-1986_3                     =
jansson-2.12                       =
jasper-1.900.1_17                  =
jbig2dec-0.16                      >
jbigkit-2.1_1                      =
jpeg-turbo-2.0.2                   >
lame-3.100_2                       =
lcms2-2.9                          =
libICE-1.0.9_3,1                   =
libSM-1.2.3,1                      =
libX11-1.6.7,1                     =
libXScrnSaver-1.2.3_2              =
libXau-1.0.9                       >
libXcomposite-0.4.4_5,1            =
libXcursor-1.1.15_2                =
libXdamage-1.1.4_5                 =
libXdmcp-1.1.3                     >
libXext-1.3.3_3,1                  =
libXfixes-5.0.3_2                  =
libXft-2.3.2_3                     =
libXi-1.7.9_2,1                    =
libXinerama-1.1.4_2,1              =
libXrandr-1.5.1_2                  =
libXrender-0.9.10_2                =
libXt-1.1.5_2,1                    =
libXtst-1.2.3_2                    =
libXxf86vm-1.1.4_3                 =
libarchive-3.3.3,1                 =
libass-0.14.0                      =
libcroco-0.6.12                    =
libdaemon-0.14_1                   =
libdrm-2.4.96,1                    =
libedit-3.1.20181209_2,1           =
libepoll-shim-0.0.20181229         =
libepoxy-1.5.2                     =
libffi-3.2.1_3                     =
libfontenc-1.1.4                   >
libgcrypt-1.8.4_1                  =
libgpg-error-1.36                  >
libgsf-1.14.44                     =
libiconv-1.14_11                   =
libidn-1.35                        >
libidn2-2.1.1                      =
libijs-0.35_5                      =
libinotify-20180201_1              =
liblqr-1-0.4.2                     =
libltdl-2.4.6                      =
liblz4-1.8.3,1                     =
libnghttp2-1.38.0                  >
libnotify-0.7.7_1                  =
libogg-1.3.3,4                     =
libpaper-1.1.24.4                  =
libpciaccess-0.13.5                =
libpthread-stubs-0.4               =
libraw-0.19.2                      >
librsvg2-2.40.20                   =
libsamplerate-0.1.9                =
libsndfile-1.0.28_2                >
libsunacl-1.0.1                    =
libtasn1-4.13_1                    =
libtheora-1.1.1_7                  =
libtool-2.4.6_1                    =
libunicode-0.4_11                  =
libunistring-0.9.10_1              =
libunwind-20170615                 =
libv4l-1.6.3_4                     =
libva-2.4.1                        >
libvdpau-1.1.1_2                   =
libvorbis-1.3.6,3                  =
libvpx-1.8.0                       =
libwmf-0.2.8.4_15                  =
libx264-0.157.2945                 >
libxcb-1.13.1                      =
libxkbcommon-0.8.0_1               =
libxml2-2.9.8                      =
libxshmfence-1.2_4                 =
libxslt-1.1.32                     =
libzvbi-0.2.35_3                   =
lua52-5.2.4                        =
lzo2-2.10_1                        =
m4-1.4.18_1,1                      =
mesa-libs-18.3.2                   =
minixmlto-0.0.2_1                  =
mkfontscale-1.2.1                  >
mono-5.10.1.57_1                   =
mpc-1.1.0_2                        =
mpfr-4.0.2                         >
nano-4.1                           >
nasm-2.14.02,1                     =
neon-0.30.2_4                      =
nettle-3.4.1_1                     =
nspr-4.21                          >
opencv-core-3.4.1_17               >
openjpeg-2.3.1                     >
openldap-client-2.4.47             =
openssl-1.0.2r,1                   >
opus-1.3.1                         >
orc-0.4.28                         =
p11-kit-0.23.15                    =
p5-Authen-SASL-2.16_1              =
p5-CGI-4.42                        >
p5-Digest-HMAC-1.03_1              =
p5-Error-0.17027                   =
p5-GSSAPI-0.28_1                   =
p5-HTML-Parser-3.72                =
p5-HTML-Tagset-3.20_1              =
p5-IO-Socket-INET6-2.72_1          =
p5-IO-Socket-SSL-2.060             =
p5-Locale-gettext-1.07             =
p5-Locale-libintl-1.31             =
p5-Mozilla-CA-20180117             =
p5-Net-SSLeay-1.85                 =
p5-Parse-Yapp-1.05_2               =
p5-Socket6-0.29                    =
p5-Text-Unidecode-1.30             =
p5-Unicode-EastAsianWidth-1.40     =
p5-XML-Parser-2.44                 =
pango-1.42.4_1                     =
pciids-20190418                    >
pcre-8.43_1                        >
perl5-5.28.1_1                     >
perl5.24-5.24.4_2                  =
pixman-0.34.0_1                    =
pkg-1.10.5_5                       =
pkgconf-1.6.1,1                    >
png-1.6.36                         =
polkit-0.114_2                     =
poppler-data-0.4.9                 =
popt-1.16_2                        =
py27-Babel-2.6.0_1                 >
py27-Jinja2-2.10                   =
py27-MarkupSafe-1.1.1              >
py27-alabaster-0.7.6               =
py27-asn1crypto-0.22.0             =
py27-certifi-2019.3.9              >
py27-cffi-1.12.3                   >
py27-chardet-3.0.4_1               >
py27-cryptography-2.6.1            >
py27-dnspython-1.16.0              >
py27-docutils-0.14_4               >
py27-enum34-1.1.6                  =
py27-idna-2.8                      >
py27-imagesize-0.7.1               =
py27-ipaddress-1.0.22              =
py27-iso8601-0.1.11                =
py27-openssl-18.0.0                =
py27-pillow-5.3.0                  =
py27-pycparser-2.18                =
py27-pygments-2.3.0_1              >
py27-pysocks-1.6.8                 =
py27-pystemmer-1.3.0_2             =
py27-pytz-2018.9,1                 =
py27-requests-2.21.0               =
py27-setuptools-41.0.0             >
py27-six-1.12.0                    =
py27-snowballstemmer-1.2.0_1       =
py27-sphinx-1.6.5_2,1              >
py27-sphinx_rtd_theme-0.4.3        >
py27-sphinxcontrib-websupport-1.1.0 =
py27-tkinter-2.7.16_6              >
py27-typing-3.6.6                  >
py27-urllib3-1.22,1                =
py36-Babel-2.6.0_1                 >
py36-Jinja2-2.10                   =
py36-MarkupSafe-1.1.1              >
py36-alabaster-0.7.6               =
py36-asn1crypto-0.22.0             =
py36-certifi-2019.3.9              >
py36-cffi-1.12.3                   >
py36-chardet-3.0.4_1               >
py36-cryptography-2.6.1            >
py36-cython-0.29_1                 >
py36-docutils-0.14_4               >
py36-idna-2.8                      >
py36-imagesize-0.7.1               =
py36-openssl-18.0.0                =
py36-pycparser-2.18                =
py36-pygments-2.3.0_1              >
py36-pysocks-1.6.8                 =
py36-pystemmer-1.3.0_2             =
py36-pytest-runner-2.11.1          =
py36-pytz-2018.9,1                 =
py36-requests-2.21.0               =
py36-setuptools-41.0.0             >
py36-setuptools_scm-3.1.0          =
py36-six-1.12.0                    =
py36-snowballstemmer-1.2.0_1       =
py36-sphinx-1.6.5_2,1              >
py36-sphinx_rtd_theme-0.4.3        >
py36-sphinxcontrib-websupport-1.1.0 =
py36-urllib3-1.22,1                =
python2-2_3                        =
python27-2.7.16_1                  >
python36-3.6.8_2                   >
readline-8.0.0                     >
samba48-4.8.11_1                   >
schroedinger-1.0.11_4              =
sdocbook-xml-1.1_2,2               =
serf-1.3.9_3                       =
shared-mime-info-1.10_1            >
speex-1.2.0,1                      =
speexdsp-1.2.r3_1                  =
spidermonkey170-17.0.0_9           >
spidermonkey52-52.9.0_3            >
sqlite3-3.27.2                     >
subversion-1.11.1_1                =
svgalib-1.4.3_7                    =
swig30-3.0.12                      =
talloc-2.1.14                      =
tcl86-8.6.9_1                      >
tdb-1.3.16,1                       =
tevent-0.9.37                      =
texi2html-5.0_2,1                  =
texinfo-6.6_1,1                    >
tiff-4.0.10                        =
tk86-8.6.9_1                       >
tpm-emulator-0.7.4_2               =
trousers-0.3.14_2                  =
unzip-6.0_7                        =
utf8proc-2.2.0                     >
v4l_compat-1.6.3_3                 =
wavpack-5.1.0_1                    =
wayland-1.16.0_1                   =
wayland-protocols-1.17             =
webp-1.0.2                         =
wget-1.20.3                        >
x265-3.0                           >
xcb-proto-1.13_1                   >
xcb-util-0.4.0_2,1                 =
xcb-util-renderutil-0.3.9_1        =
xkeyboard-config-2.24_1            =
xmlcatmgr-2.2_2                    =
xmlcharent-0.3_2                   =
xorg-fonts-truetype-7.7_1          =
xorg-macros-1.19.2                 =
xorgproto-2018.4                   =
xtrans-1.4.0                       >
xvid-1.3.5,1                       =

Edited by Baenwort

Share this post


Link to post
Share on other sites
Baenwort

I don't have this problem with my jail but:

 

Are you sure you ran a pkg upgrade and furthermore that Mono was updated to the latest stable? Because based on your report that is what is crashing. Sgen is the C# garbage collector for Mono and to make a very long explanation short there's an error causing Mono (the C# interpreter that Emby still uses for FreeBSD because .Net Core hasn't been ported to it) to crash and dump memory.

 

Could be a thousand reasons for this but as it doesn't seem to be a widespread issue with the new Emby build I'd start by making sure your jail is completely up to date.

 

You can always create a new jail and copy your settings/library.db to it, test there, as well.

 

What exactly would you recommend copying. Last time I migrated jails the backup plug in and saving locally with media was enough but Emby has changed a number of things lately that make me less confident in the success of such a simple migration.

 

I've rolled back to my pre-upgrade snapshot so there isn't a family mutiny this weekend as we are expecting to get snowed in tomorrow. 

 

I can split off another for testing if you state with more precision what you mean.

Share this post


Link to post
Share on other sites
sluggo45

Your data directory - <jailroot>/emby-server/root

 

For example mine is /mnt/Jails/appdata/jails/emby-server, where  /mnt/Jails is my mirrored ssds for all Jail storage and /appdata/jails is where I set the default Jail storage.

 

You can also copy the config.json, fstab, and plugin subdirectories one level up - in that case, just tar up </jailroot>/emby-server/

 

That will grab everything. Install a new Emby Server in a new jail (with a new name), do a basic setup (maybe pick one movie directory, etc.) and test to see if you have the same problem, if not, stop the jail and copy the files you tar'd from the old Emby jail to the directory for the new one.

Share this post


Link to post
Share on other sites
Baenwort

The install for mono-5.10.1.57_1 states this after updating to the newest:

===============================================================================
Message from mono-5.10.1.57_1:

************************************************************************
If you have build/runtime errors with Mono and Gtk# apps please try the
following first:

* Build Mono and gtk+ (x11-toolkits/gtk20) without CPUTYPE and with the
  default FreeBSD CFLAGS ('-O2 -fno-strict-aliasing -pipe') as Mono has
  been known to expose compiler bugs.

* Try building and running Mono with the GENERIC kernel.
  - Mono requires SYSVSHM, SYSVMSG, and SYSVSEM which are part of the
    GENERIC kernel.
  - Removing kernel options or changing defaults to use experimental
    options can adversely affect Mono's ability to build and run.

* Remove leftover semaphores / increase semaphore limits.
  - Close apps which use Mono and run `ipcs -sbt`.  Remove the
    semaphores with MODE "--rw-------" and NSEMS "8" using ipcrm (1)
  - _OR_ simply reboot which is the safest method.
  - On multi-user systems the semaphore limits may need to be increased
    from the defaults. The following should comfortably support 30 users.

    # echo "kern.ipc.semmni=40" >> /boot/loader.conf
    # echo "kern.ipc.semmns=300" >> /boot/loader.conf

* If you are in a jailed environment, ensure System V IPC are enabled.
  You can rely on the security.jail.sysvipc_allowed  sysctl to check
  this status.  The following enables this feature on the host system:
    # echo "jail_sysvipc_allow=\"YES\"" >> /etc/rc.conf

* Some process information are accessed through /proc (e.g. when using
  NUnit) and procfs(5) has to be mounted for these features to work:
    # echo "proc            /proc   procfs  rw 0 0" >> /etc/fstab
************************************************************************

Could any of these help?

Share this post


Link to post
Share on other sites
Baenwort

So I tried to do this from a 4.0.2 install but instead of going to the beta I used the stable 4.1.0.26 for freebsd11 (https://github.com/MediaBrowser/Emby.Releases/releases/download/4.1.0.26/emby-server-freebsd11_4.1.0.26_amd64.txz ). I already had imageMagic6 installed but I did have to install samba48 (which uninstalled 4.0.2 as part of removing the conflicting samba47).

 

However, since I did that and corrected the chapter images settings to match my old Roku Plugin settings, the server becomes unresponsive after a few seconds on navigating to the home screen. This applies via the webapp. Once this occurs no other interface will respond. However, only the webapp seems to cause this hang when the home screen is selected. if I stay in the dashboard area in the webapp I am able to have every other app work fine.

 

I've attached the series of logs from both before the update to the most recent one that ends on a hang. I only included one hardware_detection log as they all seem to be the same.

 

The computer at 192.168.1.222 you see mentioned in the logs is the desktop Windows 10 machine from which I was trying to access Emby.

 

At the same time that the web and Roku interfaces become unresponsive I get the following message on the log of the FreeNAS 11.2U3: 

Apr 25 23:12:13 FREENAS192 kernel: pid 7750 (mono-sgen), uid 989: exited on signal 6 (core dumped)

 

So I tried again from 4.0.20_1 to upgrade to 4.1.0.26 (latest stable) and still have the mono error per FreeNAS. Mono is confirmed to be latest 5.10.1.57_1 from pkg. Attached is entire putty upgrade log and also attached is Emby log from before and after.

 

After3 contains the crash of mono. The others are from reboots to update plug ins. After4 is from the recovery reboot of the jail.

 

Apr 27 15:22:16 thing.adams.fun kernel: pid 99010 (mono-sgen), uid 989: exited on signal 6 (core dumped)
Edited by Baenwort

Share this post


Link to post
Share on other sites
taylorstan

My issue is resolved....

 

used pkg update, pkg install samba48, and upgraded to 4.1.0.26

Share this post


Link to post
Share on other sites
Baenwort

My issue is resolved....

 

used pkg update, pkg install samba48, and upgraded to 4.1.0.26

 

What version did you start from?

Share this post


Link to post
Share on other sites
PhilWhite

@@Baenwort,

 

Here is something to try.   

 

it'll sound stupid but worked for me just now.

 

repeat pkg update

pkg upgrade

 

that should now install everything you need.  You can check by trying to pkg install samba48 and pkg install ImageMagick6, but both should now be there.

 

then service emby-server stop (it may already be stopped)

pkg add -f https://github.com/MediaBrowser/Emby.Releases/releases/download/4.2.0.1/emby-server-freebsd11_4.2.0.1_amd64.txz

 

When I tried to start the emby-server from within the jail after adding it I got an error message

 

So, in the gui go to your jail, stop it, and restart it

then, in the gui, go to plugins, installed and stop and restart the plugin.  Then see if you can go to the management page.

 

It just worked for me when I had some issue earlier.  That particular jail had emby-server version 4.0.2.0 beforehand

Edited by PhilWhite

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...