Jump to content


Photo

Update to 4.0.0.2 on FreeNAS


  • Please log in to reply
82 replies to this topic

#1 makarai OFFLINE  

makarai

    Advanced Member

  • Members
  • 489 posts
  • Local time: 03:49 AM

Posted 16 January 2019 - 02:41 AM

Hello,

 

This thread can serve as an experience blog on how to update your emby jail. As i have  installed the emby server a good 100 times I can share some of my experience.

 

Personally I performed the updates this morning and it took less than 5 minutes.

 

In order to make sure i don't touch my production server (jail), i always create a new server (new jail) and copy my data over, test, and go live. (with rsync 1.5gb database 10 seconds of copying)

 

If you are coming from 3.6.0.0 to 3.6.0.56  i can only recommend going the first route as the database is already updated and the folder structure is the same, you just need to know where your jails are saved and then its ez pz. (its always good where your precious data is, maybe make a snapshot of them or copy them to an unrelated location)

 

# Starting Fresh and copying the DB (Creating a new jail and copying over my settings)

I created a new jail: (creates a new jail just called emby-server)

#stable
cd /tmp
wget https://raw.githubusercontent.com/ma-karai/iocage-plugin-emby/master/emby-server.json
iocage fetch -P dhcp=on vnet=on bpf=yes allow_raw_sockets=1 -n emby-server.json --branch 'master' 

added my storage via the gui and rsynced over my settings directory with.

                # old location                                                    # new location
rsync -vrlpogth /mnt/evo/iocage/jails/emby-server-beta75/root/var/db/emby-server/ /mnt/evo/iocage/jails/emby-server/root/var/db/emby-server/

DONE.

 

# Updated a Beta server running 3.6.0.56

Since i knew i was already with the new database it was quite straight forward. only thing i had to do was add the libraw package that was newly added at somepoint, and update

 

login to your emby-beta-jail shell (with gui or with iocage console YOURJAILNAME) then

pkg install libraw

service emby-server stop
pkg add -f https://github.com/MediaBrowser/Emby.Releases/releases/download/4.0.0.2/emby-server-freebsd_4.0.0.2_amd64.txz
service emby-server start

Restart the jail

 

DONE

 

# Updated a Beta server running 3.6.0.75

 

log into the shell of the jail and

service emby-server stop
pkg add -f https://github.com/MediaBrowser/Emby.Releases/releases/download/4.0.0.2/emby-server-freebsd_4.0.0.2_amd64.txz
service emby-server start

Edited by makarai, 26 April 2019 - 07:41 AM.

  • Henry78, dolphin and vincent_y79 like this

#2 PhilWhite OFFLINE  

PhilWhite

    Advanced Member

  • Members
  • 381 posts
  • Local time: 09:49 PM

Posted 16 January 2019 - 07:50 AM

I updated from 3.6.0.76 to 4.0.0.1 (with the plugin updates and repeat library scan and switch to Emby TV guide) a few days ago and then to 4.0.0.2 yesterday...quick process, all working well.



#3 gbarone123 OFFLINE  

gbarone123

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:49 PM

Posted 16 January 2019 - 01:26 PM

I updated from 3.6.0.79 and so far all seems great. Pages and videos are quick to load. No playback issues to report from any clients on LAN or WAN. Library scans complete MUCH faster. Great work guys!

#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134545 posts
  • Local time: 09:49 PM

Posted 16 January 2019 - 01:39 PM

Thanks for the feedback !

 

FYI - we should have 4.0 stable submitted to FreeBSD ports by the weekend.



#5 Kent OFFLINE  

Kent

    Advanced Member

  • Members
  • 264 posts
  • Local time: 09:49 PM

Posted 16 January 2019 - 08:48 PM

Do i need the libraw install on .73?



#6 makarai OFFLINE  

makarai

    Advanced Member

  • Members
  • 489 posts
  • Local time: 03:49 AM

Posted 17 January 2019 - 02:06 AM

Do i need the libraw install on .73?

should already be installed. Just update the pkg if you get an error message at the end stating you need libraw, install libraw and then repeat. :D


  • Kent likes this

#7 Kent OFFLINE  

Kent

    Advanced Member

  • Members
  • 264 posts
  • Local time: 09:49 PM

Posted 17 January 2019 - 07:36 AM

should already be installed. Just update the pkg if you get an error message at the end stating you need libraw, install libraw and then repeat. :D

 

Thanks, steps for # Updated a Beta server running 3.6.0.75 worked perfectly!


  • makarai likes this

#8 MRobi OFFLINE  

MRobi

    Advanced Member

  • Members
  • 260 posts
  • Local time: 10:49 PM

Posted 17 January 2019 - 01:30 PM

 

# Updated a Beta server running 3.6.0.75

 

log into the shell of the jail and

service emby-server stop
pkg add -f https://github.com/MediaBrowser/Emby.Releases/releases/download/4.0.0.2/emby-server-freebsd_4.0.0.2_amd64.txz
service emby-server start

3.6.0.86 > 4.0.0.2 is as simple as this. Thanks @makarai



#9 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134545 posts
  • Local time: 09:49 PM

Posted 17 January 2019 - 01:33 PM

Great job guys, and thanks @makarai !



#10 gbarone123 OFFLINE  

gbarone123

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:49 PM

Posted 17 January 2019 - 08:28 PM

Luke, any chance you guys can bring back the number count of how many movies there are in the movies tab on the next release?

#11 sluggo45 OFFLINE  

sluggo45

    Advanced Member

  • Members
  • 195 posts
  • Local time: 08:49 PM

Posted 18 January 2019 - 01:26 AM

He mentioned in another thread it will be in the next update.



#12 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134545 posts
  • Local time: 09:49 PM

Posted 18 January 2019 - 01:30 AM

It will come back in the near future with the addition of virtual scrolling. Thanks.



#13 tnicks OFFLINE  

tnicks

    Newbie

  • Members
  • 7 posts
  • Local time: 01:49 AM

Posted 18 January 2019 - 10:59 PM

Why is there no 4.1 beta release for Freebsd?



#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134545 posts
  • Local time: 09:49 PM

Posted 19 January 2019 - 12:26 AM

FreeBSD is more complicated than the other platforms. Occasionally it can run a little bit behind. Thank you for your patience.


  • tnicks likes this

#15 tnicks OFFLINE  

tnicks

    Newbie

  • Members
  • 7 posts
  • Local time: 01:49 AM

Posted 19 January 2019 - 12:37 AM

Cool, just wanted to make sure it wasn't being dropped!



#16 orcist OFFLINE  

orcist

    Member

  • Members
  • 23 posts
  • Local time: 09:49 PM

Posted 19 January 2019 - 04:04 PM

Sorry if this is obvious, but I can just go from 3.5.3.0 straight to 4.0.0.2, right?



#17 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 134545 posts
  • Local time: 09:49 PM

Posted 19 January 2019 - 04:38 PM

Yes you can.



#18 orcist OFFLINE  

orcist

    Member

  • Members
  • 23 posts
  • Local time: 09:49 PM

Posted 19 January 2019 - 06:12 PM

Yes you can.

 

Thanks, Luke.



#19 gbarone123 OFFLINE  

gbarone123

    Advanced Member

  • Members
  • 33 posts
  • Local time: 08:49 PM

Posted 19 January 2019 - 06:23 PM

Orcist,

Going from 3.5.3.0 to 4.x will require “pkg install libraw” before you run the pkg add -f command.
  • Baenwort likes this

#20 SuperMinecraftKid OFFLINE  

SuperMinecraftKid

    Advanced Member

  • Members
  • 53 posts
  • Local time: 08:49 PM
  • LocationMinnesota

Posted 21 January 2019 - 10:57 PM

Very nice 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users