Jump to content


Photo

Emby cannot open images

ffmpeg error ubuntu image

  • Please log in to reply
1 reply to this topic

#1 CherryTree OFFLINE  

CherryTree

    Newbie

  • Members
  • 1 posts
  • Local time: 01:44 AM

Posted 10 December 2018 - 06:12 PM

Hi,

 

I just installed Emby and it works perfectly. Except the images. I cannot access them and that's what I saw in the log:

2018-12-10 17:06:50.191 Error App: Image Provider - Error reading image tag for /mnt/media/test.jpg
	*** Error Report ***
	Version: 3.5.3.0
	Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb
	Operating system: Unix 4.15.0.42
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 1
	Program data path: /var/lib/emby
	Application directory: /opt/emby-server/system
	TagLib.CorruptFileException: Expected SOI marker at the start of the file.
	   at TagLib.Jpeg.File.ValidateHeader()
	   at TagLib.Jpeg.File.Read(ReadStyle propertiesStyle)   at TagLib.File.Create(IFileAbstraction abstraction, String mimetype, ReadStyle propertiesStyle)
	   at Emby.Photos.PhotoProvider.FetchAsync(Photo item, MetadataRefreshOptions options, CancellationToken cancellationToken)
	TagLib.CorruptFileException
	   at TagLib.Jpeg.File.ValidateHeader()
	   at TagLib.Jpeg.File.Read(ReadStyle propertiesStyle)   at TagLib.File.Create(IFileAbstraction abstraction, String mimetype, ReadStyle propertiesStyle)
	   at Emby.Photos.PhotoProvider.FetchAsync(Photo item, MetadataRefreshOptions options, CancellationToken cancellationToken)

The file is not corrupted, I can open it with any other file manager.

 

Edit: Solved. Just had to rescan everything.


Edited by CherryTree, 10 December 2018 - 06:17 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 138046 posts
  • Local time: 08:44 PM

Posted 10 December 2018 - 07:21 PM

Hi, thanks for the feedback, glad it is sorted out.







Also tagged with one or more of these keywords: ffmpeg, error, ubuntu, image

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users