Jump to content

Hebrew subtitles not showing correctly


shraga
 Share

Recommended Posts

Hello,

 

Hebrew subtitles are not displayed correctly in my emby server either in the web player or in the LG TV app.

the problem is essentially the same as was previously reported here for iOS:

https://github.com/MediaBrowser/Emby/issues/3137

(probably an issue with left-to-right languages in general)

 

 

for example this is a text from a hebrew srt file:

23
00:04:57,124 --> 00:05:00,999
?מה קורה
.אני לא שומע אתכם

this is a screenshot from the emby player - note the misplaced punctuation:

5bb8baae5a5f4_embysnip.jpg

 

 

this is a screenshot from VLC player where the same subtitle file is displayed correctly:

 

5bb8be544e295_vlcsnip.jpg

 

 

can this be fixed ?

 

 

Link to comment
Share on other sites

If that's happening in the web player then there's not much we can do other than force transcoding and burn them in. You're probably not going to like the impact that's going to have on your server.

Link to comment
Share on other sites

I found this post 

https://emby.media/community/index.php?/topic/61575-hebrew-subtitles-weird-behaviour-in-multiple-devices/

where it looks like the problem was (partially) solved in the latest iOS beta version,

cant this be done in the windows version as well ?

 

what will be the impact of transcoding on my server ? my alternative for watching videos with hebrew subtitles at the moment is playing them with VLC

and streaming to my TV using the built-in miracast option, which works quite smoothly. (just of course not as convenient as playing directly from the TV app)

Link to comment
Share on other sites

UPDATE: I found a workaround for this issue by editing the .srt file in SubtitleEdit, it has an option "Edit-->Reverse RTL start/end" 

which apparently moves the punctuation marks from the end to the beginning of each line,  so when the order is reversed by emby it actually displays correctly ...

 

while this seems to work fine it would be nice to have this feature built in to the emby player, so that we will not have to manually fix each subtitle file

Link to comment
Share on other sites

Sorry but I just saw that that there is actually still a problem with the LG app ... 

 

in fact the original subtitle seems to display *correctly* in the LG app when there is  *one subtitle line*.

However when there are two lines (as in the above screen) it seems that the app joins them into one line without fixing the punctuation first,

so the text in above example shows as :

 

5bb921d5d4d56_lgsnip.jpg

that is, it first joins the lines and then reverses the order (moving the question mark to the end) 

instead of reversing the order of each line  first and then joining them.

Link to comment
Share on other sites

Hi Luke

 

Can you please address the issue of the subtitles lines being merged incorrectly in the LG app ?

 

Will you be working on a fix for that ? 

Link to comment
Share on other sites

  • 4 months later...

For the browser, please try Emby Server 4.1.0.9+ once available for your platform.

 

Have you tried the latest update to the Emby Apple TV app with the new video player?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...