Jump to content

HDR rarely detected


Pantalaimon
 Share

Recommended Posts

Pantalaimon

I'm having some problem with 4K HDR content for a while now. Whenever I try to play 4K HDR content on my nVidia Shield, it rarely detects HDR and gives me washed out colors most of the time. For a while I thought HDR was broken altogether, but it appears that on rare occasions HDR decides to kick in on playback.

 

I can't find a constant factor. I've fiddled around with the settings and tried multiple video files, but the issue seems completely random.

 

It's not a problem with the TV itself; it plays HDR blurays just fine.

 

 

Edited by Pantalaimon
Link to comment
Share on other sites

  • 4 weeks later...

There seems to be plenty of reports of this , I have the same issue myself. All hdr content works fine on plex, but emby only a few titles work. I've tried the beta version of client and it's still the same. Fyi I'm using nvidia shield.

 

Sent from my SM-G965F using Tapatalk

Link to comment
Share on other sites

There seems to be plenty of reports of this , I have the same issue myself. All hdr content works fine on plex, but emby only a few titles work. I've tried the beta version of client and it's still the same. Fyi I'm using nvidia shield.

 

Sent from my SM-G965F using Tapatalk

 

And, what is different about the ones that work vs. the ones that don't?

Link to comment
Share on other sites

Jdiesel

The vertical resolution on the video that doesn't work is 1920. Can you confirm that the other files that don't work have a vertical resolution other than 2160?

Link to comment
Share on other sites

Jdiesel

As a test can you make sure the Shields system resolution is set to 2160p and disable refresh rate switching in the Emby app and try the video again. I'm wondering if the refresh rate/resolution switching is getting choked up by the 1920 vertical resolution and switching the output.

Link to comment
Share on other sites

Pantalaimon

Looking at the photos by agentp1, I noticed the video where HDR works is full-frame 3840x2160, whereas the resolution on the other video is cropped. This sounded familiar, as another topic of mine about 4K resolution switching also originated from cropped formats.

 

I've tested this theory, and it seems full-frame 3840x2160 HDR videos indeed play with HDR, and cropped formats have issues. Funny thing is that after I play a few moments of a full-frame video with HDR, and then start a cropped video, good change (but not always) HDR will work as well. However any other cropped video after that will fail again. Never mind this last part, can't reproduce it systematically.

 

I've tested with cropped formats around 3840x1600

Edited by Pantalaimon
Link to comment
Share on other sites

Yes!!! Some hdr will only work after first finding hdr that always works! I thought that was odd... not in to test unfortunately

 

Sent from my SM-G965F using Tapatalk

Link to comment
Share on other sites

Guest asrequested

That does seem to be consistent. I just tried playing a range of HDR titles. The titles that are cropped, play with no HDR. The full frame titles play with HDR, although, I have one movie that won't play at all and it's being transcoded (sent log at 12.15pm)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...