Jump to content


Photo
- - - - -

MBC Xbox 360 - Cannot Play Video Error

mbc xbox 360 extender cannot play video h.264

Best Answer boston_BEN , 09 April 2014 - 08:33 PM

Problem solved.

 

The issue was the container format after all, not the codecs.

 

I reset shark007 codecs back to "at installation" settings.  I probably could have uninstalled it altogether though.

 

To get the problematic .avi files to play, I did the following...

 

1) I installed a program called VideoContainerSwitcher (can be found on SourceForge).

    1a) It needs ffmpeg to run, so install that too if you do not have it already.

2) Open VCS and point it to a folder containing the file(s) you want to change (or drag and drop).

3) In my case, the files I wanted to change were .avi, so I selected that as the input format. 

3) My .avi files were using the mkv container, so I selected the mp4 container as the output format.

4) In about 10 seconds, I had a copy of the original file, but with the mp4 container (no transcoding).

5) I changed the file extension of the new file from .mp4 back to .avi.

6) I uploaded it to my NAS, updated the MB3 library and most played on the Xbox 360 MBC just fine.

7) The few that didn't play were too high of a bit rate (over 5Mpbs peak). So, I used WinDirStat to analyze my movies folder.

    7a) I made sure the largest files (ie, higher bitrate files) were .wmv (which was easy as WinDirStat color codes).  If they weren't, I converted them to .wmv.

 

Big cheers for no (well, very little) transcoding!!

 

Special thanks to ebr, floh (Florian Fahrenberger), and philippe734.

Go to the full post


  • Please log in to reply
7 replies to this topic

#1 boston_BEN OFFLINE  

boston_BEN

    Newbie

  • Members
  • 7 posts
  • Local time: 02:56 PM

Posted 09 April 2014 - 12:42 AM

Hello,

 

I'm getting the "cannot play video" error in MBC on my Xbox 360 for files I'm sure should play OK.  They are mainly 720p .avi videos (h.264 + MPEG AAC). Most are in stereo, some 5.1. They all play in WMP and WMC just fine.  They are housed on a NAS, but I use the correct path reference (that is, not a drive letter).  All my 1080p .wmv and 480 .avi (DIVX + AC3) from the same NAS play fine on the Xbox.

 

Oddly, one .avi video plays OK and it is the same exact format as the ones that won't play (h.264, 23.9 fps, 4:2:0 YUV, MPEG AAC-SBR 48kHz Stereo).

 

I installed the Shark007 codec pack and set it to the default settings, checked the MBC log files, restated the PC, scoured the MB3 support pages, everything I can think of, but couldn't find a resolution.  The log below shows that I played 12 Years a Slave.wmv without a problem, but 21 Jump Street.avi stopped MBC dead in its tracks and gave the "Cannot Play Video" error.

 

Any ideas as to how I can fix this issue?  I figure its a codec problem, but I'm not sure what to try next.

Thanks in advance.

 

Dedicated Media PC info:

192.168.1.112

Win 7 x32

Shark007 x32 Advanced codec pack

No other 3rd party codecs installed

 

 

 

 

2014-04-08 11:50:47.3165,Debug,,Reporting stopped to server for 12 Years a Slave,16,Worker thread for Playback Finished

2014-04-08 11:50:47.3180,Debug,,Sending Http Delete to http://192.168.1.112...00000,16,Worker thread for Playback Finished
2014-04-08 11:50:47.3485,Info,,Sending Http Get to http://192.168.1.112...=Json,16,Worker thread for Playback Finished
2014-04-08 11:50:47.3865,Debug,,Setting new status on 12 Years a Slave with parent of Movies,16,Worker thread for Playback Finished
2014-04-08 11:50:47.3880,Debug,,Firing Application.PlaybackFinished for: 12 Years a Slave,16,Worker thread for Playback Finished
2014-04-08 11:50:47.3885,Debug,,Updating Resume status...,16,Worker thread for Playback Finished
2014-04-08 11:50:47.3905,Debug,,All post-playback actions have completed.,16,Worker thread for Playback Finished
2014-04-08 11:50:47.8361,Info,,Received web socket message: UserDataChanged,5,
2014-04-08 11:50:51.4335,Info,,Sending Http Get to http://192.168.1.112...n,1,Application
2014-04-08 11:50:54.5754,Debug,,Fetching image: http://192.168.1.112...a2c8e5ce,32,Net Image loader-Worker
2014-04-08 11:50:54.5754,Debug,,Loading full details for 21 Jump Street,1,Application
2014-04-08 11:50:54.5754,Info,,Sending Http Get to http://192.168.1.112...n,1,Application
2014-04-08 11:50:54.6154,Debug,,Fetching image: http://192.168.1.112...2d91d51b,33,Net Image loader-Worker
2014-04-08 11:50:58.6334,Debug,,Fetching image: http://192.168.1.112...576c471c,33,Net Image loader-Worker
2014-04-08 11:50:58.6569,Info,,Sending Http Get to http://192.168.1.112...=Json,41,Worker thread for Special Feature Load
2014-04-08 11:50:58.6659,Info,,Sending Http Get to http://192.168.1.112...n,1,Application
2014-04-08 11:50:58.7034,Debug,,Fetching image: http://192.168.1.112...0,1,Application
2014-04-08 11:50:58.7705,Debug,,===CustomImage resx://MediaBrowser/MediaBrowser.Resources/hdtype_720 being cached on first access.  Should only have to do this once per session...,1,Application
2014-04-08 11:51:05.9524,Info,,Internal Player about to play 21 Jump Street(\\NSA325\video\Movies\21 Jump Street\21 Jump Street 2012.avi) ,43,Worker thread for Play Action
2014-04-08 11:51:05.9529,Info,,Sending Http Get to http://192.168.1.112...=Json,43,Worker thread for Play Action
2014-04-08 11:51:05.9739,Info,,Internal Player playing 21 Jump Street,43,Worker thread for Play Action
2014-04-08 11:51:05.9759,Debug,,Calling MediaCenterEnvironment.PlayMedia,1,Application

Edited by boston_BEN, 09 April 2014 - 01:35 AM.


#2 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 09:56 AM

Posted 09 April 2014 - 08:13 AM

Best guess is you don't have your permissions set properly.  The 360 uses a hidden user account on the Windows host machine for which you cannot know the password.  So, you must give "Everyone" access to your media shares.



#3 boston_BEN OFFLINE  

boston_BEN

    Newbie

  • Members
  • 7 posts
  • Local time: 02:56 PM

Posted 09 April 2014 - 09:08 AM

Hi ebr,

 

Thank you for the reply.

 

I believe the permissions are set correctly.  If they weren't, I imagine none of the my video files, which are all housed in the same folder on my NAS, would play.  However, many of them play just fine.

 

Am I wrong in that assumption?  Is it possible that two video files in the same folder on the same NAS could have different permissions?

 

The media location path is \\NSA325\video\Movies

 

Thanks


Edited by boston_BEN, 09 April 2014 - 09:15 AM.


#4 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 09:56 AM

Posted 09 April 2014 - 11:26 AM

From the log it is the extender that is crapping out.  Or, more properly WMC when on the extender.

 

It could be the bitrate of the files in question.  I've heard the 360 does have problems with high bitrates.



#5 boston_BEN OFFLINE  

boston_BEN

    Newbie

  • Members
  • 7 posts
  • Local time: 02:56 PM

Posted 09 April 2014 - 01:26 PM

Hi ebr,

 

I agree that the error must be coming from the extender.  MB seems to be handling everything OK and WMC can play the video just fine on the desktop, so that leaves the extender.  I don't believe the bitrate is the issue because the .avi video that does play tops out at 4200 kbps while one of the videos that won't play tops out at only 3800 kbps.  Of course both videos average much lower bitrates, around just 900 kbps.

 

If I understand the Windows Media Extender system correctly, it creates a remote desktop connection via a hidden user account (Mcx1) on the host PC.  So, I'd imagine that if the video plays in WMC on the desktop of the host PC without issue, then it should play on the extender too.  The only problem I can imagine is that the hidden Mcx1 user either didn't get it's own copy of shark007 codecs when I installed them or doesn't have access to the codecs in my user account.  Either way, I'm unsure how to fix it.

 

Is there a step that I could have missed that allows the shark007 codecs to be used by the Mcx1 user account?

 

Thank you again for your help with this issue.



#6 boston_BEN OFFLINE  

boston_BEN

    Newbie

  • Members
  • 7 posts
  • Local time: 02:56 PM

Posted 09 April 2014 - 02:15 PM

Well, I think I found the problem.

 

I searched the shark007 website and found forum posts with screen shots from a program called mediainfo.  I installed it and found that the "containers" for my .avi files were different.  I thought the container was the same as the file extension (so .avi in this case) but mediainfo showed that the videos that played OK have MPEG-4 containers while the videos that didn't work had Matroska containers,

 

I guess the extender can't handle this, so I'll try to remux the videos into a different container and see if it helps anything.  If it doesn't, I'll just convert them to .wmv, which works but obviously takes more time.



#7 ebr OFFLINE  

ebr

    Chief Bottle Washer

  • Administrators
  • 52001 posts
  • Local time: 09:56 AM

Posted 09 April 2014 - 03:28 PM

Yeah, mkv and 360s don't get along very well.



#8 boston_BEN OFFLINE  

boston_BEN

    Newbie

  • Members
  • 7 posts
  • Local time: 02:56 PM

Posted 09 April 2014 - 08:33 PM   Best Answer

Problem solved.

 

The issue was the container format after all, not the codecs.

 

I reset shark007 codecs back to "at installation" settings.  I probably could have uninstalled it altogether though.

 

To get the problematic .avi files to play, I did the following...

 

1) I installed a program called VideoContainerSwitcher (can be found on SourceForge).

    1a) It needs ffmpeg to run, so install that too if you do not have it already.

2) Open VCS and point it to a folder containing the file(s) you want to change (or drag and drop).

3) In my case, the files I wanted to change were .avi, so I selected that as the input format. 

3) My .avi files were using the mkv container, so I selected the mp4 container as the output format.

4) In about 10 seconds, I had a copy of the original file, but with the mp4 container (no transcoding).

5) I changed the file extension of the new file from .mp4 back to .avi.

6) I uploaded it to my NAS, updated the MB3 library and most played on the Xbox 360 MBC just fine.

7) The few that didn't play were too high of a bit rate (over 5Mpbs peak). So, I used WinDirStat to analyze my movies folder.

    7a) I made sure the largest files (ie, higher bitrate files) were .wmv (which was easy as WinDirStat color codes).  If they weren't, I converted them to .wmv.

 

Big cheers for no (well, very little) transcoding!!

 

Special thanks to ebr, floh (Florian Fahrenberger), and philippe734.


Edited by boston_BEN, 11 April 2014 - 01:20 AM.






Also tagged with one or more of these keywords: mbc, xbox 360, extender, cannot play video, h.264

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users