Jump to content
Sign in to follow this  
jasonwilliams

Hauppauge HD PVR

Recommended Posts

jasonwilliams

Hello,

 

I recently configured Emby to use WinTV using my Hauppauge HD PVR.  Everything works great!  One thing I noticed is that if I close Emby while streaming Live TV, WinTV doesn't seem to release the HD PVR and I need to restart the WinTV service to get it working again.  If I use the back button, everything works perfectly.  This issue might only apply to PVR devices from Hauppauge because they work a little differently than a traiditional tuner.  This would apply to HD PVR, Collossus, & HD PVR II.  

 

Thanks,

 

Jason

Share this post


Link to post
Share on other sites
ebr

Hi.  What, exaclty, do you mean by "close Emby while streaming live TV"?

 

What app?  What device?  How do you "close" it?

Share this post


Link to post
Share on other sites
jasonwilliams

Hi ebr,

 

This is happening on all the clients I have (Emby Theater on Android, Emby Theater on Windows 10 Mobile, Web Client, Emby Theater for XBOX).  What I mean is if you close Emby by clicking the X top right while streaming, WinTV doesn't release the tuner.

 

If you click the Back button in Emby, WinTV does release the tuner.

Share this post


Link to post
Share on other sites
Luke

Well there is no top right X on Xbox One so how is it happening there?

Share this post


Link to post
Share on other sites
ebr

Nor is there on mobile - unless you go to the sessions view which is essentially a force-close of the app.

 

In those types of situations, the app is not always allowed to shut down gracefully so, from the server's perspective, it just stops requesting data.  After a while, the server should notice this and close out the stream.  Have you tried waiting for a few minutes to see if that happens?

Share this post


Link to post
Share on other sites
jasonwilliams

Yes, sorry.  

 

With XBOX, you click Home, select Emby, Click Menu button and choose "Quit Emby".  I don't normally do this except when Emby hangs.  With XBOX the problem happens most when you just click Home and choose another app.  Emby continues to run in the background, but the stream is interuppted and you get the same result.

 

On Windows Mobile, long click the back button and Close the App.  It also happens when you let Emby run in the background and start another media app, like Spotify.

 

On Android, it happens when you click the Select button and close the window.

 

I will try waiting longer.  Till now I have tried waiting about 5 minutes.  I'll time it out and report back.

Share this post


Link to post
Share on other sites
Luke

If you stop video first inside the emby app, everything will be cleaned up immediately. if you stop just by closing the app entirely, it may take the server a few minutes to realize it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...