Jump to content


Photo

some observations and thoughts

emby server mac osx

  • Please log in to reply
39 replies to this topic

#21 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 304 posts
  • Local time: 08:49 AM

Posted 05 July 2018 - 05:44 PM

You can find your log location on the Dashboard

 

 

Oh, I knew that but I thought I have to do something more specific than finding locations of logs.

 

Anyway I zipped whole log folder, can I attach you that? Should I send you here or somewhere else?



#22 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 11:49 PM
  • LocationWashington State

Posted 05 July 2018 - 05:50 PM

Oh, I knew that but I thought I have to do something more specific than finding locations of logs.

 

Anyway I zipped whole log folder, can I attach you that? Should I send you here or somewhere else?

 

It is up to you if you would like to attach them here or PM them.  If you PM them ensure to add Luke into the conversation.



#23 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 11:49 PM
  • LocationWashington State

Posted 05 July 2018 - 06:31 PM

Did you just remove the Genre Cleaner plugin?  

 

Logs show it was a version behind also 1.0.7.0 vs 1.0.8.0


Edited by Happy2Play, 05 July 2018 - 06:34 PM.


#24 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 304 posts
  • Local time: 08:49 AM

Posted 05 July 2018 - 06:42 PM

Yes I removed it because I never used it.

#25 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 304 posts
  • Local time: 08:49 AM

Posted 05 July 2018 - 06:44 PM

Do you think that pluggin has something to do with it?

#26 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 11:49 PM
  • LocationWashington State

Posted 05 July 2018 - 07:27 PM

Do you think that pluggin has something to do with it?

 

It really depends on if you ever configured it?  Have you tested the issue since removing?



#27 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 304 posts
  • Local time: 08:49 AM

Posted 05 July 2018 - 07:30 PM

I just opened the settings once and didn’t touch anything. Then I uninstalled it immediately. Issue was present before I did that and after I uninstalled it.

#28 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 304 posts
  • Local time: 08:49 AM

Posted 05 July 2018 - 07:33 PM

Last thing I did I was testing genre adding in another library. I added 2 different genres to same movie. One of those appeared and another one didn’t appear under Genres tab.

#29 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 11:49 PM
  • LocationWashington State

Posted 05 July 2018 - 07:34 PM

Last thing I did I was testing genre adding in another library. I added 2 different genres to same movie. One of those appeared and another one didn’t appear under Genres tab.

 

Can you sent that log.



#30 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 304 posts
  • Local time: 08:49 AM

Posted 05 July 2018 - 07:37 PM

I did that earlier. It should be among those I sent you. I used Hip-hop and R’n’B as genre names for Block Party movie. Hip-hop appeared as genre. The other one didn’t.

#31 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 11:49 PM
  • LocationWashington State

Posted 05 July 2018 - 08:36 PM

@Luke

 

Not sure if it is a timing issue, but I could somewhat reproduce this.  Adding a Genre you don't already have and refreshing the item at item level wouldn't update (updated item to show genre but selecting caused spinner and genre not populated via Genre), but preforming a library scan via the dashboard everything worked properly.

 

@levander

 

Do you only see this on Genres that you don't already have in your library?



#32 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 304 posts
  • Local time: 08:49 AM

Posted 05 July 2018 - 08:41 PM

This happens only to (most of) genres that are not scraped, that I add myself if that’s what you mean. (I always scan libraries from dashboard view.)

#33 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 11:49 PM
  • LocationWashington State

Posted 05 July 2018 - 08:59 PM

Sorry no matter the genre I add to any content type, and perform a library scan it appear in media and genre and is selectable.

 

5b3ebe71cb74b_Genre.jpg

 

 

 

I didn't see anything in your logs maybe Luke will, but until your server indexes the new genre you will get spinning circle.

 

5b3ebe856b98b_genre2.jpg



#34 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 304 posts
  • Local time: 08:49 AM

Posted 05 July 2018 - 09:14 PM

So do you suggest that I just click on genre and wait no matter how long for spinning to be over and it will be indexed then?

I can try that.

#35 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 11:49 PM
  • LocationWashington State

Posted 05 July 2018 - 09:36 PM

So do you suggest that I just click on genre and wait no matter how long for spinning to be over and it will be indexed then?

I can try that.

 

If a library scan is not picking up the genre additions clicking on it will never provide anything.  But the issue is either specific to your setup or the OS as I don't see this on Windows after a library refresh.

 

Just have to wait and see if Luke has any ideas.


Edited by Happy2Play, 05 July 2018 - 09:37 PM.

  • levander likes this

#36 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:49 AM

Posted 08 July 2018 - 12:48 PM

Unfortuantely i can't reproduce this. I think we should probably re-evaluate following the upcoming new release of the server. Thanks.


  • levander likes this

#37 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15358 posts
  • Local time: 11:49 PM
  • LocationWashington State

Posted 12 July 2018 - 05:08 PM

Search by Original Title


  • levander likes this

#38 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 304 posts
  • Local time: 08:49 AM

Posted 21 July 2018 - 01:43 PM

Genres issue update @Happy2Play @Luke

 

It seems that all genres appeared after I used "scan all libraries" from dashboard (actually I haven't even clicked it but it automatically started after I added some folder to one of the libraries). I am not sure that this emby 3.5.0.0 related. Maybe you could test it on previous stable release and investigate this further in hope you will be able to pin down the problem/solution.

 

P.S.

I tested adding some genres after that and library scan wouldn't help showing the genre but "all libraries scan" worked! It seems somehow logical to try to use "scan all libraries" now.. :)


Edited by levander, 21 July 2018 - 01:46 PM.


#39 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:49 AM

Posted 21 July 2018 - 05:22 PM

Thanks for the feedback. In a future update we'll improve it so that the scan isn't needed after editing.


  • levander likes this

#40 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 136138 posts
  • Local time: 02:49 AM

Posted 12 November 2018 - 03:20 PM

Here's the latest beta server for MacOS, for those interested:

https://emby.media/c...beta-for-macos/

 

Thanks.







Also tagged with one or more of these keywords: emby server, mac, osx

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users