Jump to content


Photo

some observations and thoughts

emby server mac osx

  • Please log in to reply
39 replies to this topic

#1 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 301 posts
  • Local time: 04:28 AM

Posted 03 July 2018 - 06:20 PM

Hi, I would like to share some observations and thoughts on emby server. I am a new user so forgive me if some issues I am mentioning here have been already discussed on the forum. 

 

 

Feature request:

 

- option to disable media deletion from within server (and consequently from within any client) for administrator

 

In these few weeks of using emby I happen to accidentally delete some media couple of times. Fortunately, both times I was lucky. BUT I realised it could have been much worse scenario and that some users weren't so lucky. I searched for an option to disable delete but I couldn't. Please do something about it, this shouldn't be allowed to happen by accident just because there is no logical option to restrict meddling with media files. Option to disable delete or triple password to confirm or similar. Also, in the meantime or if you don't intend to change this please suggest a workaround (?)

 

 

Bugs/Not working/Should work:

 

 

- per library setting for metadata language not working

 

I've been regularly having situations where I needed to identify movie within library and it would regularly update in some random language although I set it up in library settings. The solution is workaround: to set up metadata language for every movie per se. I already reported that but here it is again. Apart from that emby scraper (and Identify feature) works generally very very good.

 

 

- collection items disappear after relocating media

 

Which is so unfortunate because collections are one of the greatest features emby and I use it a lot. Unfortunately I found out that most of my manually created collections are just lost effort after I re-organized some media folders. I need to be able to re-organize folder structure of my media from time to time and I need those collections...

 

sort by release date not working

 

Not even close. Not in separate libraries, not in grouped libraries.

 

 

 

Fix/Should work better:

 

 

- search is too often too slow or is not working at all

 

I believe you are aware of this. And I believe you are working on improvements. Search by original title should be included. As well as collections and tags. I sometimes wait 30-45 seconds to get results. And sometimes it doesn't respond at all and then I have to try to search from another library or from dashboard.

 

- browsing through pages doesn't remember position when "refreshed"

 

and it is pretty frustrating when trying to fix something among 12000 titles and every time it throws me back on 1st page. I suppose it is more realistic that this "fix" will be part of new ui at one point but until then it would be VERY helpful to have some kind of index (1-100 | 101 - 200 | 201 - 300| ... | 9901- 10000)

 

 

 

Small things that could make things more practical but also not essential:

 

 

- Include media path in Identify window so you save user's steps before pre-identifing what to identify... It is logical (in most cases) that Identify is to be used when media is incorrectly scraped, so instead scrolling to the bottom of the page to check which title we want to identify there could be path visible in Identify window. At least.

 

- Make media file path at the bottom of movie details page as link so it could be opened/showed in finder/windows explorer. I frequently use select text and then open in finder in safari but this could be more convenient maybe.

 

 

Couple of questions:

 

- Why nfos use 2 x imdb ids?

 

- Why some of manually added genres are shown under genres in library and some are not?

 

 

 

Thanks for reading.


Edited by levander, 03 July 2018 - 07:10 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135862 posts
  • Local time: 10:28 PM

Posted 03 July 2018 - 10:17 PM

 

 

 option to disable media deletion from within server (and consequently from within any client) for administrator

 

Hi, we already have this. You can disable this for any user via user permissions. To learn more, please check out our user wiki: https://github.com/M...Wiki/wiki/Users

 

Please let us know if this helps. Thanks !


  • levander likes this

#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135862 posts
  • Local time: 10:28 PM

Posted 03 July 2018 - 10:17 PM

 

 

per library setting for metadata language not working

Can you please go over a specific example? thanks.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135862 posts
  • Local time: 10:28 PM

Posted 03 July 2018 - 10:18 PM

 

 

sort by release date not working

this works just fine in my testing. can you please go over an example? this is dependent on the release date value being filled in for your media items. is it?



#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135862 posts
  • Local time: 10:28 PM

Posted 03 July 2018 - 10:19 PM

 

 

- Why nfos use 2 x imdb ids?

Many people use Emby Server to create nfo's so that other programs can read them, and different programs support differing conventions of how the id's are stored in the file. We have tried to be accommodating so that's why we just write them all.



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135862 posts
  • Local time: 10:28 PM

Posted 03 July 2018 - 10:20 PM

 

 

 Why some of manually added genres are shown under genres in library and some are not?

This works just fine but currently if you add a new genre it won't show up until you've run a library scan. it's something we'll improve in the future. thanks !



#7 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 301 posts
  • Local time: 04:28 AM

Posted 03 July 2018 - 11:49 PM

This works just fine but currently if you add a new genre it won't show up until you've run a library scan. it's something we'll improve in the future. thanks !

 

 

It's not working fine in my case. I've been adding genres gradually and after frequent library scans most of them just haven't been picked up by the library: they ARE shown in details page but when clicked nothing happens, "the waiting circle" seems to go on indefinitely - actually this happens when clicked those genres that didn't show up under library genres in the first place. 


Edited by levander, 03 July 2018 - 11:50 PM.


#8 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 301 posts
  • Local time: 04:28 AM

Posted 04 July 2018 - 12:11 AM

Hi, we already have this. You can disable this for any user via user permissions. To learn more, please check out our user wiki: https://github.com/M...Wiki/wiki/Users

 

Please let us know if this helps. Thanks !

 

Thanks! I missed it although I tried to find it before. I kept clicking on profile in top right corner but there is just limited setups available (password and pin). Maybe add "more user related setup" link there.

 

Let me just explain how I deleted some files by accident. It was 2 scenarios:  1. when reorganising collections I automatically clicked delete instead remove from collections on some folders that I put in collection (since delete is used to remove actual collection) 2. I accidentally clicked delete while browsing collections on iOS app because of laggy response.

 

Both cases could happen to anybody, especially new user. Nobody wants to even think about possibility to lose some files. So I would suggest: 1. delete option should be disabled by default. 2. when once enabled make additional warning note that should be confirmed again when deleting actual files is at stake.



#9 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 301 posts
  • Local time: 04:28 AM

Posted 04 July 2018 - 12:25 AM

this works just fine in my testing. can you please go over an example? this is dependent on the release date value being filled in for your media items. is it?

 

 

That is correct. For different reasons obviously many release dates in my case were not scraped at all and in addition some are in disparity to production year. I would have to manually search (or just use random dates) and add dates for each film. I don't think it is not useful to have sort by release date but it would be also logical to have sort by year. 



#10 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 301 posts
  • Local time: 04:28 AM

Posted 04 July 2018 - 12:37 AM

Can you please go over a specific example? thanks.

 

Yes. When I use Identify movie metadata is scraped in italian or french or german or some other language ALTHOUGH it is american movie AND metadata language is set to English in per library settings. So I have to edit movie metadata and set metadata language to english and then Identify again to scrape it in english.



#11 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135862 posts
  • Local time: 10:28 PM

Posted 04 July 2018 - 01:03 AM

Yes. When I use Identify movie metadata is scraped in italian or french or german or some other language ALTHOUGH it is american movie AND metadata language is set to English in per library settings. So I have to edit movie metadata and set metadata language to english and then Identify again to scrape it in english.

 

You may have had a pre-existing nfo with the <language> tag inside set to italian., french or german. That's where the language setting gets written.



#12 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 301 posts
  • Local time: 04:28 AM

Posted 04 July 2018 - 12:49 PM

You may have had a pre-existing nfo with the <language> tag inside set to italian., french or german. That's where the language setting gets written.


Could be, I haven’t checked that. But even if that is the case I wouldn’t be able to search for those nfo specifically or change it manually. Or delete nfo so I can recreate it. Isn’t the idea of setting up something on upper level to override things on lower level?

#13 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 301 posts
  • Local time: 04:28 AM

Posted 04 July 2018 - 12:56 PM

It's not working fine in my case. I've been adding genres gradually and after frequent library scans most of them just haven't been picked up by the library: they ARE shown in details page but when clicked nothing happens, "the waiting circle" seems to go on indefinitely - actually this happens when clicked those genres that didn't show up under library genres in the first place.


I am trying to figure this out but no progress. I added again some genres, scanned the library and nothing. I added some different ones and they show up. I can’t figure out why this behavior. Any ideas?

#14 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135862 posts
  • Local time: 10:28 PM

Posted 04 July 2018 - 10:38 PM

Could be, I haven’t checked that. But even if that is the case I wouldn’t be able to search for those nfo specifically or change it manually. Or delete nfo so I can recreate it. Isn’t the idea of setting up something on upper level to override things on lower level?


The idea is to honor your customizations, so if that's what's in your nfo then that's what we do.

You can set at a top level and override per item if you wish. To edit per item use the editing feature. The language setting is near the bottom. Thanks !

#15 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135862 posts
  • Local time: 10:28 PM

Posted 04 July 2018 - 10:39 PM

In regards to genres, I will do some additional testing. @Happy2Play are you able to reproduce this? Thanks.

#16 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15323 posts
  • Local time: 07:28 PM
  • LocationWashington State

Posted 04 July 2018 - 10:59 PM

Can you provide a specific example.

 

Can you post a server log of you adding a genre?  Does the added genre appear in the nfo file?

 

I can do some testing but if this is OS specific I won't be any help.

 

 

Notepad++ is a good tool to find rogue language tags.



#17 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 301 posts
  • Local time: 04:28 AM

Posted 05 July 2018 - 10:18 AM

The idea is to honor your customizations, so if that's what's in your nfo then that's what we do.

You can set at a top level and override per item if you wish. To edit per item use the editing feature. The language setting is near the bottom. Thanks !

 

 

Hi, thank you all for your time.

 

Ok, I figured out that language of metadata is defined by <language> and movie speaking language is defined by <languages>. I made some tests with random movies which are already in my library where I found <language>Spanish</language> for example, obviously not made by emby (I removed movie from library and re-added it so completely new nfo by emby could be made). So I apologise for any confusion I transferred here but nfo is new for me and I try to figure it out. There are MediaElch and TMM which I used because they offer some useful moves with nfo that emby is missing at this point (imdb tags scraping in MediaElch and bulk editing plus filters in TMM) but they also contributed to this issues.

 

I have some more questions regarding nfo in emby: 

 

  1. if I delete existing nfo file from which library is showing metadata and then rescan the library I noticed the metadatata is still there even if there’s no nfo file. Where does emby keep metadata of a movie and is it possible (and how) to recreate a nfo file back in a folder based on that emby metadata in library in case I ever need it?
  2. Does Replace All Metadata do the same thing as Identify with nfo? And if not what is the difference?
  3. Is there easy way to recreate fresh new nfo from emby? (As far as I know it is only possible by first deleting nfo from movie folder and then removing and re-adding a movie to the library)
  4. Does emby shows/use media information (fileinfo) exclusively from nfo or is it stored somewhere in emby independently? 
  5. In some nfo files I found tmdb list of recommended films (as far as I know now not imported with emby scraper) …does that affect “More Like This” in emby? And is there a way to affect “More Like This” from editing nfo at this point?

Edited by levander, 05 July 2018 - 10:45 AM.


#18 levander OFFLINE  

levander

    Advanced Member

  • Members
  • 301 posts
  • Local time: 04:28 AM

Posted 05 July 2018 - 10:40 AM

Can you provide a specific example.

 

Can you post a server log of you adding a genre?  Does the added genre appear in the nfo file?

 

I can do some testing but if this is OS specific I won't be any help.

 

 

Notepad++ is a good tool to find rogue language tags.

 

Gladly but you have to explain me how to make a server log of me adding a genre.

 

I can tell you these facts:

 

Genres I add (and after I scan the library at least once):

 

- appear in nfo

- it appears on details page of the movie

- it appears in filters

 

- some of it does appear under Genres (in emby server, App TV or iOS) and some does not

- some of it appear after few days, some "never"

- those genres that does not appear under Genres tab do not respond when clicked on in details page (it's just waiting with that circle going)


Edited by levander, 05 July 2018 - 10:45 AM.


#19 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 135862 posts
  • Local time: 10:28 PM

Posted 05 July 2018 - 11:48 AM

Data will still be in the emby database. You need to use the functions inside emby as opposed to just deleting the nfo files.

#20 Happy2Play OFFLINE  

Happy2Play

    Trial and Error

  • Moderators
  • 15323 posts
  • Local time: 07:28 PM
  • LocationWashington State

Posted 05 July 2018 - 03:07 PM

You can find your log location on the Dashboard







Also tagged with one or more of these keywords: emby server, mac, osx

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users