Jump to content


Photo

Subtitle Thai Font is not being used

subtitles thai font

Best Answer Luke , 27 May 2018 - 12:26 AM

Thanks. It's resolved for the next release of Emby Server.

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 talung OFFLINE  

talung

    Newbie

  • Members
  • 8 posts
  • Local time: 06:19 AM

Posted 26 May 2018 - 03:01 AM

Hi Guys,

 

I am running Emby and Plex on the same Ubuntu 16.04 Server and using the same media files and am running into this issue.

 

5b09038de0ce0_Screenshot20180526134112.p

 

Compared to Plex

 

5b0903b810cac_Screenshot20180526134234.p

 

These are using the same media file and same subtitle file.

 

What this appears to me is that Emby is not using the fonts on the Linux box and assuming everything is in default language.  Both of these are set to direct play and not transcoding.

 

Is there something I need to so in order to install alternate language fonts in there?  My wife is Thai, so she wants the Thai subtitles and I prefer Emby over Plex.

 

All I could find in the log files was a whole bunch of this in the transcode file while I was testing stuff:

[Parsed_subtitles_1 @ 0x837460] Glyph 0xDC0 not found, selecting one more font for (Droid Sans Fallback, 700, 0) 

Seems like it is not finding relevant items and falling back to Droid Sans Font.

 

Been searching and googling for a couple of hours.. come up with no fix so far.  Can Anybody point me in the right direction?

 

Thanks

 

PS: On a side note.. anyway to get the auto subtitle downloads to store in the actual media folder like the artwork? Even with the setting set to store in media files... it keeps it in the /var/lib/emby/metadata/... section


Edited by talung, 26 May 2018 - 03:38 AM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152703 posts
  • Local time: 02:19 AM

Posted 26 May 2018 - 09:56 AM

Hi, what kind of subtitles are these?

#3 talung OFFLINE  

talung

    Newbie

  • Members
  • 8 posts
  • Local time: 06:19 AM

Posted 26 May 2018 - 10:02 AM

Hi, what kind of subtitles are these?

 

This particular one is .ssa  (  Divergent.2014.th.ssa )  but it does the same with .srt subtitles.  English ones display fine.  I would imagine it would have issues with hebrew, russian or anything that does not use the english fonts.



#4 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152703 posts
  • Local time: 02:19 AM

Posted 26 May 2018 - 03:24 PM

Can you zip up some subtitles for testing and attach them here? thanks.



#5 talung OFFLINE  

talung

    Newbie

  • Members
  • 8 posts
  • Local time: 06:19 AM

Posted 26 May 2018 - 09:55 PM

Can you zip up some subtitles for testing and attach them here? thanks.

 

I have attached a file that contains subtitles from Divergent and Insurgent.

 

This is where it becomes weird.  English ones work with no issue.

 

Divergent.2014.th.ssa  - gives weird font

 

Insurgent.2015.th.srt   - weird font

 

Insurgent.2015.th.ssa  -  works and prints fine.

 

nfi what is going on here.  

Attached Files



#6 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152703 posts
  • Local time: 02:19 AM

Posted 27 May 2018 - 12:26 AM   Best Answer

Thanks. It's resolved for the next release of Emby Server.


  • talung likes this

#7 talung OFFLINE  

talung

    Newbie

  • Members
  • 8 posts
  • Local time: 06:19 AM

Posted 27 May 2018 - 02:43 AM

Thanks.

 

Appreciate the quick response.







Also tagged with one or more of these keywords: subtitles, thai, font

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users