Jump to content
Matthew Binns

4K content and the Emby LG app

Recommended Posts

Matthew Binns

Just a little feedback on my initial experiments with 4K playback using the Emby LG app.

 

I'm finding some 4K content works and some doesn't.

 

'Sully' 4K for instance will not play on the Emby LG App. It will play on the LG Plex app. Same results for 'Jigsaw' and 'It'.

 

I'm playing UHD rips from my 4K blu-rays made using makemkv.

 

That being said, where files do play I am noticing quality degradation. 'Argo' for instance streamed via the LG app looks terrible (however the server does say it's direct playing).

 

'Argo' streamed via DNLA to my UHD blu-ray player looks far, far better and as per the disc.

 

So as it stands, if I want to watch 4K rips using Emby, the LG app is not up to the job. This may in part also be due to the TV itself. DNLA to the TV also results in reduced quality (however all files do manage to at least play, same as Plex). There could also be bandwidth issues involved. The LG TV does not have a gigabit LAN port.

 

To sum up, the only way for me to get the true 4K (exactly as per the disc) is to stream using my phone or iPad via DNLA to my Oppo UDP203 and then HDMI into the TV.

 

 

TL:DN

Emby LG app plays some 4K (albeit in reduced quality.

Plex LG app plays all 4K (albeit in reduced quality).

Edited by Matthew Binns
  • Like 1

Share this post


Link to post
Share on other sites
SamES

Hi, thanks for the feedback.  Could you please provide the mediainfo for examples that play well, play badly and don't play at all and the log files when trying to play these files.

 

Please take note of the audio format of your files.  For TrueHD, this is not supported by the TV so it must convert it somehow.  Currently it will transcode which means both the audio and video will be converted to another format.  This will result in lower quality, at the very least it will drop down to 1080p.

 

In the next release, it will DirectStream these files, so it will only convert the audio and there will be no loss of video quality. 

 

I'm taking a guess here but I suspect this is your problem.

  • Like 1

Share this post


Link to post
Share on other sites
Matthew Binns

My pleasure. that makes sense, when I rip I rip the movie and the HD audio.

 

Sully - (does not play)

 

 

Media Info

Video Title4K HEVC
CodecHEVC
ProfileMain 10
Level153
Resolution3840x2160
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.9760246
Bitrate66786 kbps
Pixel formatyuv420p10le
Ref frames1
Audio TitleEng TRUEHD 7.1 Default
Languageeng
CodecTRUEHD
Layout7.1
Channels8 ch
Sample rate48000 Hz
Bit depth24 bit
DefaultYes
Containermkv
Path/Volumes/Media 1/Video/Movies/Sully (2016)/Sully (2016).mkv

 

Jigsaw - (does not play)

 

 

Media Info

Video Title4K HEVC
CodecHEVC
ProfileMain 10
Level153
Resolution3840x2160
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.9760246
Bitrate75897 kbps
Pixel formatyuv420p10le
Ref frames1
Audio TitleEng TRUEHD 7.1 Default
Languageeng
CodecTRUEHD
Layout7.1
Channels8 ch
Sample rate48000 Hz
Bit depth24 bit
DefaultYes
Containermkv
Path/Volumes/Media 1/Video/Movies/Jigsaw (2017)/Jigsaw (2017).mkv

 

IT - (does not play)

 

 

Media Info

Video Title4K HEVC
CodecHEVC
ProfileMain 10
Level153
Resolution3840x2160
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.9760246
Bitrate53734 kbps
Pixel formatyuv420p10le
Ref frames1
Audio TitleEng TRUEHD 7.1 Default
Languageeng
CodecTRUEHD
Layout7.1
Channels8 ch
Sample rate48000 Hz
Bit depth24 bit
DefaultYes
Containermkv
Path/Volumes/Media 1/Video/Movies/IT (2017)/IT (2017).mkv
 
 
Argo - (does play - video quality reduced)
 
 
Media Info
Video Title4K HEVC
CodecHEVC
ProfileMain 10
Level153
Resolution3840x2160
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.9760246
Bitrate52232 kbps
Pixel formatyuv420p10le
Ref frames1
Audio TitleEng DTS 5.1 Default
Languageeng
CodecDTS
ProfileDTS-HD MA
Layout5.1
Channels6 ch
Sample rate48000 Hz
Bit depth24 bit
DefaultYes
Containermkv
Path/Volumes/Media 1/Video/Movies/Argo (2012)/Argo (2012).mkv
 
 
Looks possibly a True HD issue (DTS-HD MA plays).
 
​The quality degradation on the movie that does play is repeated on Plex so I don't strictly think it is an Emby issue.
 
​Whilst all files do play in the LG Plex app it is far from ideal - some buffering and occasional blockiness. This I believe to be down to bandwidth and the lack of gigabit ethernet on the TV.
 
I'd like to keep the HD audio (I have a 5.1.2 Atmos setup) so it makes sense to use an iPad as a remote and go DNLA to my Oppo, into the receiver and out to the TV.
 
Appreciate the very speedy response :)
Edited by Matthew Binns

Share this post


Link to post
Share on other sites
Matthew Binns

A little more experimentation.

 

'Warhorse' - 1080p file with high res audio.

 

Again - image degradation when played through app. Quality as per disc when played via DNLA to Oppo. Server states 'Direct playing'

 

 

Media Info
VideoTitle1080P H264
CodecH264
AVCYes
ProfileHigh
Level41
Resolution1920x1080
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.9760246
Bitrate29948 kbps
Bit depth8 bit
Pixel formatyuv420p
Ref frames1
NAL4
AudioTitleEng DTS 7.1 Default
Languageeng
CodecDTS
ProfileDTS-HD MA
Layout7.1
Channels8 ch
Sample rate48000 Hz
Bit depth24 bit
DefaultYes
Containermkv
Path/Volumes/Media 1/Video/Movies/War Horse (2011)/War Horse (2011).mkv

 

 

'Se7en' - 1080p file (DTS 5.1 and Dolby Digital 5.1) - Does not play.

 

 

Video

Title1080P VC1
CodecVC1
Codec tagWVC1
ProfileAdvanced
Level3
Resolution1920x1080
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.9760246
Bitrate30385 kbps
Pixel formatyuv420p
Ref frames1

 

 

Audio

TitleEng DTS 5.1 Default
Languageeng
CodecDTS
ProfileDTS
Layout5.1
Channels6 ch
Bitrate1536 kbps
Sample rate48000 Hz
DefaultYes

 

 

AudioTitleEng Dolby Digital 5.1
Languageeng
CodecAC3
Layout5.1
Channels6 ch
Bitrate640 kbps
Sample rate48000 Hz
DefaultNo

 

'No Country for Old Men' - 1080p file (PCM 5.1 and Dolby Digital 5.1) - Does not play - crashed app.

 

 

Media Info
VideoTitle1080P H264
CodecH264
AVCYes
ProfileHigh
Level41
Resolution1920x1080
Aspect ratio16:9
AnamorphicNo
InterlacedNo
Framerate23.9760246
Bitrate29710 kbps
Bit depth8 bit
Pixel formatyuv420p
Ref frames1
NAL4
AudioTitleEng PCM_S16LE 5.1 Default
Languageeng
CodecPCM_S16LE
Layout5.1
Channels6 ch
Bitrate4608 kbps
Sample rate48000 Hz
Bit depth16 bit
DefaultYes
AudioTitleEng Dolby Digital 5.1
Languageeng
CodecAC3
Layout5.1
Channels6 ch
Bitrate640 kbps
Sample rate48000 Hz
DefaultNo
 
Containermkv
Path/Volumes/Media 1/Video/Movies/No Country for Old Men (2008)/No Country for Old Men (2008).mkv

Share this post


Link to post
Share on other sites
SamES

I think the next version with HEVC streaming will be an improvement for you.

 

vc1 video and PCM_S16LE audio are not enabled for DirectPlay, so if you can confirm that these files will play via DLNA or from USB we could look at adding them.

 

I think that covers most of the files.  There are one or two there that surprise me, Warhorse and Argo should work,  but the others make sense, mostly due to the TrueHD audio.

  • Like 1

Share this post


Link to post
Share on other sites
Matthew Binns

Log file attached. Activity is at the bottom.

Log.txt

Share this post


Link to post
Share on other sites
Matthew Binns

Thanks.

 

Se7evn - plays fine over DNLA

Title 1080P VC1

 

No Country for Old Men - plays fine over DNLA

Audio Title Eng PCM_S16LE 5.1 Default

 

Apologies. Correction - Argo does work in the app (albeit with reduced quality video). Warhorse does not work in the app.

Edited by Matthew Binns

Share this post


Link to post
Share on other sites
SamES

I can see a lot of ffmpeg errors in the log.

 

@@Luke, is this a different issue?  

 

     System.ComponentModel.Win32Exception (0x80004005): Permission denied

2018-05-15 13:44:06.116 Error App: Error starting ffmpeg
	*** Error Report ***
	Version: 3.3.1.0
	Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll -psn_0_6809214 -noautorunwebapp
	Operating system: Unix 17.4.0.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 4
	Program data path: /Users/matthewbinns/.config/emby-server
	Application directory: /Applications/EmbyServer.app/Contents/MacOS
	System.ComponentModel.Win32Exception (0x80004005): Permission denied
	   at Interop.Sys.ForkAndExecProcess(String filename, String[] argv, String[] envp, String cwd, Boolean redirectStdin, Boolean redirectStdout, Boolean redirectStderr, Int32& lpChildPid, Int32& stdinFd, Int32& stdoutFd, Int32& stderrFd)
	   at System.Diagnostics.Process.StartCore(ProcessStartInfo startInfo)
	   at System.Diagnostics.Process.Start()
	   at Emby.Server.Implementations.Diagnostics.CommonProcess.Start()
	   at Emby.Server.MediaEncoding.Api.BaseStreamingService.<StartFfMpeg>d__72.MoveNext()
	System.ComponentModel.Win32Exception
	   at Interop.Sys.ForkAndExecProcess(String filename, String[] argv, String[] envp, String cwd, Boolean redirectStdin, Boolean redirectStdout, Boolean redirectStderr, Int32& lpChildPid, Int32& stdinFd, Int32& stdoutFd, Int32& stderrFd)
	   at System.Diagnostics.Process.StartCore(ProcessStartInfo startInfo)
	   at System.Diagnostics.Process.Start()
	   at Emby.Server.Implementations.Diagnostics.CommonProcess.Start()
	   at Emby.Server.MediaEncoding.Api.BaseStreamingService.<StartFfMpeg>d__72.MoveNext()

Share this post


Link to post
Share on other sites
martycirkus

@@SamES

 

Hi,

 

On a LG 2018 Oled 55c8, to direct play hevc 4k hdr mkv files I need to tick-off all transcoding option in the emby server user menu. If not I loose the HDR.

When you say the next version will allow to stream hevc, do you mean that I will have to tick-on the transcoding options, or it's better to leave that off as the 55c8 can read hevc files?

Thanks in advance!

Share this post


Link to post
Share on other sites
Matthew Binns

Just re-ripped War Horse with the standard audio. Still won't play in Emby LG app, IOS apps or Web app.

 

Plays in LG Plex app. Plex IOS apps. Plays streamed to the Oppo.

 

You guys don't like Equestrian films or something?  :D

Share this post


Link to post
Share on other sites
Luke

 

I can see a lot of ffmpeg errors in the log.

 

@@Luke, is this a different issue?  

 

     System.ComponentModel.Win32Exception (0x80004005): Permission denied

2018-05-15 13:44:06.116 Error App: Error starting ffmpeg
	*** Error Report ***
	Version: 3.3.1.0
	Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll -psn_0_6809214 -noautorunwebapp
	Operating system: Unix 17.4.0.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 4
	Program data path: /Users/matthewbinns/.config/emby-server
	Application directory: /Applications/EmbyServer.app/Contents/MacOS
	System.ComponentModel.Win32Exception (0x80004005): Permission denied
	   at Interop.Sys.ForkAndExecProcess(String filename, String[] argv, String[] envp, String cwd, Boolean redirectStdin, Boolean redirectStdout, Boolean redirectStderr, Int32& lpChildPid, Int32& stdinFd, Int32& stdoutFd, Int32& stderrFd)
	   at System.Diagnostics.Process.StartCore(ProcessStartInfo startInfo)
	   at System.Diagnostics.Process.Start()
	   at Emby.Server.Implementations.Diagnostics.CommonProcess.Start()
	   at Emby.Server.MediaEncoding.Api.BaseStreamingService.<StartFfMpeg>d__72.MoveNext()
	System.ComponentModel.Win32Exception
	   at Interop.Sys.ForkAndExecProcess(String filename, String[] argv, String[] envp, String cwd, Boolean redirectStdin, Boolean redirectStdout, Boolean redirectStderr, Int32& lpChildPid, Int32& stdinFd, Int32& stdoutFd, Int32& stderrFd)
	   at System.Diagnostics.Process.StartCore(ProcessStartInfo startInfo)
	   at System.Diagnostics.Process.Start()
	   at Emby.Server.Implementations.Diagnostics.CommonProcess.Start()
	   at Emby.Server.MediaEncoding.Api.BaseStreamingService.<StartFfMpeg>d__72.MoveNext()

 

That's different and unrelated. We're seeing some situations on MacOS where it doesn't' appear the server has permissions to execute ffmpeg, and we're still trying to chase that down.

Share this post


Link to post
Share on other sites
SamES

@@SamES

 

Hi,

 

On a LG 2018 Oled 55c8, to direct play hevc 4k hdr mkv files I need to tick-off all transcoding option in the emby server user menu. If not I loose the HDR.

When you say the next version will allow to stream hevc, do you mean that I will have to tick-on the transcoding options, or it's better to leave that off as the 55c8 can read hevc files?

Thanks in advance!

 

You will set it back to defaults, all options ticked.  The client/server will then determine the best playback option, which will include DirectStream for HEVC once it is enabled.

 

Having said that, if the audio, video, subs, container and bitrate are all compliant, it should DirectPlay 4K with HDR with the current version.  Matthew Binns issue is that TrueHD is not supported for DirectPlay, so in that case DirectStream is the next best option once supported.

 

If you do not have TrueHD audio in the file, then it should be able to DirectPlay and you should not be losing the HDR

Share this post


Link to post
Share on other sites
Luke

Emby for LG 1.07 has just been released. Stay tuned to the Emby blog for the release announcement. Please try it out. Thanks !

Share this post


Link to post
Share on other sites
Matthew Binns

Magic Mouse can't select headings on main screen (Movies, TV Shows, Music) etc.

 

True HD titles still not working.

 

The whole thing looks decidedly low res on my screen. Has the resolution been altered?

 

War Horse is now playing though.

 

Se7en and No Country for Old Men still not playing.

Edited by Matthew Binns

Share this post


Link to post
Share on other sites
martycirkus

You will set it back to defaults, all options ticked.  The client/server will then determine the best playback option, which will include DirectStream for HEVC once it is enabled.

 

Having said that, if the audio, video, subs, container and bitrate are all compliant, it should DirectPlay 4K with HDR with the current version.  Matthew Binns issue is that TrueHD is not supported for DirectPlay, so in that case DirectStream is the next best option once supported.

 

If you do not have TrueHD audio in the file, then it should be able to DirectPlay and you should not be losing the HDR

Hi,

I installed the 1.07 LG Emby app but I have the same problem on 2 mkv hevc 4k hdr files.

-1st "Baby Driver", the file is direct-streamed, hdr ok but I have some strange color artefacts that alternate with a normal image quality. 2 audio tracks DD5.1 and TrueHD, sound is played ok with both tracks.

-2nd "The commuter", the file is transcoded and plyed in a very stuttering way. No hdr.  Same 2 audio tracks played ok.

 

When I tick-off all remuxing and transcoding option everything is ok (appart image based subs not played).

 

Here are the logs:

 

 

ps: yes the whole interface on LG Emby app seems to be lowres now.

post-307492-0-51249800-1526667489_thumb.jpeg

ffmpeg-directstream-cee00a2c-3c95-49dc-8c21-bd3f8e652536.txt

ffmpeg-transcode-508a4f08-9594-46f6-8214-7cb68d7f5b02.txt

Edited by martycirkus

Share this post


Link to post
Share on other sites
Matthew Binns

ps: yes the whole interface on LG Emby app seems to be lowres now.

 

 

Glad it's not just me. Looks pretty nasty doesn't it.

 

Also if you view by genres the thumbnails are stretched to be squares.

 

Don't understand, the IOS apps look great.

 

Plex 1, Emby 0 as far as the LG app goes in it's current state.

Share this post


Link to post
Share on other sites
SamES

Magic Mouse can't select headings on main screen (Movies, TV Shows, Music) etc.

 

True HD titles still not working.

 

The whole thing looks decidedly low res on my screen. Has the resolution been altered?

 

War Horse is now playing though.

 

Se7en and No Country for Old Men still not playing.

 

TrueHD won't work. Firmware update is supposed to allow HDMI passthru for some OLED models, but not through the TV speakers.  The app has no way of knowing whether the receiver supports TrueHD, so this will always be transcoded.

 

We need to add vc1 video and PCM_S16LE audio (probably next release) for Se7en and No Country for Old Men.

 

I know what's causing the menu selection issue, we can fix that.

 

We're investigating the res issues.

Share this post


Link to post
Share on other sites
SamES

Hi,

I installed the 1.07 LG Emby app but I have the same problem on 2 mkv hevc 4k hdr files.

-1st "Baby Driver", the file is direct-streamed, hdr ok but I have some strange color artefacts that alternate with a normal image quality. 2 audio tracks DD5.1 and TrueHD, sound is played ok with both tracks.

-2nd "The commuter", the file is transcoded and plyed in a very stuttering way. No hdr.  Same 2 audio tracks played ok.

 

When I tick-off all remuxing and transcoding option everything is ok (appart image based subs not played).

 

Here are the logs:

 

 

ps: yes the whole interface on LG Emby app seems to be lowres now.

 

Not sure about the color artifacts.  I've seen some 4K/HEVC video that has some strange artifacts when DirectPlaying on Samsung as well.  I expect that this is an incompatibility of some type.  Does this file play OK via DLNA or USB?

 

For the Commuter, it looks like you are trying to play PGS subtitles.  If they are PGS/graphical subs they will always transcode.  Your only option is to get text subs for the file, or extract them yourself to text files using Siubtitle Edit or some other program (or tun off subs of course :))

Edited by SamES

Share this post


Link to post
Share on other sites
Matthew Binns

TrueHD won't work. Firmware update is supposed to allow HDMI passthru for some OLED models, but not through the TV speakers.  The app has no way of knowing whether the receiver supports TrueHD, so this will always be transcoded.

 

 

Appreciate the response.

 

7.1 TrueHD titles are now playing. (Fantastic Beasts)

 

5b0031e8675d0_ScreenShot20180519at151616

 

5b00322818989_ScreenShot20180519at151745

Share this post


Link to post
Share on other sites
SamES

Correct, but it is streaming, so if you check Stats for Nerds, you will see the audio track is not TrueHD, probably being converted to AC3.  Video is not being touched.

Share this post


Link to post
Share on other sites
Matthew Binns

Correct, but it is streaming, so if you check Stats for Nerds, you will see the audio track is not TrueHD, probably being converted to AC3.  Video is not being touched.

 

 

I'm fine with that. I'm not expecting TrueHD via ARC through the LG app - I'll stream over DNLA to my Oppo for that.

 

But prior to today they wouldn't play at all using the LG app.

 

Now I have the option of watching not on my main system. In stereo in the bedroom for example.

Edited by Matthew Binns
  • Like 1

Share this post


Link to post
Share on other sites
martycirkus

Not sure about the color artifacts.  I've seen some 4K/HEVC video that has some strange artifacts when DirectPlaying on Samsung as well.  I expect that this is an incompatibility of some type.  Does this file play OK via DLNA or USB?

 

For the Commuter, it looks like you are trying to play PGS subtitles.  If they are PGS/graphical subs they will always transcode.  Your only option is to get text subs for the file, or extract them yourself to text files using Siubtitle Edit or some other program (or tun off subs of course :))

Thx for the answer,

About the color artefact, it happens only when remuxing/streaming, direct playing is fine.

Yes it was the pgs subs that caused transcoding.

And it seems DTS can't be streaming/remuxing.

(I've just read the reason " Because anytime we have to remux, we use the HLS protocol, and that doesn't support carrying DTS")!! :D

Edited by martycirkus

Share this post


Link to post
Share on other sites
martycirkus

Glad it's not just me. Looks pretty nasty doesn't it.

 

Also if you view by genres the thumbnails are stretched to be squares.

 

Don't understand, the IOS apps look great.

 

Plex 1, Emby 0 as far as the LG app goes in it's current state.

Yep,

For example when you want to click (with the LG Magic remote and the motion cursor) on a playlist/folder etc... name, you have to put the cursor a little below the text and click there to have it working.

Share this post


Link to post
Share on other sites
martycirkus

Thx for the answer,

About the color artefact, it happens only when remuxing/streaming, direct playing is fine.

Yes it was the pgs subs that caused transcoding.

And it seems DTS can't be streaming/remuxing.

(I've just read the reason " Because anytime we have to remux, we use the HLS protocol, and that doesn't support carrying DTS")!! :D

 

 

Concerning DTS I made some tests with all transcoding/remuxing options ticked-on: (quality on 4k-120Mbps)

-On a mkv 4k HDR HEVC (main10 104,8Mbps) very big file (81go) I have 4 audio tracks :

-DTS-HD MA 7.1 48kHz 24bit

-DTS-HD MA 5.1 48kHz 24bit

-DTS-HD MA 2.0 48kHz 24bit

-DTS 2.0 768kbps 48Khz

 

To have a smooth playing, emby server will have to direct stream, but there are some strange behaviors:

With all transcoding/remuxing options ticked-off, the file is direct played but buffering/stuttering too much and it is unwatchable (play few seconds, stop, play again etc...) (HDR ok).

With all options ticked on, when I launch play, beginning with DTS-HD 7.1, it will be direct played, then I switch to DTS-HD 5.1 (during playing) then it switches to direct stream (with audio becoming ac3), then switching again to 7.1 and direct stream works again...  When I begin with DTS-HD 5.1 it will direct stream, and switching to 7.1 will keep direct streaming...  HDR working every time.   Strange no??

Direct streaming with 7.1 will be as stuttering/buffering than direct playing. And 5.1 will direct streams smoothly with few little pauses from time to time.

What do you think?

embyserver.txt

ffmpeg-remux-1c96db38-7d14-4ca5-88b7-a09708068382.txt

ffmpeg-remux-948919fc-ce90-4fcb-92f4-c77ab27f3ab0.txt

Share this post


Link to post
Share on other sites
Luke

Concerning DTS I made some tests with all transcoding/remuxing options ticked-on: (quality on 4k-120Mbps)

-On a mkv 4k HDR HEVC (main10 104,8Mbps) very big file (81go) I have 4 audio tracks :

-DTS-HD MA 7.1 48kHz 24bit

-DTS-HD MA 5.1 48kHz 24bit

-DTS-HD MA 2.0 48kHz 24bit

-DTS 2.0 768kbps 48Khz

 

To have a smooth playing, emby server will have to direct stream, but there are some strange behaviors:

With all transcoding/remuxing options ticked-off, the file is direct played but buffering/stuttering too much and it is unwatchable (play few seconds, stop, play again etc...) (HDR ok).

With all options ticked on, when I launch play, beginning with DTS-HD 7.1, it will be direct played, then I switch to DTS-HD 5.1 (during playing) then it switches to direct stream (with audio becoming ac3), then switching again to 7.1 and direct stream works again...  When I begin with DTS-HD 5.1 it will direct stream, and switching to 7.1 will keep direct streaming...  HDR working every time.   Strange no??

Direct streaming with 7.1 will be as stuttering/buffering than direct playing. And 5.1 will direct streams smoothly with few little pauses from time to time.

What do you think?

https://emby.media/community/index.php?/topic/59096-lg-smart-tv-app-is-encoding-although-not-necessary/?p=579737

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...