Jump to content

Missing Pictures after Update to 3.4


Soki
 Share

Recommended Posts

Good morning,

 

after updating from 3.3x to 3.4 via dpkg I am missing several pictures.

There are some folder pictures missing and a lot of pictures from media inside of all folders.

Never had this problem before after an update.

 

How to proceed from here?

 

 

EDIT:

Testet via different browsers and accounts, cleared cache of all testet browsers.

 

EDIT2:

Found several "Error ImageProcessor: Error encoding image" in server log. See attached.
included server log.txt  (changed url, private and public ips).

 

 

Thanks in advance

Soki

Log.txt

Edited by Soki
Link to comment
Share on other sites

Found a workaround in another post.

"sudo ln -s /var/lib/emby /var/lib/emby-server" did the trick for me for it seems emby wants to look for a folder that doesnt exist.

This seems to be coming from switching from legacy version. (missing repo and then switching to manual .deb install).

 

 

Found here in #7

https://emby.media/community/index.php?/topic/58573-can-not-scan-after-upgrade-to-340/

 

 

 

@@Luke ... i am a litle concerned that with another coming update (repo or manual dpkg) i will get into trouble as you stated

here with "Important - Due to this change, it will not be safe to try out the beta and then go back to stable".

If there is a chance to destroy the installation with coming updates could you maybe ensure that theres a noob-friendly

"tutorial" on what to backup, what to do, etc. to be safe here? (If needed... sorry i am not too deep into all this, i am just

afraid to destroy billions of hours of work) :P

Edited by Soki
Link to comment
Share on other sites

Another update:

 

After adding a new media file into the standard media folder and a following scan, this new media is not shown in emby.

 

 

...investigating ... help appreceated.

Link to comment
Share on other sites

Hey Luke,

 

not completely, sorry.

 

I do still encounter the problem that when i add a new media file to my media folder, after a scan this new media file does not show up in emby.

 

Any suggestions?

 

regards

Soki

Link to comment
Share on other sites

Luke

I'm guessing you didn't follow my manual update instructions that I gave you?

 

As far as new media we'd have to look at a specific example. Thanks.

Link to comment
Share on other sites

What instructions do you mean?

I do not use the beta version. All i did is just added a sym link so far.

 

EDIT: found what you meant... reading this manual now. brb.

 

EDIT2: so... all i did was adding a sym link. So i had installed 3.3x via apt-get install... then I installed 3.4 via dpkg.

+ added server log (log3.txt)

 

 

 

Just startet another scan and this popped up in the log:

 

 

2018-05-08 16:18:30.345 Error App: Error validating images for /mnt/media/FILME
    *** Error Report ***
    Version: 3.4.1.0
    Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby-server -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb
    Operating system: Unix 4.2.6.1
    64-Bit OS: True
    64-Bit Process: True
    User Interactive: True
    Processor count: 12
    Program data path: /var/lib/emby-server
    Application directory: /opt/emby-server/system
    System.ArgumentException: Illegal characters in path.
    Parameter name: path
       at System.IO.PathInternal.CheckInvalidPathChars(String path)
       at System.IO.Path.Combine(String path1, String path2)
       at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()
       at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()
       at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)
       at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)
       at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)
       at System.Linq.Enumerable.Concat2Iterator`1.ToArray()
       at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)
       at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)
       at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetFiles(BaseItem item, Boolean includeDirectories, IDirectoryService directoryService)
       at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetImages(BaseItem item, IDirectoryService directoryService)
       at System.Linq.Enumerable.SelectManySingleSelectorIterator`2.ToList()
       at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
       at MediaBrowser.Providers.Manager.ItemImageProvider.ValidateImages(BaseItem item, IEnumerable`1 providers, IDirectoryService directoryService)
       at MediaBrowser.Providers.Manager.MetadataService`2.<RefreshMetadata>d__8.MoveNext()
    System.ArgumentException
       at System.IO.PathInternal.CheckInvalidPathChars(String path)
       at System.IO.Path.Combine(String path1, String path2)
       at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()
       at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()
       at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)
       at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)
       at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)
       at System.Linq.Enumerable.Concat2Iterator`1.ToArray()
       at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)
       at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)
       at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetFiles(BaseItem item, Boolean includeDirectories, IDirectoryService directoryService)
       at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetImages(BaseItem item, IDirectoryService directoryService)
       at System.Linq.Enumerable.SelectManySingleSelectorIterator`2.ToList()
       at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
       at MediaBrowser.Providers.Manager.ItemImageProvider.ValidateImages(BaseItem item, IEnumerable`1 providers, IDirectoryService directoryService)
       at MediaBrowser.Providers.Manager.MetadataService`2.<RefreshMetadata>d__8.MoveNext()

 

 

Any ideas?

Kinda sounds like the sym link may be the problem here!?

log3.txt

Edited by Soki
Link to comment
Share on other sites

no progress so far.

new added media (testet with different files) does not show up in emby after a library scan.

Link to comment
Share on other sites

Sure. Uploaded 2 .mkv files.

Both can be played localy with no problem via different players.

The cotaining folder and files in it where renamed to fit the given style. (name name year country quality.mkv)

After added this to the media folder an scanning no new media is shown in emby. (not on frontpage, not under the media library, nowhere)

 

 

Newest log entry fter the last try (media add and scan):

2018-05-09 04:39:45.144 Error BaseItem: Error refreshing owned items for /mnt/media/FILME	*** Error Report ***	Version: 3.4.1.0	Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby-server -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb	Operating system: Unix 4.2.6.1	64-Bit OS: True	64-Bit Process: True	User Interactive: True	Processor count: 12	Program data path: /var/lib/emby-server	Application directory: /opt/emby-server/system	System.ArgumentException: Illegal characters in path.	Parameter name: path	   at System.IO.PathInternal.CheckInvalidPathChars(String path)	   at System.IO.Path.Combine(String path1, String path2)	   at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()	   at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()	   at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)	   at System.Linq.Enumerable.Concat2Iterator`1.ToArray()	   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)	   at MediaBrowser.Controller.Entities.BaseItem.<RefreshMetadata>d__347.MoveNext()	System.ArgumentException	   at System.IO.PathInternal.CheckInvalidPathChars(String path)	   at System.IO.Path.Combine(String path1, String path2)	   at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()	   at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()	   at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)	   at System.Linq.Enumerable.Concat2Iterator`1.ToArray()	   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)	   at MediaBrowser.Controller.Entities.BaseItem.<RefreshMetadata>d__347.MoveNext()	2018-05-09 04:39:45.154 Error App: Error validating images for /mnt/media/FILME	*** Error Report ***	Version: 3.4.1.0	Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby-server -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb	Operating system: Unix 4.2.6.1	64-Bit OS: True	64-Bit Process: True	User Interactive: True	Processor count: 12	Program data path: /var/lib/emby-server	Application directory: /opt/emby-server/system	System.ArgumentException: Illegal characters in path.	Parameter name: path	   at System.IO.PathInternal.CheckInvalidPathChars(String path)	   at System.IO.Path.Combine(String path1, String path2)	   at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()	   at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()	   at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)	   at System.Linq.Enumerable.Concat2Iterator`1.ToArray()	   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)	   at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetFiles(BaseItem item, Boolean includeDirectories, IDirectoryService directoryService)	   at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetImages(BaseItem item, IDirectoryService directoryService)	   at System.Linq.Enumerable.SelectManySingleSelectorIterator`2.ToList()	   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)	   at MediaBrowser.Providers.Manager.ItemImageProvider.ValidateImages(BaseItem item, IEnumerable`1 providers, IDirectoryService directoryService)	   at MediaBrowser.Providers.Manager.MetadataService`2.<RefreshMetadata>d__8.MoveNext()	System.ArgumentException	   at System.IO.PathInternal.CheckInvalidPathChars(String path)	   at System.IO.Path.Combine(String path1, String path2)	   at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()	   at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()	   at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)	   at System.Linq.Enumerable.Concat2Iterator`1.ToArray()	   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)	   at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetFiles(BaseItem item, Boolean includeDirectories, IDirectoryService directoryService)	   at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetImages(BaseItem item, IDirectoryService directoryService)	   at System.Linq.Enumerable.SelectManySingleSelectorIterator`2.ToList()	   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)	   at MediaBrowser.Providers.Manager.ItemImageProvider.ValidateImages(BaseItem item, IEnumerable`1 providers, IDirectoryService directoryService)	   at MediaBrowser.Providers.Manager.MetadataService`2.<RefreshMetadata>d__8.MoveNext()
Edited by Soki
Link to comment
Share on other sites

Good morning Luke,

 

for testing i renamed one library (in backend), followed by a library scan.

Then i renamed to the orignal name again, added a new media and scanned again.

But sadly, it does still not work. This new media (testet with several media files) does

not show up under the "movies" library.

 

Testet adding this media to another library "doku", and after a scan this new media

showed up there... so it seems it is not all librarys but only certain where i can not

add new stuff anymore.

 

How to proceed from here?

Edited by Soki
Link to comment
Share on other sites

Still no progress, sorry.

 

I am also afraid to delete a library.... do all meta and all pics already exist when i add a new one?

 

The strange thing is, i testet this with all my librarys. Its only ONE library, where i cannot add new media now.

What else could this be?

 

Sorry for pushing this so much but its really kinda urgent.

Soki

Link to comment
Share on other sites

Created a new folder, moved all media to this new folder, created a new library and scanned.

Now, no media from this library is shown anymore. (before it just was new media added to this library, now ALL is gone).

Moved it all back... scanned again... still... no media (in this case now ALL movies!) are gone.

 

HELP.

Edited by Soki
Link to comment
Share on other sites

after adding a new folder and copying all media into this news folder created a new library and scanned.

Still nothing shows up on mainpage emby (just the library but nothing in it).

 

still this error in log:

2018-05-12 07:56:46.423 Error BaseItem: Error refreshing owned items for /mnt/media/media/FILME	*** Error Report ***	Version: 3.4.1.0	Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby-server -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb	Operating system: Unix 4.2.6.1	64-Bit OS: True	64-Bit Process: True	User Interactive: True	Processor count: 12	Program data path: /var/lib/emby-server	Application directory: /opt/emby-server/system	System.ArgumentException: Illegal characters in path.	Parameter name: path	   at System.IO.PathInternal.CheckInvalidPathChars(String path)	   at System.IO.Path.Combine(String path1, String path2)	   at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()	   at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()	   at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)	   at System.Linq.Enumerable.Concat2Iterator`1.ToArray()	   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)	   at MediaBrowser.Controller.Entities.BaseItem.<RefreshMetadata>d__347.MoveNext()	System.ArgumentException	   at System.IO.PathInternal.CheckInvalidPathChars(String path)	   at System.IO.Path.Combine(String path1, String path2)	   at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()	   at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()	   at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)	   at System.Linq.Enumerable.Concat2Iterator`1.ToArray()	   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)	   at MediaBrowser.Controller.Entities.BaseItem.<RefreshMetadata>d__347.MoveNext()	2018-05-12 07:56:46.434 Error App: Error validating images for /mnt/media/media/FILME	*** Error Report ***	Version: 3.4.1.0	Command line: /opt/emby-server/system/EmbyServer.dll -programdata /var/lib/emby-server -ffmpeg /opt/emby-server/bin/ffmpeg -ffprobe /opt/emby-server/bin/ffprobe -restartexitcode 3 -updatepackage emby-server-deb_{version}_amd64.deb	Operating system: Unix 4.2.6.1	64-Bit OS: True	64-Bit Process: True	User Interactive: True	Processor count: 12	Program data path: /var/lib/emby-server	Application directory: /opt/emby-server/system	System.ArgumentException: Illegal characters in path.	Parameter name: path	   at System.IO.PathInternal.CheckInvalidPathChars(String path)	   at System.IO.Path.Combine(String path1, String path2)	   at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()	   at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()	   at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)	   at System.Linq.Enumerable.Concat2Iterator`1.ToArray()	   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)	   at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetFiles(BaseItem item, Boolean includeDirectories, IDirectoryService directoryService)	   at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetImages(BaseItem item, IDirectoryService directoryService)	   at System.Linq.Enumerable.SelectManySingleSelectorIterator`2.ToList()	   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)	   at MediaBrowser.Providers.Manager.ItemImageProvider.ValidateImages(BaseItem item, IEnumerable`1 providers, IDirectoryService directoryService)	   at MediaBrowser.Providers.Manager.MetadataService`2.<RefreshMetadata>d__8.MoveNext()	System.ArgumentException	   at System.IO.PathInternal.CheckInvalidPathChars(String path)	   at System.IO.Path.Combine(String path1, String path2)	   at System.IO.UnixFileSystem.FileSystemEnumerable`1.<Enumerate>d__11.MoveNext()	   at System.Linq.Enumerable.SelectEnumerableIterator`2.MoveNext()	   at System.Collections.Generic.LargeArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.AddRange(IEnumerable`1 items)	   at System.Collections.Generic.SparseArrayBuilder`1.ReserveOrAdd(IEnumerable`1 items)	   at System.Linq.Enumerable.Concat2Iterator`1.ToArray()	   at System.Linq.Enumerable.ToArray[TSource](IEnumerable`1 source)	   at MediaBrowser.Controller.Providers.DirectoryService.GetFileSystemEntries(String path)	   at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetFiles(BaseItem item, Boolean includeDirectories, IDirectoryService directoryService)	   at MediaBrowser.LocalMetadata.Images.LocalImageProvider.GetImages(BaseItem item, IDirectoryService directoryService)	   at System.Linq.Enumerable.SelectManySingleSelectorIterator`2.ToList()	   at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)	   at MediaBrowser.Providers.Manager.ItemImageProvider.ValidateImages(BaseItem item, IEnumerable`1 providers, IDirectoryService directoryService)	   at MediaBrowser.Providers.Manager.MetadataService`2.<RefreshMetadata>d__8.MoveNext()	
Link to comment
Share on other sites

Still no progress here. I am lost.

Did i maybe miss a guide on what to do when one switch from or to legacy?

 

I originaly used repo and now used the deb package. all i did backendwise is setting up a

symlink in /var/lib because emby changed to emby-server (or other way around...at this point

i am just confused).

 

What steps do need to be taken when going from repo to .deb?

 

Anybody?

Link to comment
Share on other sites

I am now having significant issues as well...I just did the same thing as you, I was using repo but it was not updating.  I used the deb install and updated and I thought everything was fine...but I discovered, as you did, that the folder name changed from "emby-server" to "emby" that has caused all kinds of things in my setup to go haywire.  I can fix all the things that are related to my shares, metadata updating etc. that goes on outside of emby...but now it appears that emby itself is broken as I am getting errors trying to scan the library.

 

From the dashboard it displays this...obviously because "emby-server" folder no longer exists.  Other than doing a simlink, is there a way to tell emby that the folder name is different?  I would have assumed that running the deb would have done a proper upgrade, which is what I read from a comment @@Luke made in a post.

 

What to do next?

 

Scan media library failed.
56 minutes ago
Could not find a part of the path '/var/lib/emby-server/root/default/Movies - DS1817'.
Link to comment
Share on other sites

Good morning,

 

i am a litle bit ashamed to tell the outcome of my countless hours investigation this weekend.

... well ... turns out in my collection where 2 media folders with "umlaute"... well that should have

been pretty clear with this above mentioned error "illegal characters in path". I only wished this

error message would have been more clear ... like "THIS or THAT" patch... that would have saved

me alot of headache in this 12h troubleshooting weekend.

 

At this point all seems to run again now. After changing the folders all scans run through and

all librarys are beeing shown again.

 

If i encounter any other problems after the switch from legacy to new version, i will update here.

 

Thanks

Link to comment
Share on other sites

 

I am now having significant issues as well...I just did the same thing as you, I was using repo but it was not updating.  I used the deb install and updated and I thought everything was fine...but I discovered, as you did, that the folder name changed from "emby-server" to "emby" that has caused all kinds of things in my setup to go haywire.  I can fix all the things that are related to my shares, metadata updating etc. that goes on outside of emby...but now it appears that emby itself is broken as I am getting errors trying to scan the library.

 

From the dashboard it displays this...obviously because "emby-server" folder no longer exists.  Other than doing a simlink, is there a way to tell emby that the folder name is different?  I would have assumed that running the deb would have done a proper upgrade, which is what I read from a comment @@Luke made in a post.

 

What to do next?

 

Scan media library failed.
56 minutes ago
Could not find a part of the path '/var/lib/emby-server/root/default/Movies - DS1817'.

 

I remember seeing a post with a similar problem to this in the test area shortly after the switchover to the pre-built packages. I think someone had gone through and made a symlink or something from the old folder to the new folder. I wish i could say i remember better what was done. For many i think its less problematic to backup everything, remove the old emby, install new emby and then restore libraries and such. 

Link to comment
Share on other sites

I remember seeing a post with a similar problem to this in the test area shortly after the switchover to the pre-built packages. I think someone had gone through and made a symlink or something from the old folder to the new folder. I wish i could say i remember better what was done. For many i think its less problematic to backup everything, remove the old emby, install new emby and then restore libraries and such. 

 

 

Thanks, I found that...but I didn't want to mess around with Symlinks, I prefer to keep things clean.  I could be wrong about this, but I don't think restoring a backup would solve the problem because the backup information for each library pointed to the old folder any would simply restore the libraries as they were (pointing to the wrong place).

 

I ended up removing the libraries...which was kind of a chore as it kicked a lot of errors and took a while to remove them all.  I then rebooted and added them back (which also took a while as I have a lot of stuff to scan in each library).  In the end, it seems to all be working normally now.  Was a pain though for sure.

 

I see that @@Luke mentioned this is fixed in a beta or something so it doesn't happen to folks in the future...so that is a good thing.

 

Thanks.

Link to comment
Share on other sites

Luke

Switching between our older install package that updated using apt-get update, and our new .deb based packages is something that wasn't really intended. They are currently not compatible.

 

The best approach would be a fresh install of the new package, or a rename/symlinks of certain folders based on what this user did:

https://emby.media/community/index.php?/topic/58777-scan-media-library-failed-on-ubuntu-version-3410/?p=576120

 

Thanks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...