Jump to content
tekman13

Transcode using SW instead of HW (QuickSync)

Recommended Posts

tekman13

I noticed Emby is not HW transcoding on my machine anymore.  I'm certain it has used hardware to transcode in the past, and pretty sure it was as recently as a couple weeks ago.  Now when I play media, I am seeing high CPU utilization from ffmpeg, and 0% GPU utilization.  I have an i7-7700, and 2 streams is too much for it to even handle. Any ideas on why it isn't using HW?  I checked to make sure HW encoding is enabled in the server settings, and checked the log and it appears that quicksync (libmfx) is enabled in the ffmpeg config (though to TBH I'm not the most experienced with ffmpeg and what don't really know what I'm looking for when it comes to diagnosing).

 

Any thoughts, or anyone else notice this?

Server-Log.txt

Transcode-Log.txt

Share this post


Link to post
Share on other sites
Luke

I would double check to make sure that you have it enabled in server transcoding settings.

 

Also did you overwrite the included ffmpeg executable with your own version? That doesn't look like the one we supply with the server. While you're certainly welcome to do this, you're going to be kind of on your own as far as troubleshooting is concerned. Thanks.

Share this post


Link to post
Share on other sites
tekman13

Confirmed I have hardware transcoding enabled. It is set to Intel QuickSync.  I've even tried to toggle it back and forth a few times to see if that reset something. (super technical level of troubleshooting)

 

I have not replaced ffmpeg.  I just reinstalled the OS last night and the only things installed right now are firefox, bitdefender, and emby.  OS is windows 10.  Emby was downloaded directly from the web.

Share this post


Link to post
Share on other sites
tekman13

Again, not an expert, but looking at the logs again, it looks like the ffmpeg call is missing the --hwaccel options. (Assuming that's necessary for quicksync acceleration.)

Share this post


Link to post
Share on other sites
Luke

My mistake, sorry. Can you show a screenshot of your server transcoding settings? thanks.

Share this post


Link to post
Share on other sites
cybergrimes

Try turning off decode but leave encoding checked, see if you get a different result.

Share this post


Link to post
Share on other sites
tekman13

Turning off decoding pings both the GPU and CPU at 50-60%% for a single stream. It also doesn’t release the resources for a couple minutes after ending the stream.

 

I have an i7-7700. I should be able to get more than 1 stream out of it (and previous to a few weeks ago I thought I saw transcodes at around 10-15% GPU and negligible CPU).

Share this post


Link to post
Share on other sites
tekman13

Turning off decoding pings both the GPU and CPU at 50-60%% for a single stream. It also doesn’t release the resources for a couple minutes after ending the stream.

 

I have an i7-7700. I should be able to get more than 1 stream out of it (and previous to a few weeks ago I thought I saw transcodes at around 10-15% GPU and negligible CPU).

Additionally, the stream never actually plays. I’m only getting the first frame. It just sits with a spinning circle after that.

Share this post


Link to post
Share on other sites
tekman13

My mistake, sorry. Can you show a screenshot of your server transcoding settings? thanks.

Any update or info I can try?

Share this post


Link to post
Share on other sites
Luke

Have you made sure that both windows and your graphics drivers are up to date?

Share this post


Link to post
Share on other sites
tekman13

Have you made sure that both windows and your graphics drivers are up to date?

Yes, but are latest (according to windows update)

Share this post


Link to post
Share on other sites
tekman13

Yes, but are latest (according to windows update)

Both* are latest

Share this post


Link to post
Share on other sites
cybergrimes

Intel dropped new drivers on 3/27, Windows Update probably doesn't have them yet

https://downloadcenter.intel.com/product/98909/Intel-HD-Graphics-630

 

Not sure it will change much, I get similar CPU/GPU usage on my i7-7700t also. I've seen QSV encoding around 10-15% on a single encode before too but not sure it was with Emby *shrug*

Edited by cybergrimes

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...