Jump to content
jakeclifford

ANSWERED Server stuck on indexing

Recommended Posts

jakeclifford

Hi there,

 

i admit to be a new user and i signed up for the premiere monthly package to try emby up again my plex server.  I have a large library and maybe this is related to my problem.  That said my server has been stuck on indexing at 71.7 percent for two weeks now. I have restarted the app, the server many times but still gets stuck in the same spot.  Where I am not familiar with emby i was wondering if perhaps i have something setup wrong.  i wanted to attach the logs but when i click to download the lastest log it says its 4.3gb is that possible?  Anyways i would be very interested to see it functioning properly.  As it stands when i use the player i can see shows in the list no artwork and nothing will play Im assuming its because the server is hung on something.

 

I will happy provide the logs if someone can explain to this newb of emby how to correctly download the logs.  emby is running on a osx dedicated server with the latest software and latest production version of emby.

 

Thanks in advance

 

Share this post


Link to post
Share on other sites
jakeclifford

okay you move me now what?

Share this post


Link to post
Share on other sites
jakeclifford

if i am a premium subscriber why m i moved 

Share this post


Link to post
Share on other sites
Luke

Hi, welcome. If the topic was moved it was done by a moderator. I'm one of the ones who can help you with this so let's take a look.

 

First question is, when the scan appears to be stuck, are you able to stop it by cancelling, or does it stay stuck in a cancelling state. If the former, then we know it's not actually stuck, but just taking a long, long time. If the latter, then it's stuck. Thanks !

Share this post


Link to post
Share on other sites
jakeclifford

let me try

Share this post


Link to post
Share on other sites
jakeclifford

i am rebooting the whole server to see

Share this post


Link to post
Share on other sites
jakeclifford

Okay the server had crashed its been running since last night. Its almost to the 71% mark where it gets stuck but at the moment its at 69%.  I pulled some stats from plex.  I have 3500 plus movies, 4000 music files,  and just over 30,000 tv episodes.  I also have audio books and some other small collections but i didn't add some stuff in until i see how the main stuff worked.  I was able to get the log file so hopefully this helps you understand whats happening to me.

 

Thank you

 

Log.txt

Edited by jakeclifford

Share this post


Link to post
Share on other sites
ebr

if i am a premium subscriber why m i moved 

 

Hi.  The forum you originally posted in is for questions and help with your Emby Premiere subscription specifically (like how to purchase, how to cancel, problems with validating, etc.).  We provide the same support to all users whether Premiere or not so this is the proper area to troubleshoot your problem.

 

Thanks!

Share this post


Link to post
Share on other sites
jakeclifford

Can someone please help?  Its still getting stuck.

Share this post


Link to post
Share on other sites
Guest asrequested

I think it's probably just the initial scan. At certain points it will look like it's stuck, but is just in the middle of a long process. Once complete, the subsequent scans will take far less time.

Share this post


Link to post
Share on other sites
Happy2Play

Has a initial scan ever finished?

 

Hanging around 68% is normal but not for two weeks, 24-48 hours maybe but I guess your actual libraries could be a issue depending on their folder layout.  My first test would be removing your music library.

Share this post


Link to post
Share on other sites
jakeclifford

No been trying for 2 weeks, it always sticks at 71.7 percent never gets past that.

Share this post


Link to post
Share on other sites
jakeclifford

I removed all the libraries but movies and ill try adding them one at a time.

  • Like 1

Share this post


Link to post
Share on other sites
Diedrich

I removed all the libraries but movies and ill try adding them one at a time.

That was going to be exactly my suggestion. I have a feeling you have some unorthodox file system. You can look at the Wiki to look at proper folder structure.

 

If you find a particular medium getting stuck (i.e. TV) then I would start with only having series A-G being scanned. Then you could add in series H-L... and so on, until you find where the scan is getting choked.

 

What is the longest duration you have let it scan?

  • Like 1

Share this post


Link to post
Share on other sites
Guest asrequested

Try this:

 

Add one library at a time, with download artwork disabled. Wait for the scan to complete before adding another. Once all libraries are added, re-enable download artwork, one library at a time. Each time you re-enable downloading artwork, run a scan only on that library. 

  • Like 2

Share this post


Link to post
Share on other sites
Luke

You have a number of plugins installed, and two of them in particular will cause library scans to take longer:

  • kodi sync
  • roku thumbnails

Please try removing those plugins. Additionally it looks like you may have customized the server's cache path but forgotten to grant write access on that folder:

2018-03-28 10:26:52.072 Info HttpClient: GET https://www.thetvdb.com/api/B89CE93890E9419B/series/113561/all/en.zip
2018-03-28 10:26:52.121 Error App: Error in TheTVDB
	*** Error Report ***
	Version: 3.3.0.0
	Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll
	Operating system: Unix 17.4.0.0
	64-Bit OS: True
	64-Bit Process: True
	User Interactive: True
	Processor count: 4
	Program data path: /Users/administrator/emby-server
	Application directory: /Applications/EmbyServer.app/Contents/MacOS
	System.UnauthorizedAccessException: Access to the path '/Volumes/Lacie 1/EMBY/CACHE/cache/tvdb/113561' is denied. ---> System.IO.IOException: Permission denied
	   --- End of inner exception stack trace ---

This is going to create a situation where files are downloaded from the internet over and over because they can't be cached locally.

  • Like 1

Share this post


Link to post
Share on other sites
jakeclifford

Okay i will remove both of those as I am not using either of them.   Also i deleted all libraries except to movie libraries and it did manage to complete that.  It is now scanning one of my tv folders.  I be interested to know what settings are good and bad for the tv shows.  As i left a couple unchecked

post-290458-0-16964300-1522437325_thumb.png

post-290458-0-74464800-1522437337_thumb.png

Edited by jakeclifford

Share this post


Link to post
Share on other sites
ebr

Do you have a Plex server scanning your media at the same time on the same machine?

Share this post


Link to post
Share on other sites
jakeclifford

Okay, removed those plugins and changed the read write on that directory.  good catch i missed that. 

Share this post


Link to post
Share on other sites
jakeclifford

there is a plex server running on the same box, it is already scanned its been running for years.  it only index changed content. 

Share this post


Link to post
Share on other sites
jakeclifford

i turned off plex scanning till this is operational.  just to make sure it doesn't interfere. 

Share this post


Link to post
Share on other sites
jakeclifford

2018-03-30 17:51:37.338 Info HttpClient: POST https://api.opensubtitles.org/xml-rpc

2018-03-30 17:51:37.768 Error SubtitleManager: Error downloading subtitles from Open Subtitles
*** Error Report ***
Version: 3.3.1.0
Command line: /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll /Applications/EmbyServer.app/Contents/MacOS/EmbyServer.dll -psn_0_1712546 -noautorunwebapp
Operating system: Unix 17.4.0.0
64-Bit OS: True
64-Bit Process: True
User Interactive: True
Processor count: 4
Program data path: /Users/administrator/emby-server
Application directory: /Applications/EmbyServer.app/Contents/MacOS
MediaBrowser.Model.Net.HttpException: 520
  at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.<SendAsyncInternal>d__20.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.<SendAsync>d__17.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.MediaEncoding.Subtitles.OpenSubtitleDownloader.<SearchSubtitlesAsync>d__33.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.MediaEncoding.Subtitles.OpenSubtitleDownloader.<Search>d__32.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.Providers.Subtitles.SubtitleManager.<SearchSubtitles>d__16.MoveNext()
MediaBrowser.Model.Net.HttpException
  at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.<SendAsyncInternal>d__20.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at Emby.Server.Implementations.HttpClientManager.CoreHttpClientManager.<SendAsync>d__17.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.MediaEncoding.Subtitles.OpenSubtitleDownloader.<SearchSubtitlesAsync>d__33.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.MediaEncoding.Subtitles.OpenSubtitleDownloader.<Search>d__32.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
  at MediaBrowser.Providers.Subtitles.SubtitleManager.<SearchSubtitles>d__16.MoveNext()

Share this post


Link to post
Share on other sites
jakeclifford

i am getting an error related to open subtitles.  here is an updated log, i have fixed all the above things and seem to be getting closer in traction but on going through the most recent logs i noticed open subtitles error.

 

i have attached the complete log here. 

Share this post


Link to post
Share on other sites
Luke

That's looks like an error coming from open subtitles server. Nothing to worry about. It will handle that and continue forward.

 

I would just allow the scan to finish now that you've made adjustments based on previous suggestions.

Share this post


Link to post
Share on other sites
jakeclifford

okay, i was just letting it scan a small directory of 100 less things before i let it scan my 30,000 plus tv shows lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...