Jump to content


Photo

HEVC / x265 video playback issues iPhone 7 iOS 11.2.6

hevc x265 iOS playback issue

  • Please log in to reply
3 replies to this topic

#1 lateparty OFFLINE  

lateparty

    Advanced Member

  • Members
  • 46 posts
  • Local time: 12:34 AM

Posted 03 March 2018 - 11:25 AM

Hello,

 

Please find below my media playback issue report:

 

Source file stream mediainfo:

  • Video: 4998 Kbps, 1920*1080 at 23.976 fps, HEVC (Main@L4@Main)
  • Audio: 495 Kbps, 48.0 KHz, 6 channels / 2 channels, AAC (LC)

Playback results:

  • Emby: 3.3.0.0
  • Playback Device: iPhone 7 Plus
  • Playback OS: iOS 11.2.6
  • Player: Safari
  • Instance 1: Occurred ~00:53 - Emby user profile with enabled video transcoding policy - Playback result: Video and Audio transcoded to h264/mp3
  • Instance 2: Occurred ~01:05 - Emby user profile with disabled video transcoding policy - Playback result: Black/blank video output, stuttering audio output.

 

Attached are obfuscated logs. Happy to private message the original logs but this should be more than enough detail.

 

Note: I attempted using Aloha browser (my goto for iOS), and the iOS app and got the same results as with Safari, but was expecting transcoding in both. No fault found. 

 

-lateparty

 

Edit 20170304 - Attachment deleted by user.


Edited by lateparty, 03 March 2018 - 10:31 PM.


#2 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 145887 posts
  • Local time: 09:34 AM

Posted 03 March 2018 - 11:57 AM

Hi, it doesn't look like in any of these logs you actually had transcoding disabled.



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 145887 posts
  • Local time: 09:34 AM

Posted 03 March 2018 - 12:01 PM

Ok I see in the log you did direct play. We're direct playing to the apple player. There's not a whole lot we can do change how it behaves. For this reason I would suggest just trusting the defaults and allowing it to transcode.



#4 lateparty OFFLINE  

lateparty

    Advanced Member

  • Members
  • 46 posts
  • Local time: 12:34 AM

Posted 03 March 2018 - 12:17 PM

Thanks for looking into it. Wouldn't have posted this at all if it weren't for https://emby.media/c...87-143/?hl=hevc

 

Will just run the files through Handbrake and live in hope that one day I have a mobile device that can play HEVC files. It's a shame because the file played fine through the LG TV app.







Also tagged with one or more of these keywords: hevc, x265, iOS, playback issue

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users