Jump to content

"Auto" for Android Mobile over Mobile data or external Wi-Fi issues


Richard Branches
 Share

Recommended Posts

Richard Branches

I was testing the "Auto" setting in the Android app with the 3G connection of my phone.

 

What I noticed about the auto setting is that most of the time it doesn't work, with all the testing I made, audio (music library) or video (video library) wasn't transcoded depending on the internet speed of the 3G connection.

 

With the music library, I tested some FLAC files and they were played directly, like the picture below:

 

Since 3G speed is mostly slow, the song stutter a lot, and also the data usage was high because of the file size.

 

5a8dd563ea601_Directplaying.png

 

However, if I set the quality in settings to, for example, 192Kbps, the song is indeed transcoded:

 

5a8dd654abd28_Transcoded.png

 

But according to the log, the song wasn't transcoded to the selected quality (192Kbps) but at 128Kbps, this is what the log says about the transcoding:

 

encoder         : Lavf58.3.100
    Stream #0:0: Audio: aac (LC), 44100 Hz, stereo, fltp (16 bit), 128 kb/s

 

 

- This issue is the same with videos, transcoding only works if I select a quality in settings or when I select a quality during playback.

 

- If you must know, the upload speed of my home internet where the computer with the server is connected is 1Mbps.

 

- I haven't test this with an external Wi-Fi connection but surely it's gonna be the same.

 

- The log is attached to this post as well.

ffmpeg-transcode-44475f42-43e8-4336-a142-757ebbcafb1b.txt

Edited by Richard Branches
Link to comment
Share on other sites

Richard Branches

I received today the Emby server update to version Version 3.3.0.0 and this issue has been partially fixed:

 

- "Auto" is still direct playing some songs in FLAC through mobile data, which uses up a lot of data.

 

- Choosing an specific bitrate in settings is working now but it's transcoding songs with the same bitrate, for example, I selected 320Kbps and all my MP3s are in that bitrate and they are getting transcoded when they shouldn't, the idea is to transcode them ONLY when they are higher than the selected bitrate. However, with "Auto" they are not getting transcoded.

Edited by delacosta78
Link to comment
Share on other sites

Richard Branches

Try refreshing metadata on those albums

 

Remember the other post where I said I had to remove the library and then add it again because refreshing didn't work?...

Link to comment
Share on other sites

Richard Branches

 

What do you want me to do with that? to repeat another post with the same issue already explained here or do you want the logs? please, explain your "how to report a problem" request. Thanks.

Link to comment
Share on other sites

Richard Branches
On 25/02/2018 at 09:37, ebr said:

Hi.  Refresh the album like Luke is requesting, then post the server log from when you did that.

 

Thanks.

 

If "refreshing" means this:

 

5a94bc2b1d5d8_Refreshmetadata.png

 

Then that's what I did.

 

Afterwards, while I was on my phone connected to the 3G data connection, I recorded a screen video from my computer where you can see all the songs I skip are FLAC files not getting transcoded, from minute 1:30 to 3:19 I was trying to switch the quality manually to 320Kbps in settings (Emby app is slow on my phone) and the MP3 you see at the end of the video is a 320Kbps file that was transcoded regardless of whether its bitrate was the same as in settings, so they should be transcoded ONLY if the bitrate is HIGHER.

 

Meanwhile, all the FLAC songs I tested were transcoded correctly to the selected quality (not shown in the video).

 

All the MP3 songs I tested were not transcoded when "Auto" was selected.

 

I was unable to upload the video here so it's on Youtube, although it's not public:

 

https://youtu.be/ajblmlCZVkQ

ffmpeg-transcode-7a8c3abf-e647-4b0e-beb6-ba2161d55205.txt

server-63655228915.txt

Edited by Richard Branches
Link to comment
Share on other sites

FYI the reason for the mp3 transcode is because the file contains embedded images and this pushes the total container bitrate beyond 320k. It's something we can adjust for a future release. thanks.

Link to comment
Share on other sites

Richard Branches

FYI the reason for the mp3 transcode is because the file contains embedded images and this pushes the total container bitrate beyond 320k. It's something we can adjust for a future release. thanks.

 

I thought so...

 

What about "Auto"?, you could see in the video they still are not getting transcoded...

Link to comment
Share on other sites

Richard Branches

Is something wrong about that?

 

Yes!, it's not working!, did you see the video? that's the main purpose of this post, it should transcode automatically all the music while using mobile data or an external wifi connection when the upload speed of the internet where the server is connected is slower than the download speed, in my case my download speed is 5 Mbps but the upload speed is 1 Mbps or less, so playing a hugh FLAC file when I'm using mobile data, the song stutters and takes up too much of my data plan or when I'm at my grandma's internet wifi (which its download speed is also 5Mbps) the song also stutters, the server should transcode them depending on those factors otherwise you should remove that "auto" setting and let users select a manual option instead.

Edited by delacosta78
Link to comment
Share on other sites

Richard Branches

I think we're going in circles now. Try refreshing the metadata of the music album.

 

It doesn't work, please, understand, that's why I insist so much on this because it's not working as it should, you can see it on the video, all the skipped songs are FLAC files that never got transcoded through mobile data, period.

Link to comment
Share on other sites

Richard Branches

Why do you think that refreshing the album doesn't refresh? Can you provide a log from that?

 

"Refreshing" works, "Auto" doesn't work.

 

The only log I can provide is the server log which is already in comment # 12, which was created while I was recording the screen video.

Edited by delacosta78
Link to comment
Share on other sites

Ok, I tested this with both the android app and the web app. Inside the apps I set all playback qualities to Auto. Then on the server i set the internet streaming bitrate limit to:

0.5

Then I tried to play some flac files, and in all cases the flac files were transcoded.

Link to comment
Share on other sites

Ok, I tested this with both the android app and the web app. Inside the apps I set all playback qualities to Auto. Then on the server i set the internet streaming bitrate limit to:

0.5

Then I tried to play some flac files, and in all cases the flac files were transcoded.

 

Maybe I missed it but my understanding of the issue was that he did not set a limit on the server side at all.  Rather, his actual internet connection is quite slow and he thinks our auto bitrate detection on the app end is not discovering this properly.

 

It could be that the detection is running when connected locally and then the network switches and the detection is not re-running before playback (although, I bet it does re-run on a network switch).

 

Even if all of that is working properly, I can imagine some sort of network level caching could still be fooling our auto bitrate detection routine.

 

In any case, it seems to me that, if the outbound connection really is only 1Mb, then the right answer is to do what Luke tested and set the limit on the server so that it will always be sure to work.

Link to comment
Share on other sites

Richard Branches

Ok, I tested this with both the android app and the web app. Inside the apps I set all playback qualities to Auto. Then on the server i set the internet streaming bitrate limit to:

0.5

Then I tried to play some flac files, and in all cases the flac files were transcoded.

 

 

Thanks for the tip, can you tell me where is the option in the server to set the streaming bitrate limit?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...