Jump to content


Photo

Connection failure when attempting to connect remotely

connection failure port forwarding troubleshooting server external

  • Please log in to reply
7 replies to this topic

#1 mrdaneeyul OFFLINE  

mrdaneeyul

    Newbie

  • Members
  • 1 posts
  • Local time: 06:47 AM

Posted 16 January 2018 - 05:57 PM

Hey all! I'm attempting to set up Emby to run externally. However, whenever I attempt to connect with my Android device in either Chrome or the Emby app, I can see the server but get the message "We're unable to connect to the selected server right now. Please ensure it is running and try again."

 

I've been doing a fair bit of research on this issue and haven't been able to find anything that has solved the problem (though plenty of others with similar issues).

 

I've gone through the entire Connection Troubleshooter with no luck. I'm uncertain if my router is blocking traffic and how to check if so.

 

I'm on AT&T U-verse. The combined modem/router that AT&T gave us should be in bridge mode, and I'm using my own router for WiFi and ethernet connections.

 

I've set up a static IP for my PC that's running Emby Server. I've also set up port forwarding on my router for 8096 and that static IP address. Now it shows up as the local address. The remote address, however, is different:

 

 

[image removed]

 

I can connect to the local one from inside my network, no problem there. Still having problems connecting remotely.

 

I've tried both signing in with Emby Connect (the server shows up but gives me the error message when I attempt to connect) and adding a server manually for both the remote and in-home addresses (same message) on my Android from both Chrome and the Emby app. canyouseeme.org is showing my public IP address at port 8096 is not connecting ("Connection refused").

 

I suspect the problem is due to the difference between the two IP addresses, possibly due to the AT&T U-verse modem. I am unable to use that IP address, however, in my port forwarding (my router insists upon 10.166.*.*, which is different from the public IP). I did set "External domain" to the same IP as the In-Home (LAN) access just for kicks and that didn't seem to work either.

 

The attached log file does have an "error processing request" but I don't know if it's related.

 

I did some digging on the forum, on port forwarding in general, and so forth, and now I'm here. Has anyone else run into this particular problem when connecting remotely? Thanks.


Edited by mrdaneeyul, 18 January 2018 - 09:02 AM.
Removed image showing public IP address


#2 sector327 OFFLINE  

sector327

    Advanced Member

  • Members
  • 46 posts
  • Local time: 07:47 AM

Posted 20 August 2018 - 11:24 PM

I know this is an older post but I thought I'd put this here in hopes it might help someone. For the past week or so, I've been setting up my new nas with a new asus router, emby running on an Intel i7 computer. Before this, I had never opened the firewall on the ATT dsl to see if I could get to emby remotely.  Well having so much new on the setup, its been an ordeal to determine where the issue is. Is it the ATT modem I had to completely open? Is it the new Asus router? Is is the firewall in Fedora where Emby is running? I gave up one night and the very next day, emby over the cell data was working! I checked canyouseeme and sure enough, 8096 was open. I was showing this to a friend tonight and all of the sudden, I couldn't connect. canyouseeme was showing port blocked. I hadnt made a change since it had been working. I double checked the att router, asus router, no computer changes (fedora 28) and nothing changed but 8096 still not working. reboot everything. still no work. so I turned on the webserver on the nas, opened port 80 & 8080 on the asus router and sure enough, 80 came through fine but 8080 is blocked. (and fwiw, 8096 still blocked/won't connect.)

 

at this point I'm pretty confident the issue is at&t. I wonder if they are intermittently blocking ports but sometimes lets things through.  I can't wait until Google Fiber gets here!  (hopefully they don't have issues like this. idk....)



#3 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 139953 posts
  • Local time: 07:47 AM

Posted 21 August 2018 - 12:59 PM

Hi, yes you do have to open the 8096 port in your router. You can also try a different port in the event that at&T is blocking it.



#4 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12573 posts
  • Local time: 04:47 AM

Posted 21 August 2018 - 01:13 PM

Try port 443.

#5 sector327 OFFLINE  

sector327

    Advanced Member

  • Members
  • 46 posts
  • Local time: 07:47 AM

Posted 21 August 2018 - 01:28 PM

Hi, yes you do have to open the 8096 port in your router. You can also try a different port in the event that at&T is blocking it.

 

 

Try port 443.

 

 

That's what I thought about this morning. So to get this straight, I'd have the remote emby client ask for http://564.32.71.66:443 (made up IP) and then have the router redirect all port 443 requests to port 8096?  Am I following correctly?  (or are you saying to have emby just run on port 443 instead of 8096? which I guess would be some sort of reconfigure on emby itself)



#6 Doofus OFFLINE  

Doofus

    Advanced Member

  • Members
  • 12573 posts
  • Local time: 04:47 AM

Posted 21 August 2018 - 02:14 PM

You can just choose which port the server uses. You can set it in the server. Unless you want to use redirection?

#7 sector327 OFFLINE  

sector327

    Advanced Member

  • Members
  • 46 posts
  • Local time: 07:47 AM

Posted 21 August 2018 - 02:38 PM

You can just choose which port the server uses. You can set it in the server. Unless you want to use redirection?

 

Ah I see what you mean and I found the setting in Emby. I guess the first step is to figure out what port ATT doesnt block. In my router I just set 443, 80, 8080 (all different tries, not at the same time) all to port forward to 8096 (all forwarding to the emby server) and none are showing as open on canyouseeme. However I did turn the web server on my nas and set 80 to forward to 80 through the router and THAT is working (checked from phone data connection). 

 

(another thing checked, I set the server in the DMZ and 8096 not working there either. )


Edited by sector327, 21 August 2018 - 02:42 PM.


#8 sector327 OFFLINE  

sector327

    Advanced Member

  • Members
  • 46 posts
  • Local time: 07:47 AM

Posted 22 August 2018 - 12:16 AM

Ah I see what you mean and I found the setting in Emby. I guess the first step is to figure out what port ATT doesnt block. In my router I just set 443, 80, 8080 (all different tries, not at the same time) all to port forward to 8096 (all forwarding to the emby server) and none are showing as open on canyouseeme. However I did turn the web server on my nas and set 80 to forward to 80 through the router and THAT is working (checked from phone data connection). 

 

(another thing checked, I set the server in the DMZ and 8096 not working there either. )

 

ok....asus released a FW update for the GT5300 router today. Release notes didn't mention anything about fixing port forwarding or mesh stability but I updated FW and the 8096 is now open. I can access from the outside! (now......no changes ANYWHERE and lets see if this lasts. I don't like ATT or trust them to start but this Asus router has been flaky since the start. Anyone interested in hearing stories about how bad the mesh performance is, look over on snbforum. Yeah....its bad. trust me)


Edited by sector327, 22 August 2018 - 12:19 AM.






Also tagged with one or more of these keywords: connection failure, port forwarding, troubleshooting, server, external

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users