Jump to content

microsoft ehome receiver not working properly in win 10


Recommended Posts

Hey guys, This is not so much an emby problem, just looking for any expert advice from the community.

I have a HTPC that was running Win 7, and used a Fusion Dvico remote (plugged into USB port) for control of my WMC, and also Emby.

After upgrading, finally to Win 10, I have a curious but not unheard of problem, that when the HTPC is turned on, the remote IR receiver driver is not automatically loaded.

Simply unplugging it for 1-2 seconds resolves the issue as the USB Input device driver is then correctly installed, and bingo, I can use my Logitech Harmony for full remote facilities.

I have researched a fair bit and have tried the following:-

1) regedit all USB devices and "ForceHCResetOnResume"

2) use a $5 USB hub controller from the mobo usb ports, and plug the remote receiver into one of these ports

3) tried all different USB ports on the mobo

4) used MCEStandby Tool (which also tries the ForceHCResetOnResume)


Still no go, any guru out there who has experience with this issue?

On some occassions, windows will install "Dvico Remocon V1.00" driver, but on most occassions it seems to just go for "USB Input Device".

Any thoughts?

Thanks Brad

Link to comment
Share on other sites

You can try here http://www.eventghost.net/forum/viewtopic.php?f=13&t=9785. A few other ideas are that if your resuming from sleep you could configure your USB port to not sleep - this is also mentioned around those forums- or if your turning your PC all the way off and all the way on you could somehow attempt to control the order and times at which your drivers are loaded.

Link to comment
Share on other sites

@@Senna, yes I have the same drivers loaded. Problem is they are not loaded  on start, I have to unplug the USB cable and then replug to get the remote recognised.


@@jachin99, thanks for the info I tried eventghost, and can see and add the Dvico fusion remocon v1.00 plugin, but again when I start the htpc, shows plugin, but must unplug/replug to get working.

I find eventghost quite confusing, can see events being logged, but don't really understand what adding the plugin does.


Seems like such a simple problem but for a HTPC it is quite annoying to have to physically unplug/replug every time I start the PC.

Thanks Brad

Link to comment
Share on other sites

Adding the plugin enables EG to read input from your remote. EG itself is just a kind of input output device running in software on your PC. Whatever you decide on your best bet might be to to configure your PC to not let your USB ports sleep. Support for that is also on the EG forums but in a nutshell there are three separate places on your PC you might have to disable this. I believe this is a windows limitation in terms of how will does go in and out of sleep

Link to comment
Share on other sites

From: http://eventghost.net/forum/viewtopic.php?f=2&t=9940


"The issue is not with EG (technically) It is with windows. Specifically with how windows handles it's power state changes and notifications of the programs when this state changes.


When windows goes into Sleep/Hibernate/Standby basically any kind of a lower power consumption state this issue will arise. When windows goes into one of these states it will power down your devices and notify the programs.


These 2 things happen at the same time. but depending on how many applications you have running and what order you started them in is going to make this a ghost problem. it will sometimes happen and sometimes not. Also the speed of your computer has to deal with it as well. But essentially what is happening is the devices are getting powered down before EG gets the notification of the power state change. If you have EG as one of the first things to run you will be less likely to have this problem. Not 100% guarantee tho. So EG sees the devices get unplugged and then the computer goes into a low power state.


When the computer resumes the same thing happens with the devices power being turned back on and the applications being told to start running again.

In some cases the devices will get plugged back in (powered on) before EG resumes so it never sees the devices get added. so it thinks they are still removed from the system. This is the reason why they stop working in EG.


The fix. Buy a faster computer.. and run less programs, and don't have so many devices...


LOL... nah.. I'm joking.


What we need to do is to adjust the power settings. specifically for USB. this is done in 3 places.. the first place being the BIOS of your computer. now this I am not going to be able to give you simple instruction to many variations out there. But poke about you will find the settings.


The second place is Power Options in the control panel. We want to change the Power Profile (Plan). You will need to Create a power plan and you can select any of the 3 options. these are templates. when done with creating it you will want to change the plan settings. in little tiny print you will see Change advanced power settings. You will need to change any and all setting in here that are related to the USB make sure anything that is trying to manage or turn off power or suspend power is turned off.


The 3rd place is in the device manager. this again is one you are going to have to poke about a bit. But you will want to cruz through all of the devices in the Universal Serial Bus Controllers section do to the properties of each item. if you see a power management tab click on it and make sure that the Allow the computer to turn off this device to save power is unchecked.


doing this will ensure that when you PC goes to sleep or standby it will not turn off the power to the USB devices. this will ensure that the devices are present all the time.


If this is not working for you then drop a line and we can walk through and find out what is causing the issue."


If need be start a thread over there. The Emby forums are great but EG forums might be a little better in your case

Link to comment
Share on other sites

Maybe this could be of help, my report from USBtree view for the receiver for comparison.


Edit: And to add to that, mine is connected to an old powered genuine usb2 hub and just as @jachin99 describes perfectly, its setup that when PC goes to sleep or hibernate, the hub remains powered and is not being cut off from power.

eHome Infrared Receiver (USBCIR).txt

Edited by Senna
Link to comment
Share on other sites

Thanks guys, appreciate the help and ideas, have checked the device manager and made sure all power saving features for usb hubs are off, couldn't find any power management issues related to usb settings in the bios (just enabled or disabled), and have checked my power options in windows and made sure that selective usb sleep is off, strange behaviour when I open usbtree viewer, the hub that is the issue, (regardless of location), frequently, shows red symbol on it and then goes beserk trying to connect...this even shows in event ghost









 makes me think it could even be a mobo or the actual receiver power issue...?

Edited by braddles69
Link to comment
Share on other sites

yes...just really annoying...trying to track down this when it worked fine in win 7, upgrade to win 10 and a core function of my htpc...becomes shit...;)

Link to comment
Share on other sites

Thanks for the help guys, appreciate it, but it was doing my head in trying to track down such a simple problem, so in the end I swapped out the Dvico card and receiver for a Videomate E750 card that I had in my office pc, it has dual tuners and...an integrated ir receiver, after installing the drivers it just worked...had to remap my logitech harmony to the new remote, but much easier than tracking down a usb power problem...

thanks again for the input and goodnight,

Cheers Brad

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...