Jump to content

Roku Emby App and Emby Beta App Not playing


gunneric
 Share

Recommended Posts

gunneric

So I've done a complete uninstal and reinstall of both the Emby Server and Roku Emby Apps.  I sent in the Roku Emby Beta App around 5:37pm Pacific and the Roku Emby App around 5:42 pm Pacific.

 

I am attaching my server file.

 

The file I was trying to play for the Emby Beta is "Little Nicky"

 

The file I was trying to play for Emby is "Anger Management"

 

the User name is "Eric"

 

I can see from the Emby Server log that it couldn't access the file because of an System IO, but I have no idea what the Roku responded with as I don't have access to that log.

 

Hope these help.

server-63645670769.txt

Link to comment
Share on other sites

Happy2Play

@@ebr

 

Do you know a reason for the log to have references to UserAgent:  Roku/DVP-6.x and UserAgent:  Roku/DVP-8.0?

Link to comment
Share on other sites

gunneric

The Only difference that I can say is Little Nicky was from the Roku Emby Beta App and Anger Management is from the regular Roku Emby App.  Other than that, they are both on the same Server, same hard drive, same Roku, same folder in the hard drive.

 

I am currently trying moving things in to different folders, Horror, Sci Fi, and the like, giving each it's own tile on the emby server.

 

My thought being that maybe, the "Movies" catagory is just too big at over 200 movies.

 

Same with TV, I now have a Cartoons, Current TV and Old TV.  Since I will have several hundred individual episodes.  I'm wondering if it is just getting overwhelmed parsing it all out.

 

Seems that I had similar trouble before when my library was just too big.  I got rid of a lot of shows that I just didn't watch anymore and everything worked, again.

 

Something to think about.  I'll let you know how this next run goes with the different tiles and sub-folders.

Link to comment
Share on other sites

gunneric

The putting the files in to different tiles didn't work still nothing plays with the Roku Emby App, but it plays fine with the Roku Media Player.

Link to comment
Share on other sites

I don't see any playback attempts in your app logs.  Exactly how did you try to play them?

 

Do these items play from the web app?

Link to comment
Share on other sites

@@ebr

 

Do you know a reason for the log to have references to UserAgent:  Roku/DVP-6.x and UserAgent:  Roku/DVP-8.0?

 

The old user agent is being advertised by the Roku DLNA service it looks like.

Link to comment
Share on other sites

gunneric

Yes, they play from the web app without issue.

 

As I stated in O P they were attempted to be played from the Roku Emby Beta App for Little Nicky and the Channelstore.Roku Emby App for Anger Management.

 

Each sending of the log from the app was right after the play attempt.  The server log shows both attempts to play fail with System IO.

 

Is there a different Roku App that I can install, in a hidden channel or private channel?

Link to comment
Share on other sites

As I stated in O P they were attempted to be played from the Roku Emby Beta App for Little Nicky and the Channelstore.Roku Emby App for Anger Management.

 

Yes, but I'm asking exactly how you did that.

 

e.g.  I navigated to the "On Now" row on the home screen an pressed the "play" button on my remote.  OR I went into my live TV library, selected a program, navigated to the play button on the screen and clicked "OK" on my remote...

Link to comment
Share on other sites

gunneric

Sorry, I didn't understand the question.

 

I believe that with Little Nicky (Roku Emby Beta) I went to the recently added, selected Little Nicky, it went to Little Nicky explanation screen and I played from there.

 

With Anger Management (Roku Emby) I went in through the Movie catalogue, selected Anger Management, it went to Anger Management explanation screen and I played from there.

 

In both instances, after selecting play, I got the loading wheel until the screen went blank.  At which time I had to back all of the way out to the Main Roku Menu, reselect the respective Emby App and sent the log file to your servers.

 

Hope this answers your questions.

Link to comment
Share on other sites

At which time I had to back all of the way out to the Main Roku Menu, reselect the respective Emby App and sent the log file to your servers.

 

Ah... thanks.  That explains why I can't see anything in the log.  Once you re-start the app, we get a new log.  That makes this a lot tougher to diagnose.

 

Do you have external access to your server setup?  If so, you could set me up as a guest (create one for 'ebr') and I can see if I can replicate with your content.

 

Thanks.

Link to comment
Share on other sites

gunneric

I still cannot play anything, on my roku express through the emby app.

 

It shouldn't make a difference, but maybe try something on the TV side too.

 

But Like I said it shouldn't make a difference, as I can't play anything from the Roku Emby app.

 

Not sure what I can do to get the Roku Emby App log, I have access to the Roku via the Developer, but I can't get in to it or see anything through web browser.

Edited by gunneric
Link to comment
Share on other sites

gunneric

I see that you ebr were using a Roku Premiere, I wonder if it is a Roku Express issue?

 

I can do everything but watch content.  I can see the content, I can make it watched or un-watched, I just can't play it.  I wonder if the Roku Express just doesn't have the processing power needed to play the content.

 

The strange thing is that it was working before when I had less content.

 

Does the Roku Emby App store information to make the use smoother, maybe uses up the Roku Express on board RAM or ROM that it doesn't release when the user plays the content?

 

I'm just spit balling here.

 

Thoughts????

Link to comment
Share on other sites

Your logs didn't even show an attempt to play the content so something else strange is going on.  I don't have any idea what at this point, though...

Link to comment
Share on other sites

gunneric

I'm going to give the Neon Blue a try, just loaded it, but wont be able to test until tomorrow.

 

Wife currently has control of TV.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...