Jump to content
nekoLite

ANSWERED compile ffmpeg with smb support?

Recommended Posts

nekoLite

Hi! 

 

I have an issue with Emby in that it doesn't keep track of how long I've been watching a movie/episode. Even if I watch it for only 1 second it will immediately mark it as watched. 

 

Looking through these forums I've understood that it is due to Emby not being able to determine the runtime of my files because ffprobe fails. The reason being that I have all my shares mapped over SMB. 

 

The solution I've seen mentioned is to compile FFmpeg with SMB support. Something I've not been able to do. I'm running Linux Mint, and been trying to compile using this guide: https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu only with adding --enable-libsmbclient to the configure part. 

 

'm out of my depth and was hoping someone here has managed to do this themselves? 

Edited by nekoLite

Share this post


Link to post
Share on other sites
mastrmind11

Are you sure that's the problem?  Plenty of people use SMB on these forums, so it seems kind of suspect that SMB would be the culprit.  Have you tried NFS instead?

Share this post


Link to post
Share on other sites
nekoLite

Not sure no, but basing it on the following:

 

1) None of my movies or episodes have any Runtime listed. Which is required for watched/unwatched/resume playback to work properly from what I understand. 

2) When i do a refresh missing information and capture a debug log (see attached) I see the following ffprobe error repeatedly "System.Exception: ffprobe failed - streams and format are both null."

3) The first comment by Luke in this thread: https://emby.media/community/index.php?/topic/47515-ffprobe-errors-on-raspberry-pi-3-when-scanning-library/ - "we've recently added native smb support to emby, however we need to update our installation instructions to mention that ffmpeg needs to be compiled with smb support. That is why you were getting that error. What you've done is fine as a workaround though. Thanks !"

 

If I've come to the wrong conclusion please let me know so that I can look elsewhere for a solution  :huh:

 

EDI1: As for trying with NFS, I would prefer to avoid having to rebuild the media library since it is quite.. large.. and I spent a considerable amount of time correcting metadata and setting the correct watched/unwatched status on everything. 

Log.txt

Edited by nekoLite

Share this post


Link to post
Share on other sites
nekoLite

Iäve also tried the solution found here: https://emby.media/community/index.php?/topic/46809-runtime-missing-possibly-on-all-files/?hl=ffprobe&do=findComment&comment=440834

 

But even if I install ffmpeg myself, and set the correct path in Server Dashboard > Transcoding save the settings and even restart Emby server. When I try to do a refresh it keeps using the ffprobe found in the emby server folder. 

Log2.txt

Edited by nekoLite

Share this post


Link to post
Share on other sites
Luke

Yea for now you will need to build it with smb support on your own but we are planning on adding this to our own ffmpeg build.

 

Another option you can take that might be easier is to avoid smb by mounting the share to a local folder in your OS. Then add that local folder to Emby. That was the "old" way before we added native smb support internally.

 

Let us know if this helps. Thanks !

  • Like 1

Share this post


Link to post
Share on other sites
nekoLite

Thank you for the confirmation Luke, after some thinking and googling I managed to figure out why the compiling wasn't working for me. 

 

I managed to compile ffmpeg with smb support and now it works when it tries to probe them! 

Edited by nekoLite

Share this post


Link to post
Share on other sites
Luke

Thanks for the feedback.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...