Jump to content


Photo

compile ffmpeg with smb support?

smb ffmpeg runtime

Best Answer Luke , 27 June 2017 - 02:53 PM

Yea for now you will need to build it with smb support on your own but we are planning on adding this to our own ffmpeg build.

 

Another option you can take that might be easier is to avoid smb by mounting the share to a local folder in your OS. Then add that local folder to Emby. That was the "old" way before we added native smb support internally.

 

Let us know if this helps. Thanks !

Go to the full post


  • Please log in to reply
6 replies to this topic

#1 nekoLite OFFLINE  

nekoLite

    Newbie

  • Members
  • 5 posts
  • Local time: 09:51 PM

Posted 27 June 2017 - 06:54 AM

Hi! 

 

I have an issue with Emby in that it doesn't keep track of how long I've been watching a movie/episode. Even if I watch it for only 1 second it will immediately mark it as watched. 

 

Looking through these forums I've understood that it is due to Emby not being able to determine the runtime of my files because ffprobe fails. The reason being that I have all my shares mapped over SMB. 

 

The solution I've seen mentioned is to compile FFmpeg with SMB support. Something I've not been able to do. I'm running Linux Mint, and been trying to compile using this guide: https://trac.ffmpeg....ionGuide/Ubuntu only with adding --enable-libsmbclient to the configure part. 

 

'm out of my depth and was hoping someone here has managed to do this themselves? 


Edited by nekoLite, 27 June 2017 - 08:20 AM.


#2 mastrmind11 OFFLINE  

mastrmind11

    Advanced Member

  • Members
  • 2807 posts
  • Local time: 03:51 PM
  • LocationLong Island, NY

Posted 27 June 2017 - 07:57 AM

Are you sure that's the problem?  Plenty of people use SMB on these forums, so it seems kind of suspect that SMB would be the culprit.  Have you tried NFS instead?



#3 nekoLite OFFLINE  

nekoLite

    Newbie

  • Members
  • 5 posts
  • Local time: 09:51 PM

Posted 27 June 2017 - 08:16 AM

Not sure no, but basing it on the following:

 

1) None of my movies or episodes have any Runtime listed. Which is required for watched/unwatched/resume playback to work properly from what I understand. 

2) When i do a refresh missing information and capture a debug log (see attached) I see the following ffprobe error repeatedly "System.Exception: ffprobe failed - streams and format are both null."

3) The first comment by Luke in this thread: https://emby.media/c...anning-library/ - "we've recently added native smb support to emby, however we need to update our installation instructions to mention that ffmpeg needs to be compiled with smb support. That is why you were getting that error. What you've done is fine as a workaround though. Thanks !"

 

If I've come to the wrong conclusion please let me know so that I can look elsewhere for a solution  :huh:

 

EDI1: As for trying with NFS, I would prefer to avoid having to rebuild the media library since it is quite.. large.. and I spent a considerable amount of time correcting metadata and setting the correct watched/unwatched status on everything. 

Attached Files

  • Attached File  Log.txt   1.5MB   1 downloads

Edited by nekoLite, 27 June 2017 - 08:29 AM.


#4 nekoLite OFFLINE  

nekoLite

    Newbie

  • Members
  • 5 posts
  • Local time: 09:51 PM

Posted 27 June 2017 - 10:59 AM

IƤve also tried the solution found here: https://emby.media/c...obe#entry440834

 

But even if I install ffmpeg myself, and set the correct path in Server Dashboard > Transcoding save the settings and even restart Emby server. When I try to do a refresh it keeps using the ffprobe found in the emby server folder. 

Attached Files

  • Attached File  Log2.txt   659.69KB   0 downloads

Edited by nekoLite, 27 June 2017 - 11:05 AM.


#5 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140337 posts
  • Local time: 03:51 PM

Posted 27 June 2017 - 02:53 PM   Best Answer

Yea for now you will need to build it with smb support on your own but we are planning on adding this to our own ffmpeg build.

 

Another option you can take that might be easier is to avoid smb by mounting the share to a local folder in your OS. Then add that local folder to Emby. That was the "old" way before we added native smb support internally.

 

Let us know if this helps. Thanks !


  • nekoLite likes this

#6 nekoLite OFFLINE  

nekoLite

    Newbie

  • Members
  • 5 posts
  • Local time: 09:51 PM

Posted 28 June 2017 - 07:06 AM

Thank you for the confirmation Luke, after some thinking and googling I managed to figure out why the compiling wasn't working for me. 

 

I managed to compile ffmpeg with smb support and now it works when it tries to probe them! 


Edited by nekoLite, 28 June 2017 - 10:35 AM.


#7 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 140337 posts
  • Local time: 03:51 PM

Posted 28 June 2017 - 02:00 PM

Thanks for the feedback.







Also tagged with one or more of these keywords: smb, ffmpeg, runtime

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users