Jump to content

Show Intro Skip Option (Plugin)


Liquidfire88

Recommended Posts

2 minutes ago, Weevillo said:

Right, for this particular show the first episode lacks an intro, as do all the shows in the screenshots I sent earlier which suffer from the same "problem".

ok thanks - leave it with us - everything in the log is suggesting it's doing exactly what it should be (lol) but clearly we have a problem somewhere .. 😜

We may need s1e1,e2 and e3 to investigate - is there a way you can provide these (via a PM link) ?

Link to comment
Share on other sites

17 minutes ago, rbjtech said:

We may need s1e1,e2 and e3 to investigate - is there a way you can provide these (via a PM link) ?

I've sent you a PM.

  • Thanks 1
Link to comment
Share on other sites

fillidill
1 hour ago, Spooky83 said:

Do you only have one user? If so try creating a second one. This solved the problem for me on my test server. 

I actually had two users already. But I tried your suggestion and created a new one but the problem persists :( 

EDIT: A reboot solved it!

Edited by fillidill
  • Like 1
  • Thanks 1
Link to comment
Share on other sites

3 minutes ago, fillidill said:

I actually had two users already. But I tried your suggestion and created a new one but the problem persists :( 

EDIT: A reboot solved it!

A Browser Cache 'clear' would have also likely fixed it - Especially if you ran a previous version of the IntroSkip plugin.

  • Thanks 1
Link to comment
Share on other sites

fillidill

I've played around a bit now and it seems to get the correct intro time frame for all of the shows I've tried which is awesome!
The skip intro function doesn't seem to work very well tough. It randomly works only one time then and again and then stops to work. I can't really figure out why 🧐

Link to comment
Share on other sites

27 minutes ago, fillidill said:

I've played around a bit now and it seems to get the correct intro time frame for all of the shows I've tried which is awesome!
The skip intro function doesn't seem to work very well tough. It randomly works only one time then and again and then stops to work. I can't really figure out why 🧐

Keep in mind that the skip intro functionality does not work if any scans are currently running.  Also, if you have "match resolution" or "match refresh rate" enabled in your client device then any intros that start at 00:00:00 aren't currently skipped.

Edited by datanet
  • Like 2
Link to comment
Share on other sites

2 minutes ago, datanet said:

Keep in mind that the skip intro functionality does not work if any scans are currently running.  Also, if you have "match resolution" or "match refresh rate" enabled in your client device then any intros that start at 00:00:00 will not be skipped.

This is correct, I may have fixed this, but I'm not entirely sure.

We create a monitor that runs alongside the stream.

When the stream starts it calculates when it should skip the intro. It is no longer based on what the client is reporting exclusively.

However, if the client reports an update during progress, we will attempt to sync where the client is with our monitor. 

If match refresh rate is on, it may throw the whole thing off still. That part is still being tested.

  • Like 1
Link to comment
Share on other sites

Also to note, which has thrown me a few times, if you are using a Browser to view/test the Auto-Skip, the first Session that you created is the one that will get the trigger.  So if you then open up a second Tab, Auto-skip will not work on that 2nd tab.  If you go back to the first tab, it should work perfectly well.

 

  • Like 2
Link to comment
Share on other sites

6 minutes ago, chef said:

This is correct, I may have fixed this, but I'm not entirely sure.

We create a monitor that runs alongside the stream.

When the stream starts it calculates when it should skip the intro. It is no longer based on what the client is reporting exclusively.

However, if the client reports an update during progress, we will attempt to sync where the client is with our monitor. 

If match refresh rate is on, it may throw the whole thing off still. That part is still being tested.

I would think that should resolve the problem.  I guess the question is, does the client report an update during progress when the refresh rate or resolution change is initiated or when playback actually starts.  In my case, I have to pad the intro start by a full 5 seconds for it to properly skip the intro after the refresh rate/resolution change.

Link to comment
Share on other sites

fillidill
6 minutes ago, rbjtech said:

Also to note, which has thrown me a few times, if you are using a Browser to view/test the Auto-Skip, the first Session that you created is the one that will get the trigger.  So if you then open up a second Tab, Auto-skip will not work on that 2nd tab.  If you go back to the first tab, it should work perfectly well.

 

After some testing I think you solved my problem, that was it! Now it seems to work consistently.

  • Like 2
Link to comment
Share on other sites

Right auto skip will only run in the first instance of the client.

If auto skip gets extracted into it's own plugin in the future, then perhaps there is a way to do this per actual session/client ID.

 

Link to comment
Share on other sites

9 hours ago, fillidill said:

Hi guys,
Just tried version IntroSkip_v0.0.1.74 on the latest Emby beta for the first time.
I can't seem to choose a user to enable the auto skip feature. Is that possible to do right now or am I doing something wrong? The dropdown is completely empty for me. 

I can't seem to recreate this happening on my server. I have one user, and it shows up in the list.

autoskipUsers.png.07f9baf50afe8d9d58dd707955f3fb09.png

Maybe it only happens on first run?

Link to comment
Share on other sites

Hello !

Just tried this plugin on my server with Emby 4.6.7.0. For my correct understanding, should I see a button during the Intro Sequence asking me if I want to skip Intros like on Plex or is it just an auto skip feature to enable per user in the auto skip page ? I'm currently trying on Safari and it does not seems to work but on Chrome, the auto skip is working.

Thanks for the hard work !

Link to comment
Share on other sites

stevehoffman203
3 hours ago, nSGecko said:

Hello !

Just tried this plugin on my server with Emby 4.6.7.0. For my correct understanding, should I see a button during the Intro Sequence asking me if I want to skip Intros like on Plex or is it just an auto skip feature to enable per user in the auto skip page ? I'm currently trying on Safari and it does not seems to work but on Chrome, the auto skip is working.

Thanks for the hard work !

I have the same issue except I am on 4.7.0.21 beta .  I ran the processes, it found and marked the Title Chapters and they look good, but I don't get a Intro Skip button either.  I've tried Edge and Chrome so far from the computer.  My TVs all run off of Fire TV with the Emby App, but I haven't tried those yet.

2022-01-27 09_19_09-stevehoffman.ddns.net - Remote Desktop Connection.jpg

Link to comment
Share on other sites

samuelqwe

@nSGecko and @stevehoffman203

There is no intro skip button at the moment since plugins don’t have the capability of adding these kinds of things.

Auto skip is the only way to use detected intros currently. The plugin is also still only a beta, but it already works very well.

3 hours ago, nSGecko said:

I'm currently trying on Safari and it does not seems to work but on Chrome, the auto skip is working.

Make sure you only have a single browser window open and that auto skip is enabled for the user, the plugin will only take the first web session per user for the auto skip.

Edited by samuelqwe
  • Agree 2
Link to comment
Share on other sites

To add - the manual 'skip intro' button is definitely on it's way - we have already seen some modifications to the Core emby code to allow us to utilise this.  However, we don't have an ETA at this time. 

If the Intro timing data is good - Auto-Skip works extremely well, so there should be no need for a manual button - but if it's not correct, then of course it will skip part of the show that is not an Intro..

Unlike P**x, you can edit the Intro timings to your liking, or simply remove the timings altogether if you wish.

Link to comment
Share on other sites

stevehoffman203
42 minutes ago, samuelqwe said:

@nSGecko and @stevehoffman203

There is no intro skip button at the moment since plugins don’t have the capability of adding these kinds of things.

Auto skip is the only way to use detected intros currently. The plugin is also still only a beta, but it already works very well.

Make sure you only have a single browser window open and that auto skip is enabled for the user, the plugin will only take the first web session per user for the auto skip.

I must have missed the part of enabling auto skip on the user.  I'll check into that.

Thanks!

  • Like 1
Link to comment
Share on other sites

38 minutes ago, samuelqwe said:

@nSGecko and @stevehoffman203

There is no intro skip button at the moment since plugins don’t have the capability of adding these kinds of things.

Auto skip is the only way to use detected intros currently. The plugin is also still only a beta, but it already works very well.

Make sure you only have a single browser window open and that auto skip is enabled for the user, the plugin will only take the first web session per user for the auto skip.

Thank you for the explanation, it is now working as design.

Indeed the skip button is not necessary as the auto skip works great, it is just so confusing at the start to see the video jumping itself to the correct position but you quickly get used to it.

Link to comment
Share on other sites

1 minute ago, nSGecko said:

Thank you for the explanation, it is now working as design.

Indeed the skip button is not necessary as the auto skip works great, it is just so confusing at the start to see the video jumping itself to the correct position but you quickly get used to it.

Cool - that's why we opted to have the message advising what had just happened - you can turn this on/off as you wish. 

  • Like 1
Link to comment
Share on other sites

stevehoffman203
12 minutes ago, stevehoffman203 said:

I must have missed the part of enabling auto skip on the user.  I'll check into that.

Thanks!

I must be dumb or something.  I don't see anywhere to enable a user for auto skip.

Link to comment
Share on other sites

Just now, stevehoffman203 said:

I do not.

2022-01-27 10_29_53-stevehoffman.ddns.net - Remote Desktop Connection.jpg

ah ok - What version of the Plugin are you using ?

I think I see the issue - the link on the main page is VERY out of date !

Use this one - you'll need to re-start emby and clear the browser cache..

Sorry !

https://emby.media/community/index.php?/topic/48304-show-intro-skip-option/&do=findComment&comment=1109427

 

Link to comment
Share on other sites

stevehoffman203
8 minutes ago, rbjtech said:

ah ok - What version of the Plugin are you using ?

I think I see the issue - the link on the main page is VERY out of date !

Use this one - you'll need to re-start emby and clear the browser cache..

Sorry !

https://emby.media/community/index.php?/topic/48304-show-intro-skip-option/&do=findComment&comment=1109427

 

That did it!  It's working perfectly now!!!

Thank you so much!!!

  • Like 1
Link to comment
Share on other sites

@stevehoffman203 you may have issues having loaded the old plugin.

Please PM us if you run into problems.

I will go back through the thread and remove all the versions prior to the current release.

Apologies.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...