Jump to content

KayJay
 Share

Recommended Posts

KayJay

Hello everyone.

 

Having some issues with my Emby Server Version 3.2.16.0.

 

I have a Roku that I push all of my media to and just recently the emby app hasn't been working. I've figured out that every time i can not play something i have to come upstairs because my Emby Server app has stopped running and I have to manually start the process again.

 

I've attached the error log file with this that i got from http://localhost:8096/web/log.html - If anyone needs a ny more logs to have a look at please let me know.

 

Emby Log.txt

Link to comment
Share on other sites

Hi, there is no obvious crash here. What do you mean exactly by server stopped running? thanks !

Link to comment
Share on other sites

KayJay

Hi Luke.

 

I mean when I come upstairs and hover over the Emby icon in the system tray, it's there but then it closes.

 

Then I have to manually restart the Emby Server App.

 

I don't know what it is but it's happening probably 6-7 times a day now.

Link to comment
Share on other sites

Can you try removing your installed plugins and see if that makes a difference? thanks !

Link to comment
Share on other sites

  • 3 months later...
RSAvenell

Did you ever figure out why your system was doing this?  Mine is doing the same thing.  When I go to play something on my Roku, it doesn't find the server.  I check my media PC, and Emby shows in the system tray, but then disappears.

 

If I relaunch Emby server, it works again.

 

I don't know when it stops working, usually the next day I try watching something and it happens again.

 

This is pretty recent for me - over the past month.  I didn't notice it doing it before.

 

Thanks.

Link to comment
Share on other sites

Did you ever figure out why your system was doing this?  Mine is doing the same thing.  When I go to play something on my Roku, it doesn't find the server.  I check my media PC, and Emby shows in the system tray, but then disappears.

 

If I relaunch Emby server, it works again.

 

I don't know when it stops working, usually the next day I try watching something and it happens again.

 

This is pretty recent for me - over the past month.  I didn't notice it doing it before.

 

Thanks.

 

Sounds like this:

 

https://emby.media/community/index.php?/topic/49951-roku-77-software-issues/

Link to comment
Share on other sites

Did you ever figure out why your system was doing this?  Mine is doing the same thing.  When I go to play something on my Roku, it doesn't find the server.  I check my media PC, and Emby shows in the system tray, but then disappears.

 

If I relaunch Emby server, it works again.

 

I don't know when it stops working, usually the next day I try watching something and it happens again.

 

This is pretty recent for me - over the past month.  I didn't notice it doing it before.

 

Thanks.

 

The next time you have this situation, before restarting the server, go find your logs and post the latest server log and any log labeled "unhandled...".

 

Instructions here.

Link to comment
Share on other sites

  • 1 month later...
Krikroff

Hum, sounds like my problem, server constantly crashing (web front stops responding after a while, DLNA c'ant see Emby, etc...)

 

In logs seems my sonos devices span the server.

 

see:

2017-10-12 10:22:34.850 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:34.866 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:34.866 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:35.864 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:35.864 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:35.864 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:35.880 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:35.880 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:35.880 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:36.878 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:36.878 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:36.878 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:36.878 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:36.894 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:36.894 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:37.892 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:37.892 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:37.892 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:37.908 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:37.908 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:37.908 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:38.906 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:38.906 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:38.906 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:38.906 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:38.922 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:38.922 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:39.920 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:39.920 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:39.920 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:39.936 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:39.936 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:39.936 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:40.934 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:40.934 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:40.934 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:40.934 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:40.950 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:40.950 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:41.948 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:41.948 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:41.948 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:41.964 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:41.964 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:41.964 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:42.962 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:42.962 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:42.962 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:42.962 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:42.978 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:42.978 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:43.976 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:43.976 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:43.976 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:43.992 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:43.992 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:43.992 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:44.990 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:44.990 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:44.990 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:44.990 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:45.006 Info HttpClient: HttpClientManager POST: http://192.168.1.81:1400/MediaRenderer/AVTransport/Control
2017-10-12 10:22:45.006 Info HttpClient: HttpClientManager POST: http://192.168.1.83:1400/MediaRenderer/AVTransport/Control
Link to comment
Share on other sites

Thanks for the heads up on Roku.. I'll not try..  Amazon Fire effectively subsidizes their units, sells them at near below cost.. you can't argue with that and have "sufficient" processing at the client

Link to comment
Share on other sites

maegibbons

Hi @@Luke,

 

I also try an installation on my ReadyNAS with the same behavior, the server seems to fail regularly...

 

Try not to muddy the waters with this. 

 

The easiest platform for @@Luke to investigate and debug is windows.   Lets deal with your issues on that OS 1st.

 

Emby totally crashing on windows is VERY rare.

 

The last entry in your log was at 14:06:09

 

At what time did you detect that emby was not running and how did you detect it?

 

Krs

 

Mark

Edited by maegibbons
Link to comment
Share on other sites

If you're on windows can you try running the beta installer from the website and let me know if the issue persists? thanks.

Link to comment
Share on other sites

Krikroff
@@maegibbons, thanks for your reply ;)

 

Emby has always been stable on my Windows server, it seems to me that the problems have happened with version 3.1.x

I detect the problem when I want to access my library from a player and the server does not appear in the list, i then  check the dashboard which is unreachable...

 

Nota: Emby runs as a service

 

@@Luke, yes i can ;)

Edited by Krikroff
Link to comment
Share on other sites

maegibbons

Have you tried running it NOT as a service for a while just in case that is causing a problrm in recent builds?

 

Are you running as a service using NSSM or SC?

 

Krs

 

Mark

Link to comment
Share on other sites

Krikroff
Hi,

 

@@Luke, i run Version 3.2.33.11 beta (not as a service) since two days without issues   

 

@@maegibbons, i have configured the windows background service for Emby server from services.msc with automatic start (tried delayed option) and administrator account used.

 

Regards

Link to comment
Share on other sites

Krikroff

Hi,

 

I'm sorry I'm coming back with my problems.

 

Everything works fine with the beta but since I installed the latest stable version (3.2.34.0) i have strange behaviors

 

If I run Emby from the menu and "Run Emby Server" no problem everything works but  it is impossible to launch Emby as a service.

 

Application disposing just after Skia: SkiaSharp version: 1.58.0.0

 

I use NSSM as recommended, tried to remove and re-install service w/o a positive result :(

 

Have you any advices for me ?

 

Attached log file error-server-63644637873.txt

Edited by Krikroff
Link to comment
Share on other sites

Hi,

 

I'm sorry I'm coming back with my problems.

 

Everything works fine with the beta but since I installed the latest stable version (3.2.34.0) i have strange behaviors

 

If I run Emby from the menu and "Run Emby Server" no problem everything works but  it is impossible to launch Emby as a service.

 

Application disposing just after Skia: SkiaSharp version: 1.58.0.0

 

I use NSSM as recommended, tried to remove and re-install service w/o a positive result :(

 

Have you any advices for me ?

 

Attached log file attachicon.giferror-server-63644637873.txt

 

What if you just run it as an app and not as a service, what happens then?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...