Jump to content
Sign in to follow this  
nortok00

Question about cast & Crew thumbnail images

Recommended Posts

nortok00

Hello all,

 

I'm trying to sort out whether this is a general problem with my install or an incompatibility between the image sizing of Emby and the image sizing of the online image db's (themoviedb, etc.).

 

I have a bunch of tv shows where the cast/crew images appear but they appear squished (incorrect aspect ratio). I have my primary db's set that for TV the images come from thetvdb.com and for movies it's themoviedb.org. It appears that thetvdb doesn't support profile/actor images but themoviedb does and this is where Emby is getting the images. The specifications for themoviedb images is with an aspect ratio of 1:1.5 with a maximum resolution of 2000x3000 and the lowest resolution of 500x750. Both are obviously 1:1.5. I had to resize the images to about 180x275 for it to look correct on Emby. This isn't quite 1:1.5 (that would be 180x270. Is there a way to correct Emby for the correct aspect ratio so the images scale properly? I don't want to have to redo images locally. Or am I wrong in this? I checked a bunch of the images on themoviedb and they are 1:1.5 so I don't think it's the size of the images uploaded that's the issue.

Share this post


Link to post
Share on other sites
nortok00

Just looked more closely and thetvdb does have some actor images so that's good.

 

Also, disregard this post. I downloaded a couple of the problem images from themoviedb and they're not 1:1.5 so I guess there is no image moderation going on to make sure they conform to the standard!

 

Apologies for the post.

Share this post


Link to post
Share on other sites
Happy2Play

They must be really old images as you get automated error message if it isn't 1:1.5.  Can you provide a specific example.

Share this post


Link to post
Share on other sites
nortok00

Hi @@Happy2Play. Thanks for the speedy reply.

 

Here is the image that isn't 1:1.5 (unless I'm going crazy in my math): https://www.themoviedb.org/person/54447-samuel-west/images/profiles (376x479). This is the one that Emby pulled and it appeared distorted.

 

Actually one more problem. A lot of the guest actors in my episodes aren't showing (it's for Foyle's War). The only one that showed was the above problem image for Samuel West. They're appearing with just the name in a colored block (screenshot attached). I thought it was because they didn't have profiles but I checked and they do. I then did an "Edit images" on one of them and an image was there. When I backed out of that screen suddenly the image was showing. The example is for Ronald Pickup in the second screenshot attached. He originally just showed a coloured block with his name but after clicking into "Edit images" it's now suddenly showing.

 

Another odd thing is that I lost a guest actor after clicking into it (Edit images). The actor is no longer even showing under Cast & Crew. Not sure what happened. I tried doing a refresh but his name didn't come back.

post-177961-0-37691800-1493160770_thumb.jpg

post-177961-0-86516400-1493160770_thumb.jpg

Share this post


Link to post
Share on other sites
nortok00

Here's another issue. One of the actor's in one of the episodes has a full profile in TMDB but he's not being found in Emby Cast & Crew. The name is John Wood. All I see is his name in a coloured box (screenshot attached). His profile is here: https://www.themoviedb.org/person/8937-john-wood. Having said that there are a lot of John Wood's in the TMDB so even if an exact match can't be found for some reason should I not be able to search (Edit images > search) and be able to pull up a list of all John Wood's in TMDB to choose from? I see nothing when I pull up the search for John Wood. Screenshot attached.

 

Thanks!

post-177961-0-74154200-1493164350_thumb.jpg

post-177961-0-28320000-1493164502_thumb.jpg

Share this post


Link to post
Share on other sites
Happy2Play

The actor has to have a external id to get a image via Edit Image.  So you would have to use Identify and search by name or external id.

Share this post


Link to post
Share on other sites
One2Go

I have in my old directory from MB 2.6 many actors under their name and that is how they were found and displayed in the ImagesByName/People directory. Is there something similar in Emby where people/actors can be manually added and where is it located? I am using Emby for WMC.

 

Thanks

O2G

Share this post


Link to post
Share on other sites
Happy2Play

I have in my old directory from MB 2.6 many actors under their name and that is how they were found and displayed in the ImagesByName/People directory. Is there something similar in Emby where people/actors can be manually added and where is it located? I am using Emby for WMC.

 

Thanks

O2G

 

Emby's People path is C:\Users\username\AppData\Roaming\Emby-Server\metadata\People.  I don't remember is MB 2.6 used character, A-Z subfolders.  If not then you will need to sort all your actors into their perspective subfolder.

 

ImagesByName folder was just merged/renamed Metadata

  • Like 1

Share this post


Link to post
Share on other sites
nortok00

Thanks @@Happy2Play. I guess that was my bad... I thought the "search" feature was the same as Identify. I will try that now that I see you can add a specific ID.

 

The only other question I have (which I posted above with screenshots" is that some of the actors actually have been properly identified but they aren't displaying in the Cast & Crew area. I just happened to click into some of them and there was the image. When I backed out of that view (into the main episode view again where you can see all of the Cast/Crew images) suddenly the image appeared. My example above shows the actor "Ronald Pickup". Emby was only displaying his name in a colored block. I thought maybe he didn't have a profile or his profile wasn't identified so I clicked into the block and there was an image and full bio for him. When I backed out of that screen his image suddenly appeared. This is happening to a lot of the actors. I just went through another episode where only one actor image was showing. I started clicking into all of them (there were 11 actors listed) and I managed to get 5 more to show up after clicking into their blocks.

 

I have provided more screenshots. The first screenshot shows only Anthony Howell's image but when I started clicking into each actor's block some of them display images (see second screenshot of Peter Stark). When I back out of his profile page suddenly his image shows. By the time I finished clicking into all of them I managed to get four more images to appear (see third screenshot). I don't know why these aren't displaying in the first place.

 

The other thing is... some of the actors disappear when I back out of their profile page. For example in the first screenshot you can see "Joe Gallagher" appear (bottom row) but in the third screenshot he's gone. I actually saw his block disappear after I backed out of his profile page.

 

Thanks!

post-177961-0-34736700-1493168729_thumb.jpg

post-177961-0-84099100-1493168729_thumb.jpg

post-177961-0-29259900-1493168730_thumb.jpg

Share this post


Link to post
Share on other sites
One2Go

Emby's People path is C:\Users\username\AppData\Roaming\Emby-Server\metadata\People.  I don't remember is MB 2.6 used character, A-Z subfolders.  If not then you will need to sort all your actors into their perspective subfolder.

 

ImagesByName folder was just merged/renamed Metadata

Thanks this is very helpful.

 

Yes MB 2.6 had each actor/person in their own subfolder. Sometimes you had to correct the folder name because it either had a "period" in there or not.

Share this post


Link to post
Share on other sites
Happy2Play

There has been a big change in people images to not hammer the provider site.  So depending on how you are adding your media and the options you have enable will determine if they are gotten on demand (when you click on them) or when initial metadata is retrieved (ensure you have "Download images in advance" enabled - Dashboard-Library=select each library).

Download images in advance
By default, most images are only downloaded when requested by an Emby app. Enable this option to download all images in advance, as new media is imported. This may cause significantly longer library scans.

I assume you Joe Armstrong, sometimes Emby miss identies or there is something different in the name that it retrieves and it becomes a mismatch in the database so the link gets broken.  So the initial metadata does match the metadata title of the actor Emby is looking for.

 

Sometimes you can do a search in Emby for the actor and look at the metadata and see the issue or you may have to go the actors folder and look at the metadata manually.

Share this post


Link to post
Share on other sites
ebr

Thanks this is very helpful.

 

Yes MB 2.6 had each actor/person in their own subfolder. Sometimes you had to correct the folder name because it either had a "period" in there or not.

 

But 2.6 did not use the A-Z parent folders to which he was referring so  you will need to re-arrange your people like that.

 

e.g.  metadata\people\t\tom cruise

Share this post


Link to post
Share on other sites
One2Go

But 2.6 did not use the A-Z parent folders to which he was referring so you will need to re-arrange your people like that.

 

e.g. metadata\people\t\tom cruise

I noticed that and since I am using Media Matter it did that already and it also explained why some actors did not show up in MB 2.6.

 

Thanks for the tip and saving me time.

Edited by One2Go

Share this post


Link to post
Share on other sites
One2Go

@@ebr Just to double check, the MB 2.6 actors images were named folder.jpg and ion the new version they are named poster.jpg. Will both names be recognized as valid pictures for actors/people?

 

My quick tests says yes they will be displayed but just to be sure to avoid additional downloads and duplicates in the people folders,

 

Thanks

O2G

Share this post


Link to post
Share on other sites
ebr

Yes we will read both but any future ones will only be written as "poster".

Share this post


Link to post
Share on other sites
One2Go

Thanks for the most reassuring message, I have close to 15'000 entries in the people folders and hate to rename all of them even if it could be done easily with some program. Anything newly written will be poster.jpg because that is what the meta data managers create.

Share this post


Link to post
Share on other sites
Luke

If you make changes to the folder directly and not within the web UI, just be aware you need to run the people refresh scheduled task.

Share this post


Link to post
Share on other sites
Happy2Play

Yes we will read both but any future ones will only be written as "poster".

 

Unless you are on "Legacy" <ImageSavingConvention> as I am.

Share this post


Link to post
Share on other sites
One2Go

If you make changes to the folder directly and not within the web UI, just be aware you need to run the people refresh scheduled task.

thanks for alerting me to this. I am indeed merging folders and their people image into the metadata/people folder.

 

How and were do I rub/start the people refresh scheduled task?

 

Thanks,

O2G

Share this post


Link to post
Share on other sites
Happy2Play

thanks for alerting me to this. I am indeed merging folders and their people image into the metadata/people folder.

 

How and were do I rub/start the people refresh scheduled task?

 

Thanks,

O2G

 

Dashboard-Scheduled Tasks

Share this post


Link to post
Share on other sites
One2Go

Thanks for the tip. After searching the forum I believe that this may not be necessary in my case. Here is what my procedure is.

 

Because sources for people images are sometimes not to my liking because of wrong resolution or too large resolution as well as terrible pictures themselves, I almost always check the people images before they get put in the structure. So when I copy people images into the metadata/people folder under their starting letter, it is my understanding that after a manual library scan they will then become available for display is that correct? I also understand that the people refresh scan is like doing a manual refresh of am item with the setting of replacing all metadata rather then finding missing metadata is that correct?

 

Since I most of the time manually update my metadata and all my metadata is current and up to date is there a reason to run the scheduled people refresh task?

 

@@Happy2Play Thanks for your help and assistance it seems that this is your forte and I hope you can provide and help me with this, because I already am spending an exorbitant amount of time to get Emby to the point were I was with MB and I keep telling myself just this last tweak and I am finished. The wife thinks this is never ending project, I am trying to prove her wrong, because happy wife, happy life :D

Edited by One2Go

Share this post


Link to post
Share on other sites
One2Go

Ran the refresh for people on 1050 movies and 145 TV shows with almost 3500 episodes took 41 minutes which makes me think it used the local images already in the people folder. It looks like that people folders that had already images like folder.jpg in them were ignored and that the poster.jpg were from a previous refresh.

 

All in all it seems to be a success, now on to the tweaking.

Share this post


Link to post
Share on other sites
gismo33

Hello, I don't know if that is related to the messages above, but on my emby server there are several actor thumbnails with false ratio aspect if am browsing my movies library in chrome/web browser.

  • I attached two images. First image shows the actor thumbs for one movie. Look at actor "James Earl Jones", this thumb has a false ratio aspect.
  • If I am clicking on the actors image the image now is correct and don't have a false ratio aspect (see image 2).
  • My assumption: The default ratio aspect for actor images is 1:1,5 but there are several "false" ratio aspects on tmdb with 1:1,29 or even lower. For actor "James Earl" this is the case, see TMDB (1800px/1441px = 1:1,25 and not 1:1,5). So I guess the actor's thumbnail view in emby should not change the ratio aspect of images to get 1:1,5 but cropping or zooming to get the ratio aspect of 1:1,5 if the original image is not in that ratio aspect.

 

Thanks 

post-5482-0-00339200-1522515179_thumb.jpeg

post-5482-0-06452900-1522515186_thumb.jpeg

Edited by gismo33

Share this post


Link to post
Share on other sites
Luke

Hi, we'll take a look at this, thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...