Jump to content


Photo

First JPG's were deleted then some of my movies were deleted.

delete movies files

  • Please log in to reply
27 replies to this topic

#21 interman OFFLINE  

interman

    Advanced Member

  • Members
  • 53 posts
  • Local time: 01:20 AM

Posted 12 April 2017 - 11:16 PM

I am sorry, which log. If you mean the first one, then no, I deleted the movie. 

 

If you mean the second log I sent, it is tough to remember but Auto-organize delete is most probably the only action. 



#22 interman OFFLINE  

interman

    Advanced Member

  • Members
  • 53 posts
  • Local time: 01:20 AM

Posted 12 April 2017 - 11:41 PM

More Information. 

 

Luke:

 

for the past 2 days, I was noticing that Auto organizing was not working. All files dropped into the AO directory would be classed as a movie. This afternoon I took a look. Seems that somehow my movies directory got set to the whole drive and the AO directory below that. So all files were picked up by the movie section before the AO section.

 

So, I went in and removed that directory from EMBY (you cannot seem to edit it) and then EMBY said it removed the wrong one. So I removed the second directory and re-added the right directory to EMBY.

 

Then the AO started working perfectly. Correct me if I am wrong, but none of those actions should have deleted any files, in whole or in part? Yes/no?

 

And the files/folders deleted have no rhyme or reason. Some I have watched and some not. Some are new and some old. Some Avi and some Mp4.


Edited by interman, 12 April 2017 - 11:44 PM.


#23 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152703 posts
  • Local time: 02:20 AM

Posted 13 April 2017 - 02:53 PM

I will need to add more logging in order to determine what happened, so I will be doing that with the beta if you want to jump on that and perform the same actions again. Thanks.



#24 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152703 posts
  • Local time: 02:20 AM

Posted 13 April 2017 - 02:54 PM

More Information. 

 

Luke:

 

for the past 2 days, I was noticing that Auto organizing was not working. All files dropped into the AO directory would be classed as a movie. This afternoon I took a look. Seems that somehow my movies directory got set to the whole drive and the AO directory below that. So all files were picked up by the movie section before the AO section.

 

So, I went in and removed that directory from EMBY (you cannot seem to edit it) and then EMBY said it removed the wrong one. So I removed the second directory and re-added the right directory to EMBY.

 

Then the AO started working perfectly. Correct me if I am wrong, but none of those actions should have deleted any files, in whole or in part? Yes/no?

 

And the files/folders deleted have no rhyme or reason. Some I have watched and some not. Some are new and some old. Some Avi and some Mp4.

 

When you use library setup in the server dashboard, this does not do any deleting. If you use the trash on media screens within Emby apps, that will delete.



#25 interman OFFLINE  

interman

    Advanced Member

  • Members
  • 53 posts
  • Local time: 01:20 AM

Posted 13 April 2017 - 03:15 PM

Luke:

 

Completely agree with the logic, however, I deleted one movie with trash can and this was the result. I will be happy to test more, anyway you like. I have been recovering my movies all day from work. When I get home, I will setup a backup and try again. 

 

You said something about a beta. Should I download and install?

Don



#26 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152703 posts
  • Local time: 02:20 AM

Posted 13 April 2017 - 04:20 PM

Yes the download page on our website will have beta links as well. thanks.



#27 interman OFFLINE  

interman

    Advanced Member

  • Members
  • 53 posts
  • Local time: 01:20 AM

Posted 14 April 2017 - 09:13 AM

Luke and EBR have been very helpful in troubleshooting this. 

 

L and E, I will download and install the beta this weekend to see if I can recreate the problem. It was more critacal to recover my files first, and as of today have recovered 300 movies in the 1TB range. Most but not all. 

 

If I can make a suggestion, When this happened, it seemed to delete without the recycle bin. If there is a switch or something in the program that can force ALL file deletions to the recycle bin, I would encourage that. I see the AutoOrganize does, but in this case it did not. 

 

Anyway, I will update this topic when I test again. 

 

Thank you,

 

Don



#28 Luke OFFLINE  

Luke

    System Architect

  • Administrators
  • 152703 posts
  • Local time: 02:20 AM

Posted 14 April 2017 - 12:35 PM

Thanks for the update.







Also tagged with one or more of these keywords: delete, movies, files

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users