Jump to content
interman

First JPG's were deleted then some of my movies were deleted.

Recommended Posts

interman

Ok, this one actually freaked me out a little. 

 

I was watching a movie through Emby. I decided it sucked and deleted it from in the program (trash can). Then I went back to the movie list and all the pictures were gone. When I went to the server, in the directories, all the NFOs and JPGs were deleted. Worst part is that I rebooted everything then told it to scan the directories and it does not update. I am starting to re idendify all the movies. 

 

Any idea why?

 

Also, only the movies. The TV shows are fine and so it the music files.

 

Don

 

Epilogue: a lot of my movie files are gone. Deleted. I think is related. Not sure how or why. 

Edited by interman

Share this post


Link to post
Share on other sites
interman

Pardon me, correct. All the JPG's were deleted. I thought the NFos were gone, but they are still there. However, only by reidentifying each movie can I get the JPG's back.

Edited by interman

Share this post


Link to post
Share on other sites
interman

OK, one more update. I deleted the movie directory from EMBY. Then I added it back. All the movies are updating and re-adding the JPG's, EXCEPT the one or two that I Identified during the break. 

 

Solved for now but still very strange.

 

Don

Share this post


Link to post
Share on other sites
interman

One last update. A good chunk of my movies are gone. I had so many movies that I needed a new hard drive. After this problem, EMBY and file manager says I only have 77 movies left. Somehow a bunch of movies got deleted. 

 

Not sure where they all went but they are gone. 

Don

Share this post


Link to post
Share on other sites
interman

Several things happened on this and I am going to repost this question in another post. 

Share this post


Link to post
Share on other sites
interman

Hello all:

 

It has bee a frustrating few hours, so please bear with me. 

 

I Was watching a movie today. I decided to delete the movie. I cliecked on the Trash Can inside of EMBY and I assumed it deleted. When I returned to the movie list, all of the posters were gone from my movies. I tried restarted the EMBY server, then rebooted the entire PC server to no avail. Then I opened file manager and when I went to the movie directories, all the JPG's were gone. I told EMBY to rescan the library with no luck. So I decided to remove the file folder from EMBY and add it back. Sure enough, all the JPG's were releaded for the movies. 

 

But then I noticed that I only had 77 movies in my library. I had over 300 before this happened. So I opened file manager and sure enough, a good number of mu movies (directory, movie, JPG, and NFO) were gone. I searched for ones I knew I had (like Jack Reacher 1 and 2) and some were missing. 

 

It is a brand new drive. I have done a SMART check. I have run three different virus programs and everything appears normal. My music and Television files are untouched. 

 

At this point, my files are gone. I cannot figure out what I did wrong or why some movies were deleted and some were not, but this seems to be a serious problem. 

 

Can anyone help me troubleshoot this and see why the files were deleted? 

 

Thank you,

Don

Share this post


Link to post
Share on other sites
interman

OK, why was this moved? 

Share this post


Link to post
Share on other sites
ebr

Hi.

 

What app did you use to execute the delete?

 

And, do you have the server log from when you did that?

 

How to Report a Problem

Share this post


Link to post
Share on other sites
ebr

OK, why was this moved? 

 

Because it is a general server issue.  The forum you were in is for questions or issues with Emby Premiere subscriptions.  Thanks.

Share this post


Link to post
Share on other sites
interman

What is Emby premier subscription? I thought that was for people who purchased the product, which I did.

Share this post


Link to post
Share on other sites
interman

I used the EMBY app to delete the file. I Yes, I have the server log. 

Share this post


Link to post
Share on other sites
ebr

What is Emby premier subscription? I thought that was for people who purchased the product, which I did.

 

Emby Premiere is the paid subscription that opens up additional features in the server and apps.

 

We do not limit support for people who have not purchased Premiere.  That forum is for when you are having some sort of issue with your Premiere subscription itself (trouble subscribing or getting your key or have a question about Premiere).

 

This is the best place to get help for the issue you are having.  However, one topic is fine so we can use the other one from here on out.

Share this post


Link to post
Share on other sites
ebr

Which Emby app?  There are about a dozen of them :).

 

(web app, Android TV, iOS, Android Mobile, Apple TV, Roku, ...)

Share this post


Link to post
Share on other sites
interman

I was in CHROME, on my windows 10 PC on my home network, streaming from my server on my home network also running windows 10. 

 

I was playing the movie and I wanted to delete, so I client the left arrow at the top left of the screen to go back to the movie landing page. I then clicked the trash can in just to the roght of the poster. Where is says RESUME< PLAY< TRAILER< THE THREE DOTS, then TRASH CAN< then CHECK IF WATCHED, then FAVORITE.

 

I have many log files from this afternoon, as I rebooted many times trying to fix the missing JPG problem. I can send them all or if you can help me find the one that deleted the file, I will search first. 

Share this post


Link to post
Share on other sites
ebr

If you know what time you did the delete then you can find the proper log via the file timestamp.  If not, then you can search them for the title of the item you deleted.  Thanks.

Share this post


Link to post
Share on other sites
interman

Ok, here is the log file. I was watching Star Trek the roddenberry files. 

 

Time stamp on this is 2017-04-12 18:13:32.8365. I then rebooted the server about 2-3 minutes later to see if I could recover the JPG's (posters and such). The next log file has no "TREK" in it so this has to be the one. 

 

I also included the screenshot where I client the trashcan button, in case it helps. 

 

Please let me know what else I can do to help trouble shoot. I am reading the log file, but some of this is over my head. 

 

Don

 

Sorry if I have a tone. 

 

post-197087-0-32097200-1492043599_thumb.png

server-63627614869.txt

Share this post


Link to post
Share on other sites
interman

I should add one more note.

 

I am sure/100% positive all the JPG's disappeared when I deleted the movie mentioned above.Mainly because there were there before and not there after. 

 

For the movie files, I just noticed them tonight when this happened. They may have been gone for a few days, but were all there last weekend as some of the ones missing were watched. What is funny is which ones are missing. I put two Total Recalls (old and new) into the folder at the same time. One is there and one is missing. Same with Jack Reacher. I Cannot for the life of me, figure out the connection or reason why some are missing. 

 

Don

Share this post


Link to post
Share on other sites
interman

Ok, sorry for the continuous posts.

 

I downloaded EaseUS Data REcovery. I looked and it says that Total Recall 2012 was last accessed on 4/1/2017 3:53pm, but the NFO file was accessed today at 2:03 pm. So the total recall movie had to have been there at 2:03 today. 

 

I am included the log for that time period as well. Maybe there is something in there. 

 

In fact, when I look at the deleted files, All the NFO's have time stamps today at 2:00 pm. (ish). 

 

Unless you tell me otherwise, I am goign to try and recover some of these movies. 

 

Don

 

 

 

 

server-63627552000.txt

Share this post


Link to post
Share on other sites
Luke

Ok, sorry for the continuous posts.

 

I downloaded EaseUS Data REcovery. I looked and it says that Total Recall 2012 was last accessed on 4/1/2017 3:53pm, but the NFO file was accessed today at 2:03 pm. So the total recall movie had to have been there at 2:03 today. 

 

I am included the log for that time period as well. Maybe there is something in there. 

 

In fact, when I look at the deleted files, All the NFO's have time stamps today at 2:00 pm. (ish). 

 

Unless you tell me otherwise, I am goign to try and recover some of these movies. 

 

Don

 

In this particular log it looks like the only deletion you performed was in relation to auto-organize. is that correct?

Share this post


Link to post
Share on other sites
interman

no. i deleted the star trek movie directly. that is when the jpgs disappeared.

Share this post


Link to post
Share on other sites
interman

I am sorry, which log. If you mean the first one, then no, I deleted the movie. 

 

If you mean the second log I sent, it is tough to remember but Auto-organize delete is most probably the only action. 

Share this post


Link to post
Share on other sites
interman

More Information. 

 

Luke:

 

for the past 2 days, I was noticing that Auto organizing was not working. All files dropped into the AO directory would be classed as a movie. This afternoon I took a look. Seems that somehow my movies directory got set to the whole drive and the AO directory below that. So all files were picked up by the movie section before the AO section.

 

So, I went in and removed that directory from EMBY (you cannot seem to edit it) and then EMBY said it removed the wrong one. So I removed the second directory and re-added the right directory to EMBY.

 

Then the AO started working perfectly. Correct me if I am wrong, but none of those actions should have deleted any files, in whole or in part? Yes/no?

 

And the files/folders deleted have no rhyme or reason. Some I have watched and some not. Some are new and some old. Some Avi and some Mp4.

Edited by interman

Share this post


Link to post
Share on other sites
Luke

I will need to add more logging in order to determine what happened, so I will be doing that with the beta if you want to jump on that and perform the same actions again. Thanks.

Share this post


Link to post
Share on other sites
Luke

More Information. 

 

Luke:

 

for the past 2 days, I was noticing that Auto organizing was not working. All files dropped into the AO directory would be classed as a movie. This afternoon I took a look. Seems that somehow my movies directory got set to the whole drive and the AO directory below that. So all files were picked up by the movie section before the AO section.

 

So, I went in and removed that directory from EMBY (you cannot seem to edit it) and then EMBY said it removed the wrong one. So I removed the second directory and re-added the right directory to EMBY.

 

Then the AO started working perfectly. Correct me if I am wrong, but none of those actions should have deleted any files, in whole or in part? Yes/no?

 

And the files/folders deleted have no rhyme or reason. Some I have watched and some not. Some are new and some old. Some Avi and some Mp4.

 

When you use library setup in the server dashboard, this does not do any deleting. If you use the trash on media screens within Emby apps, that will delete.

Share this post


Link to post
Share on other sites
interman

Luke:

 

Completely agree with the logic, however, I deleted one movie with trash can and this was the result. I will be happy to test more, anyway you like. I have been recovering my movies all day from work. When I get home, I will setup a backup and try again. 

 

You said something about a beta. Should I download and install?

Don

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...